Taming Apache OpenOffice
Version 3.4

Getting Started
Copyright
This document is Copyright © 2013 by Jean Hollis Weber. You may distribute it and/or modify it under the terms of the Creative Commons Attribution License, version 3.0 or later (http://creativecommons.org/licenses/by/3.0/).
Apache, Apache OpenOffice, and OpenOffice.org are trademarks of the Apache Software Foundation. Used with permission. No endorsement by The Apache Software Foundation is implied by the use of these marks. All other trademarks mentioned in this guide belong to their respective owners.

Acknowledgements
This book is based on an earlier draft written by volunteers from the ODFAuthors and Apache OpenOffice communities, and on Getting Started with OpenOffice.org 3.3, with additional material adapted from Getting Started with LibreOffice 3.4. The contributors to those books are listed on page 14.

Publication date and software version
Published 10 May 2013. Based on Apache OpenOffice 3.4.1.

Publisher
Friends of OpenDocument, Inc.
544/60 Beck Drive North
Condon, QLD 4815, Australia
http://friendsofopendocument.com/
# Contents

**Preface**............................................................................................................................................ 9  
Who is this book for?............................................................................................................................... 9  
What's in this book?................................................................................................................................. 9  
Where to get more help.......................................................................................................................... 9  
What's new in Apache OpenOffice 3.4?................................................................................................. 10  
What are the advantages of Apache OpenOffice?.................................................................................. 11  
What you see may be different.............................................................................................................. 11  
Using Apache OpenOffice on a Mac...................................................................................................... 12  
Frequently asked questions..................................................................................................................... 12  
What are all these things called?........................................................................................................... 13  
Acknowledgements................................................................................................................................ 14  

**Chapter 1**  
**Introducing Apache OpenOffice**.................................................................................................. 15  
What is Apache OpenOffice?................................................................................................................ 15  
Minimum requirements........................................................................................................................... 16  
How to get and install the software...................................................................................................... 16  
Extensions and add-ons.......................................................................................................................... 16  
Starting Apache OpenOffice.................................................................................................................. 17  
Parts of the main window....................................................................................................................... 18  
Starting a new document....................................................................................................................... 23  
Opening an existing document.............................................................................................................. 23  
Saving a document................................................................................................................................. 24  
Closing a document............................................................................................................................... 25  
Closing Apache OpenOffice.................................................................................................................. 26  
Using the Open and Save As dialogs..................................................................................................... 26  
Using the Navigator.................................................................................................................................. 27  
Undoing and redoing changes.............................................................................................................. 28  

**Chapter 2**  
**Using Styles and Templates**........................................................................................................ 31  
What is a template?................................................................................................................................. 31  
What are styles?....................................................................................................................................... 31  
Applying styles....................................................................................................................................... 32  
Modifying styles.................................................................................................................................... 34  
Creating new (custom) styles................................................................................................................. 36  
Copying and moving styles..................................................................................................................... 37  
Deleting styles....................................................................................................................................... 39  
Using a template to create a document................................................................................................. 39  
Creating a template............................................................................................................................... 40  
Editing a template.................................................................................................................................... 42  
Adding templates using the Extension Manager.................................................................................. 43  
Setting a default template...................................................................................................................... 44  
Associating a document with a different template............................................................................... 44  
Organizing templates............................................................................................................................ 45
# Examples of style use

---

## Chapter 3
### Getting Started with Writer

- What is Writer? .......................................................... 49
- The Writer interface .................................................. 49
- Changing document views ........................................... 52
- Moving quickly through a document ......................... 52
- Working with documents .......................................... 53
- Working with text .................................................... 54
- Formatting text ....................................................... 62
- Formatting pages .................................................... 66
- Adding comments to a document ............................... 70
- Creating a table of contents ...................................... 71
- Creating indexes and bibliographies .......................... 71
- Adding images and other graphics .............................. 72
- Adding tables, spreadsheets, and charts .................... 72
- Adding a movie or sound ......................................... 73
- Printing ................................................................. 74
- Using mail merge ................................................... 74
- Tracking changes to a document .............................. 74
- Using fields .......................................................... 75
- Linking to another part of a document ....................... 75
- Using master documents ......................................... 78
- Creating fill-in forms .............................................. 78

## Chapter 4
### Getting Started with Calc

- What is Calc? ........................................................ 79
- Spreadsheets, sheets and cells .................................. 79
- Parts of the main Calc window ................................ 79
- Opening and saving CSV files ................................ 82
- Navigating within spreadsheets ................................. 84
- Selecting items in a sheet or spreadsheet ................... 88
- Working with columns and rows ............................... 90
- Working with sheets .............................................. 91
- Viewing Calc ........................................................ 93
- Entering data using the keyboard ............................. 96
- Speeding up data entry .......................................... 98
- Validating cell contents ........................................ 101
- Editing data ......................................................... 101
- Formatting data .................................................... 102
- Autoformatting cells and sheets ............................. 106
- Formatting spreadsheets using themes ...................... 107
- Using conditional formatting .................................. 108
- Hiding and showing data ....................................... 108
- Sorting records .................................................... 109
Using formulas and functions................................................................. 110
Analyzing data.................................................................................. 110
Printing.............................................................................................. 111

Chapter 5
Getting Started with Impress................................................................. 119
What is Impress?................................................................................ 119
Starting Impress................................................................................ 119
The main Impress window.................................................................. 120
Workspace views............................................................................... 124
Creating a new presentation............................................................... 128
Formatting a presentation................................................................. 130
Adding and formatting text............................................................... 134
Adding pictures, tables, charts, media files, and other objects............ 138
Working with master pages and styles............................................... 141
Adding comments to a presentation.................................................. 146
Setting up the slide show.................................................................... 147
Running a slide show......................................................................... 148

Chapter 6
Getting Started with Draw................................................................. 149
What is Draw?.................................................................................... 149
Parts of the main Draw window........................................................ 149
Choosing and defining colors............................................................. 152
Positioning objects with snap functions........................................... 153
Positioning objects with guiding lines................................................. 155
The basic drawing shapes................................................................... 155
Drawing geometric shapes............................................................... 160
Selecting objects............................................................................... 161
Moving and dynamically adjusting an object's size......................... 163
Editing objects................................................................................. 164
Using styles....................................................................................... 166
Special effects................................................................................... 166
Combining multiple objects............................................................... 169
Aids for positioning objects............................................................... 170
Inserting and editing pictures............................................................ 170
Working with 3D objects................................................................. 170
Exporting graphics........................................................................... 171
Adding comments to a drawing......................................................... 171

Chapter 7
Getting Started with Base................................................................. 173
Introduction....................................................................................... 173
Planning a database........................................................................ 174
Creating a new database.................................................................. 175
Creating database tables.................................................................. 176
Defining relationships...................................................................... 183
Creating a database form................................................................. 185
Accessing other data sources................................................................. 199
Using data sources in Apache OpenOffice........................................ 199
Entering data in a form........................................................................ 203
Creating queries................................................................................. 205
Creating reports................................................................................ 213

Chapter 8
Getting Started with Math..................................................................... 221
What is Math?...................................................................................... 221
Getting started.................................................................................... 221
Entering a formula.............................................................................. 221
Customizations.................................................................................... 227
Formula layout.................................................................................... 229
Numbering equations.......................................................................... 231

Chapter 9
Printing, Exporting, and E-mailing......................................................... 233
Introduction....................................................................................... 233
Quick printing.................................................................................... 233
Controlling printing........................................................................... 233
Exporting to PDF............................................................................... 242
Exporting to other formats............................................................... 248
E-mailing documents......................................................................... 248
Digital signing of documents............................................................. 252
Removing personal data..................................................................... 252

Chapter 10
Graphics, the Gallery, and Fontwork.................................................... 253
Introduction....................................................................................... 253
Adding images to a document............................................................ 253
Modifying and positioning graphics.................................................... 257
Managing the Gallery......................................................................... 257
Creating an image map....................................................................... 260
Using Apache OpenOffice’s drawing tools........................................ 261
Using Fontwork............................................................................... 263

Chapter 11
Setting Up and Customizing Apache OpenOffice............................... 269
Choosing options for all of Apache OpenOffice................................. 269
Choosing options for loading and saving documents......................... 282
Choosing language settings............................................................... 287
Choosing Internet options................................................................ 289
Controlling AOO’s AutoCorrect functions......................................... 289
Customizing Apache OpenOffice....................................................... 290
Adding functionality with extensions.................................................. 299

Chapter 12
Open Source, Open Standards, OpenDocument.................................. 303
Introduction....................................................................................... 303
A short history of Apache OpenOffice.............................................. 303
Preface

Who is this book for?
Anyone who wants to get up to speed quickly with Apache OpenOffice will find this book valuable. You may be new to office software, or you may be familiar with another office suite.

What's in this book?
This book introduces the main components of Apache OpenOffice:

- Writer (word processing)
- Calc (spreadsheets)
- Impress (presentations)
- Draw (vector graphics)
- Base (database)
- Math (equation editor)

It also covers some of the features common to all components, including setup and customization, styles and templates, and printing. For more detail, see the user guides for the individual components.

Where to get more help
This book, the other Apache OpenOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system
Apache OpenOffice comes with an extensive Help system. This is your first line of support for using the program.

To display the full Help system, press F1 or select OpenOffice.org Help from the Help menu. In addition, you can choose whether to activate Tips, Extended tips, and the Help Agent (using Tools > Options > OpenOffice.org > General).

If Tips are enabled, place the mouse pointer over any of the icons to see a small box ("tooltip") with a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's This? and hold the pointer over the icon.

Free online support
The Apache OpenOffice community not only develops software, but provides free, volunteer-based support. See this web page: http://support.openoffice.org/index.html

Users can get comprehensive online support from the community through mailing lists. Other websites run by users also offer free tips and tutorials. This forum provides community support for Apache OpenOffice and other programs: http://forum.openoffice.org/en/forum/

Paid support and training
Alternatively, you can pay for support services. Service contracts can be purchased from a vendor or consulting firm specializing in Apache OpenOffice.
What’s new in Apache OpenOffice 3.4?

This section summarizes some of the changes since OpenOffice.org 3.3. For details, see the Release Notes for Apache OpenOffice 3.4 and 3.4.1:
http://www.openoffice.org/development/releases/3.4.0.html
http://www.openoffice.org/development/releases/3.4.1.html

• Faster startup
• Support for Scalable Vector Graphics (SVG)
• Enhanced RTF export
• Reduced PDF file size
• Improved ODF 1.2 encryption support
• Improved navigation in Styles and Formatting, Navigator, and options dialogs
• New regular expressions (regexp) engine
• New Color Picker dialog
• Enhanced or additional graphics support (in addition to SVG):
  – Support for Line Cap property for thick lines and 3D objects
  – Support for shear transformations for graphic objects in Draw/Impress and Calc
  – Support for attributes and transformations for OLE objects in Draw/Impress and Calc
  – Enhanced crop support and mirroring for graphical objects
• Calc:
  – DataPilot renamed Pivot Table and no longer limited in the number of fields supported
  – Improved CSV export; new CSV export option, Quote all text cells
  – Support for new conditional functions from ODF 1.2
  – New, faster Linear Programming solver
• Chart:
  – Legend within a chart is now resizable
  – Data axid now available for category charts
  – Time axis now supported
  – Enhanced chart visualization
• Math:
  – Option to save only used symbols for each formula
  – Option to use automatic baseline for Math objects in Writer documents
  – Symbol catalog now supports UTF-32 characters
• Draw/Impress:
  – Better defaults for snap, grid settings, bullet spacing, and indentation
  – Changed default for "copy when moving"
  – Animate outline shapes “By 1st level paragraphs” as default
  – New default colors of drawing objects
  – Setting default shadow distance for shapes
  – Enhancement to the "mouse as pen" feature in impress slideshow
  – Default full width for text in shapes
  – Change outline default bullet symbol order
  – Shortcut for inserting comments changed
  – Set pixel resolution when exporting graphics
• Writer: Asian Language Word Count now correct
What are the advantages of Apache OpenOffice?

Here are some of the advantages of Apache OpenOffice over proprietary office suites:

- **No licensing fees.** Apache OpenOffice is free for anyone to use and distribute at no cost. There are no hidden charges now or in the future.
- **Open source.** You can distribute, copy, and modify the software as much as you wish, in accordance with the Apache 2 license.
- **Cross-platform.** Apache OpenOffice runs on several hardware architectures and under multiple operating systems, such as Microsoft Windows, Mac OS X, and Linux.
- **Extensive language support.** The user interface for Apache OpenOffice is available in several languages, and more are being added. Apache OpenOffice also supports bi-directional text and complex text layout for many scripts.
- **Consistent user interface.** All the components have a similar “look and feel,” making them easy to use and master.
- **Integration.** The components of Apache OpenOffice are well integrated with one another.
  - All the components share a common spelling checker and other tools, which are used consistently across the suite. For example, the drawing tools available in Writer are also found in Calc, with similar but enhanced versions in Impress and Draw.
  - You do not need to know which application was used to create a particular file. For example, you can open a Draw file from Writer.
- **Granularity.** Usually, if you change an option, it affects all components. However, Apache OpenOffice options can be set at a component level or even document level.
- **File compatibility.** In addition to its native OpenDocument formats, Apache OpenOffice includes PDF and Flash export capabilities, as well as support for opening and saving files in many common formats including Microsoft Office, HTML, XML, WordPerfect, and Lotus 1-2-3 formats. An extension provides the ability to import and edit some PDF files.
- **No vendor lock-in.** Apache OpenOffice uses OpenDocument, an XML (eXtensible Markup Language) file format developed as an industry standard by OASIS (Organization for the Advancement of Structured Information Standards). These files can easily be unzipped and read by any text editor, and their framework is open and published.
- **You have a voice.** Enhancements, software fixes, and release dates are community-driven. You can join the community and affect the course of the product you use.

You can read more about Apache OpenOffice, its mission, history, licensing, and other organizational information on the Apache OpenOffice website, http://www.openoffice.org/.

What you see may be different

Apache OpenOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers).

The pictures in this book were taken from a variety of computers and operating systems. Some pictures will therefore not look exactly like what you see on your computer.
Using Apache OpenOffice on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this book. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>OpenOffice.org &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>⌃+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Frequently asked questions

**How is Apache OpenOffice licensed?**
Apache OpenOffice is distributed under the Apache License, Version 2.0, [http://www.apache.org/licenses/LICENSE-2.0.html](http://www.apache.org/licenses/LICENSE-2.0.html).

**May I distribute Apache OpenOffice to anyone?**
Yes.

**How many computers may I install it on?**
As many as you like.

**May I sell it?**
Yes.

**May I use Apache OpenOffice in my business?**
Yes.

**I am writing a software application. May I use programming code from Apache OpenOffice in my program?**
You may, within the parameters set in the Apache 2.0 license (see above).

**Why do I need Java to run Apache OpenOffice? Is it written in Java?**
Apache OpenOffice is not written in Java; it is written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JDK/JRE is only required for some features. The most notable one is the HSQLDB relational database engine.

Note: Java is available at no cost. If you do not want to use Java, you can still use nearly all of the features of Apache OpenOffice.
What are all these things called?

The terms used in Apache OpenOffice for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls for you to use to specify how to carry out an action. The technical names for common controls are shown in Figure 1; not shown is the list box (from which you select an item). In most cases we do not use the technical terms in this book, but it is useful to know them because the Help and other sources of information often use them.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and your document. An example of this type is the Find & Replace dialog.

Figure 1: Dialog showing common controls:
1 = Tabbed page (not strictly speaking a control)
2 = Radio buttons (only one can be selected at a time)
3 = Checkbox (more than one can be selected at a time)
4 = Spin box (click the up and down arrows to change the number shown in the text box next to it, or type in the text box)
5 = Thumbnail or preview
6 = Drop-down list from which to select an item
7 = Push buttons
# Acknowledgements

This book is adapted from *Getting Started with OpenOffice.org 3.3*, with additional material adapted from *Getting Started with LibreOffice 3.4*. The contributors to those books are:

**OpenOffice.org**

<table>
<thead>
<tr>
<th>Jean Hollis Weber</th>
<th>Michele Zarri</th>
<th>Magnus Adielsson</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thomas Astleitner</td>
<td>Richard Barnes</td>
<td>Agnes Belzunce</td>
</tr>
<tr>
<td>Chris Bonde</td>
<td>Nicole Cairns</td>
<td>Daniel Carrera</td>
</tr>
<tr>
<td>JiHui Choi</td>
<td>Richard Detwiler</td>
<td>Alexander Noël Dunne</td>
</tr>
<tr>
<td>Laurent Duperval</td>
<td>Spencer E. Harpe</td>
<td>Regina Henschel</td>
</tr>
<tr>
<td>Peter Hillier-Brook</td>
<td>Richard Holt</td>
<td>John Kane</td>
</tr>
<tr>
<td>Rachel Karch</td>
<td>Stefan A. Keel</td>
<td>Jared Kobos</td>
</tr>
<tr>
<td>Michael Kotsarinis</td>
<td>Peter Kupfer</td>
<td>Ian Laurenson</td>
</tr>
<tr>
<td>Dan Lewis</td>
<td>Alan Madden</td>
<td>Michel Pinquier</td>
</tr>
<tr>
<td>Andrew Pitonyak</td>
<td>Carol Roberts</td>
<td>Iain Roberts</td>
</tr>
<tr>
<td>Hazel Russman</td>
<td>Gary Schnabl</td>
<td>Robert Scott</td>
</tr>
<tr>
<td>Joe Sellman</td>
<td>Janet Swisher</td>
<td>Jim Taylor</td>
</tr>
<tr>
<td>Alex Thurgood</td>
<td>Barbara M. Tobias</td>
<td>Claire Wood</td>
</tr>
<tr>
<td>Linda Worthington</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**LibreOffice:**

<table>
<thead>
<tr>
<th>Ron Faile Jr.</th>
<th>Jeremy Cartwright</th>
<th>Jean Hollis Weber</th>
</tr>
</thead>
<tbody>
<tr>
<td>Martin Fox</td>
<td>Andrew Pitonyak</td>
<td>Hazel Russman</td>
</tr>
<tr>
<td>John A Smith</td>
<td>David Michel</td>
<td>Peter Schofield</td>
</tr>
<tr>
<td>Dan Lewis</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Kevin A. McKenna contributed further editing and review of an earlier draft of this book.
Chapter 1
Introducing Apache OpenOffice

What is Apache OpenOffice?
Apache OpenOffice (OpenOffice.org) is a freely available, full-featured office productivity suite. Its native file format is OpenDocument, an open standard format that is being adopted by governments worldwide as a required file format for publishing and accepting documents. Apache OpenOffice can also open and save documents in many other formats, including those used by several versions of Microsoft Office.

Note
Apache OpenOffice 3.4 installs as OpenOffice.org 3.4. Therefore, icons, window title bars, options in dialogs, and other places show the name OpenOffice.org.

Apache OpenOffice includes the following components.

**Writer (word processor)**
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other documents. You can insert graphics and objects from other components into Writer documents. Writer can export files to HTML, XHTML, XML, Adobe’s Portable Document Format (PDF), and several versions of Microsoft Word files.

**Calc (spreadsheet)**
Calc has all of the advanced analysis, charting, and decision-making features expected from a high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2-D and 3-D charts, which can be integrated into other Apache OpenOffice documents. You can also open and work with Microsoft Excel workbooks and save them in Excel format. Calc can export spreadsheets to Adobe’s PDF and to HTML.

**Impress (presentations)**
Impress provides all the common multimedia presentation tools, such as special effects, animation, and drawing tools. It is integrated with the advanced graphics capabilities of Apache OpenOffice’s Draw and Math components. Slide shows can be further enhanced with Fontwork’s special effects text, as well as sound and video clips. Impress is compatible with Microsoft’s PowerPoint file format and can also save your work in numerous graphics formats, including Macromedia Flash (SWF).
Draw (vector graphics)

Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 3-D artwork. Its Smart Connectors feature allows you to define your own connection points. You can use Draw to create drawings for use in any of Apache OpenOffice’s other components, and you can create your own clip art and add it to the Gallery. Draw can import graphics from many common formats and save them in over 20 formats, including PNG, HTML, PDF, and Flash.

Base (database)

Base provides tools for day-to-day database work within a simple interface. It can create and edit forms, reports, queries, tables, views, and relations, so that managing a connected database is much the same as in other popular database applications. Base provides many new features, such as the ability to analyze and edit relationships from a diagram view. Base incorporates HSQLDB as its default relational database engine. It can also use dBASE, Microsoft Access, MySQL, or Oracle, or any ODBC-compliant or JDBC-compliant database. Base also provides support for a subset of ANSI-92 SQL.

Math (formula editor)

Math is Apache OpenOffice’s formula or equation editor. You can use it to create complex equations that include symbols or characters not available in standard font sets. While it is most commonly used to create formulas in other documents, such as Writer and Impress files, Math can also work as a standalone tool. You can save formulas in the standard Mathematical Markup Language (MathML) format for inclusion in web pages and other documents not created by Apache OpenOffice.

Minimum requirements

Apache OpenOffice 3.4 requires one of the following operating systems:

- **Microsoft Windows** XP, 2003, Vista, 7, or 8
- **GNU/Linux** Kernel version 2.6 and glibc 2.11.1 or higher
- **Mac OS X** 10.4 (Tiger) or higher

Some features (wizards and the HSQLDB database engine) require that the Java Runtime Environment (JRE) 1.5.x or higher be installed on your computer. Although Apache OpenOffice will work without Java support, some features will not be available.

How to get and install the software

You can download the installation package (approximately 150MB) from the project’s website, www.openoffice.org/.

To install Apache OpenOffice, follow the same procedure that you use to install other software.

Extensions and add-ons

Extensions and add-ons to enhance Apache OpenOffice are collected in the official extensions repository, http://extensions.services.openoffice.org/. Most are free, but some are not. See Chapter 11 (Setting up and Customizing Apache OpenOffice) for more information.
Starting Apache OpenOffice

The most common ways to start Apache OpenOffice are:

- Using the system menu, the standard menu from which most applications are started. On Windows, it is called the Start menu. On Mac OS X, it is the Applications menu. On GNOME, it is called the Applications menu. On KDE it is identified by the KDE logo.

  When Apache OpenOffice was installed on your computer, in most cases a menu entry for each component was added to your system menu. If you see only one icon, it opens the Start Center (Figure 11), from which the components can be started. The exact name and location of these menu entries depend on the operating system and graphical user interface.

- From an icon on the desktop or (on a Mac) the Launchpad.

Starting from an existing document

You can start Apache OpenOffice by double-clicking on the filename of a document with an OpenDocument extension such as .odt, .ods, .odp in a file manager such as Windows Explorer, Finder on the Mac, or Nautilus on Linux. The appropriate component will start and the document will be loaded.

Note for Windows users

If you have associated Microsoft Office file types with Apache OpenOffice, then when you double-click on a *.doc (Word) file, it opens in Writer; *.xls (Excel) files open in Calc, and *.ppt (PowerPoint) files open in Impress.

If you did not associate the file types, then when you double-click on a Microsoft Word document, it opens in Microsoft Word (if Word is installed on your computer), Excel files open in Excel, and PowerPoint files open in PowerPoint.

You can use another method to open Microsoft Office files in Apache OpenOffice and save in those formats from Apache OpenOffice. See “Opening an existing document” on page 23 for more information.

Using the Quickstarter under Windows

The Quickstarter is an icon that is placed in the Windows system tray during system startup. It indicates that Apache OpenOffice has been loaded and is ready to use. (The Quickstarter loads library *.dll files required by Apache OpenOffice, thus shortening the startup time for Apache OpenOffice components by about half.) If the Quickstarter is disabled, see “Reactivating the Quickstarter” if you want to enable it.

Using the Quickstarter icon

Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 2) from which you can open a new document, open the Templates and Documents dialog, or choose an existing document to open. You can also double-click the Quickstarter icon to display the Templates and Documents dialog.
Disabling the Quickstarter

To close the Quickstarter, right-click on the icon in the system tray, and then click Exit Quickstarter on the pop-up menu. The next time the computer is restarted, the Quickstarter will be loaded again.

To prevent Apache OpenOffice from loading during system startup, deselect the Load OpenOffice.org during system start-up item on the pop-up menu. You might want to do this if your computer has insufficient memory, for example.

Reactivating the Quickstarter

If the Quickstarter has been disabled, you can reactivate it by selecting the Load OpenOffice.org during system start-up checkbox in Tools > Options > OpenOffice.org > Memory.

Using the Quickstarter in Linux and Mac OS X

Apache OpenOffice under Linux has a Quickstarter that looks and acts like the one described above for Windows. (The checkbox on the Memory page is labeled Enable systray quickstarter. If you do not have this checkbox, the Quickstarter module is not installed on your system.)

Mac OS X provides similar functionality through a pop-up menu from the dock.

Parts of the main window

The main window is similar in each component of Apache OpenOffice, although some details vary. See the chapters in this book about Writer, Calc, Draw, and Impress for descriptions of those details.

Common features include the menu bar, the standard toolbar, and the formatting toolbar at the top of the window and the status bar at the bottom.
Menu bar

The Menu bar is located across the top of the Apache OpenOffice window, just below the Title bar. (On a Mac it is at the top of the screen in the same location as the menu bar for other programs.) When you choose one of the menus listed below, a submenu drops down to show commands.

- **File** contains commands that apply to the entire document such as Open, Save, and Export as PDF.
- **Edit** contains commands for editing the document such as Undo: xxx (where xxx is the command to undo) and Find & Replace. It also contains commands to cut, copy, and paste selected parts of your document.
- **View** contains commands for controlling the display of the document such as Zoom and Web Layout.
- **Insert** contains commands for inserting elements into your document such as Header, Footer, and Picture.
- **Format** contains commands, such as Styles and Formatting and AutoCorrect, for formatting the layout of your document.
- **Table** shows all commands to insert and edit a table in a text document.
- **Tools** contains functions such as Spelling and Grammar, Customize, and Options.
- **Window** contains commands for the display window.
- **Help** contains links to the OpenOffice.org Help file, What's This?, and information about the program.

Toolbars

Apache OpenOffice has several types of toolbars: docked, floating, and tear-off. Docked toolbars can be moved to different locations or made to float, and floating toolbars can be docked.

The top docked toolbar is called the **Standard toolbar**. The Standard toolbar is consistent across the OpenOffice.org applications.

The second toolbar at the top is the **Formatting toolbar**. It is a context-sensitive bar that shows the relevant tools in response to the cursor’s current position or selection. For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting text.

### Displaying or hiding toolbars

To display or hide toolbars, choose **View > Toolbars**, then click on the name of a toolbar in the list. An active toolbar shows a checkmark beside its name. Tear-off toolbars are not listed in the View menu.

### Submenus and tear-off toolbars

Toolbar icons with a small triangle to the right will display submenus, tear-off toolbars, and other ways of selecting things, depending on the icon.

Figure 3 shows a tear-off toolbar from the Drawing toolbar.

The tear-off toolbars can be floating or docked along an edge of the screen or in one of the existing toolbar areas. To move a floating tear-off toolbar, drag it by the title bar. See “Moving toolbars” below.
Apache OpenOffice includes several additional context-sensitive toolbars, whose defaults appear as floating toolbars in response to the cursor’s current position or selection. For example, when the cursor is in a table, a floating Table toolbar appears, and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears. You can dock these toolbars to the top, bottom, or side of the window, if you wish (see "Moving toolbars" below).

Moving toolbars

To move a docked toolbar, place the mouse pointer over the toolbar handle (the small vertical bar to the left of the toolbar), hold down the left mouse button, drag the toolbar to the new location, and then release the mouse button (Figure 4). To move a floating toolbar, click on its title bar and drag it to a new location (Figure 5).

Docking/floating windows and toolbars

Toolbars and some windows, such as the Navigator and the Styles and Formatting window, are dockable. You can move, resize, or dock them to an edge.
To dock a window or toolbar, hold down the Control key and double-click on the frame of the floating window (or in a vacant area near the icons at the top of the floating window) to dock it in its last position.

![Control+click to dock or undock](image)

To undock a window, hold down the Control key and double-click on the frame (or a vacant area near the icons at the top) of the docked window.

**Customizing toolbars**

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar. You can also add icons and create new toolbars, as described in Chapter 11.

To access a toolbar’s customization options, use the down-arrow at the end of the toolbar or on its title bar.

![Toolbar customization icons](image)

To show or hide icons defined for the selected toolbar, choose Visible Buttons from the drop-down menu. Visible icons are indicated by an outline around the icon. Click on icons to hide or show them on the toolbar.

![Selection of visible toolbar icons](image)

**Right-click (context) menus**

You can quickly access many menu functions by right-clicking on a paragraph, graphic, or other object. A context menu will pop up. Often the context menu is the fastest and an easier way to reach a function. If you are not sure where a function is located in the menus or toolbars, you can often find it by right-clicking.
**Status bar**

The status bar is located at the bottom of the workspace. It provides information about the document and convenient ways to quickly change some features. It is similar in Writer, Calc, Impress, and Draw, although each component includes some component-specific items.

![Figure 9: Left end of status bar in Writer](image)

![Figure 10: Right end of status bar in Writer](image)

Common status bar items are described below.

**Page, sheet, or slide number**

Shows the current page, sheet, or slide number and the total number of pages, sheets, or slides in the document. Double-click on this field to open the Navigator. Other uses of this field depend on the component.

**Page style or slide design**

Shows the current page style or slide design. To edit the current page style or slide design, double-click on this field.

**Unsaved changes**

An asterisk (*) appears here if changes to the document have not been saved.

**Digital signature**

If the document has been digitally signed, an icon shows here. You can double-click the icon to view the certificate.

**Object information**

Displays information relevant to the cursor’s position or the selected element of the document. Double-clicking in this area usually opens a relevant dialog.

**Zoom slider and percent**

To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Double-clicking on the zoom level percent opens the **Zoom & View Layout** dialog.
Starting a new document

You can start a new, blank document in Apache OpenOffice in several ways.

When Apache OpenOffice is open but no document is open (for example if you close all the open documents but leave the program running), the Start Center is shown. Click one of the icons to open a new document of that type, or click the Templates icon to start a new document using a template.

![Apache OpenOffice Start Center](image)

*Figure 11: Apache OpenOffice Start Center*

You can also start a new document in one of the following ways.

- Use **File > New** and choose the type of document.
- Use the arrow next to the **New** button on the main toolbar. From the drop-down menu, select the type of document to be created.
- Press **Control+N** on the keyboard.
- Use **File > Wizards** for some special types of documents.

If a document is already open in Apache OpenOffice, the new document opens in a new window.

Opening an existing document

When no document is open, the Start Center provides an icon for opening an existing document or choosing from a list of recently-edited documents.
You can also open an existing document in one of the following ways.

- Choose **File > Open**.
- Click the **Open** button on the main toolbar.
- Press **Control+O** on the keyboard.

In each case, the Open dialog appears. Select the file you want, and then click **Open**. If a document is already open in Apache OpenOffice, the second document opens in a new window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for. For example, if you choose **Text documents** as the file type, you will only see documents Writer can open (including .odt, .doc, .txt); if you choose **Spreadsheets**, you will see .ods, .xls, and other files that Calc opens.

You can also open an existing document that is in an OpenDocument format by double-clicking on the file’s icon on the desktop or in a file manager such as Windows Explorer.

If you have associated Microsoft Office file formats with Apache OpenOffice, you can also open these files by double-clicking on them.

### Saving a document

To save a new document, do one of the following:

- Press **Control+S**.
- Choose **File > Save** from the menu bar.
- Click the **Save** button on the main toolbar.

When the Save As dialog appears, enter the file name, verify the file type (if applicable), and click **Save**.

To save an open document with the current file name, choose **File > Save**. This will overwrite the last saved state of the file.

### Password protection

To protect an entire document from being viewable without a password, use the option on the Save As dialog to enter a password.

1) On the Save As dialog, select the **Save with password** option, and then click **Save**. You will receive a prompt (Figure 12).

2) Type the same password in both fields, and then click **OK**. If the passwords match, the document is saved password protected. If the passwords do not match, you receive an error message. Close the message box to return to the Set Password dialog and enter the password again.

### Caution

Apache OpenOffice uses a very strong encryption mechanism that makes it almost impossible to recover the contents of a document if you lose the password.
Writer and Calc provide a second level of protection, which allows a file to be viewed but not changed without a password; that is, the file opens in read-only mode.

To protect a document from being changed:

1) Choose More Options from the Set Password dialog.
2) Enter the password in the Enter password to allow editing field. Repeat the password in the Confirm password field. Click OK.

**Saving a document automatically**

You can choose to have Apache OpenOffice save files for you automatically. Automatic saving, like manual saving, overwrites the last saved state of the file. To set up automatic file saving:

1) Choose Tools > Options > Load/Save > General.
2) Mark Save AutoRecovery information every, and set the time interval.

**Closing a document**

To close a document, choose File > Close.

You can also close a document by clicking on the Close icon on the document window. This button may look like the X shown in Figure 13. It may be in a different location on your operating system.

**Figure 13. Close icons**

In Windows and Linux, if more than one OpenOffice.org window is open, each window looks like the sample shown on the left in Figure 13. Closing this window leaves the other OpenOffice.org windows open.

If only one OpenOffice.org window is open, it looks like the sample shown on the right in Figure 13. Notice the small X below the large X. Clicking the small X closes the document but leaves OpenOffice.org open. Clicking the large X closes Apache OpenOffice completely.
If the document has not been saved since the last change, a message box is displayed. Choose whether to save or discard your changes.

- **Save**: The document is saved and then closed.
- **Discard**: The document is closed, and all modifications since the last save are lost.
- **Cancel**: Nothing happens, and you return to the document.

**Caution**

Not saving your document could result in the loss of recently made changes, or worse still, your entire file.

---

**Closing Apache OpenOffice**

To close Apache OpenOffice completely, choose **File > Exit**, or close the last open document as described in “Closing a document” above.

If all the documents have been saved, Apache OpenOffice closes immediately. If any documents have been modified but not saved, a warning message appears. Follow the procedure in “Closing a document” to save or discard your changes.

**Using the Open and Save As dialogs**

You can choose whether to use the OpenOffice.org Open and Save As dialogs or the ones provided by your operating system.

To view or change which type of dialog OpenOffice.org uses:

1. Choose **Tools > Options > OpenOffice.org > General**.
2. Select the **Use OpenOffice.org dialogs** option.

This section discusses the OpenOffice.org Open and Save As dialogs. Figure 14 shows the Save As dialog; the Open dialog is similar.

The three buttons in the top right of the OpenOffice.org Open and Save As dialogs are, from left to right:

- **Go Up One Level** in the folder (directory) hierarchy. Click and hold this button for a second to drop down a list of higher level folders; to go to one of the folders on the list, move the mouse pointer over its name and release the mouse button.
- **Create New Folder**.
- **Default Directory**.

For documents (in OpenDocument format) that have been saved with more than one version, use the **Version** drop-down to select which version you wish to open in read-only mode. For Microsoft Office documents, only the current version can be opened.

Use the **File type** field to specify the type of file to be opened or the format of the file to be saved.

The **Read-only** option on the Open dialog opens the file for reading and printing only. Consequently, most of the toolbars disappear, and most menu options are disabled. An **Edit File** button is displayed on the Standard toolbar to open the file for editing.

You can open files from the Web by typing a URL in the **File name** field on the Open dialog.
The Navigator lists objects contained in a document, collected into categories. For example, in Writer it shows Headings, Tables, Text frames, Comments, Graphics, Bookmarks, and other items, as shown in Figure 15. In Calc it shows Sheets, Range Names, Database Ranges, Graphics, Drawing Objects, and other items. In Impress and Draw it shows Slides, Pictures, and other items.

To open the Navigator, click its icon on the Standard toolbar, or press F5, or choose View > Navigator on the menu bar.

You can dock the Navigator to either side of the main Apache OpenOffice window or leave it floating (see "Docking/floating windows and toolbars" on page 20).

Click the marker (+ or arrow) by any of the categories to display the list of objects in that category. To hide the list of categories and show only the toolbars at the top, click the List Box On/Off icon. Click this icon again to show the list box.

The Navigator provides several convenient ways to move around a document and find items in it:

- When a category is showing the list of objects in it, double-click on an object to jump directly to that object's location in the document.

Objects are much easier to find if you have given them names when creating them, instead of keeping Apache OpenOffice's default graphics1, graphics2, Table1, Table2, and so on—which may not correspond to the position of the object in the document.

If you only want to see the content in a certain category, highlight the category and click the Content View icon. Until you click the icon again, only the objects of that category will be displayed.
Click the Navigation icon (second icon from the left at the top of the Navigator) to display the Navigation toolbar (Figure 16). Here you can pick one of the categories and use the Previous and Next icons to move from one item to the next. This is particularly helpful for finding items like bookmarks and indexes, which can be difficult to see. The names of the icons (shown in the tooltips) change to match the selected category; for example, Next Graphic or Next Bookmark.

To jump to a specific page in the document, type its page number in the box at the top of the Navigator.

A bit of experimentation with the other icons will demonstrate their functions. Some component-specific uses are described in the chapters on Writer and the other components.

**Undoing and redoing changes**

To undo the most recent change, press Control+Z, or click the Undo icon on the Standard toolbar, or choose Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone (see below for an example from Writer).
Click the small triangle to the right of the **Undo** icon to get a list of all the changes that can be undone. You can select multiple changes and undo them at the same time.

![List of actions that can be undone](image)

After changes have been undone, **Redo** becomes active. To redo a change, select **Edit > Redo**, or press **Control+Y** or click on the Redo icon. As with Undo, click on the triangle to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes Apache OpenOffice remembers, choose **Tools > Options > OpenOffice.org > Memory** and in the Undo section change **Number of steps**. Be aware that asking Apache OpenOffice to remember more changes consumes more computer memory.
What is a template?

A template is a model that you use to create other documents. For example, you can create a template for business reports that has your company’s logo on the first page. New documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

All documents in Apache OpenOffice are based on templates. You can create a specific template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template when you start a new document, then the document is based on the default template for that type of document. If you have not specified a default template, Apache OpenOffice uses the blank template for that type of document that is installed with Apache OpenOffice. See “Setting a default template” on page 44 for more information.

What are styles?

A style is a set of formats that you can apply to selected pages, text, frames, and other elements in your document to quickly change their appearance. When you apply a style, you apply a whole group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their documents without paying any attention to styles. They are used to writing documents according to physical attributes. For example, you might specify the font family, font size, and any formatting such as bold or italic.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New Roman, bold, centered”, and you start saying “Title” because you have defined the “Title” style to have those characteristics. In other words, styles means that you shift the emphasis from what the text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy. For example, you may decide to change the indentation of all paragraphs, or change the font of all titles. For a long document, this simple task can be prohibitive. Styles make the task easy.

In addition, styles are used by Apache OpenOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents. Some common examples of style use are given in “Examples of style use” on page 47.
Apache OpenOffice supports the following types of styles:

- **Page styles** include margins, headers and footers, borders and backgrounds. In Calc, page styles also include the sequence for printing sheets.
- **Paragraph styles** control all aspects of a paragraph's appearance, such as text alignment, tab stops, line spacing, and borders, and can include character formatting.
- **Character styles** affect selected text within a paragraph, such as the font and size of text, or bold and italic formats.
- **Frame styles** are used to format graphic and text frames, including wrapping type, borders, backgrounds, and columns.
- **Numbering styles** apply similar alignment, numbering or bullet characters, and fonts to numbered or bulleted lists.
- **Cell styles** include fonts, alignment, borders, background, number formats (for example, currency, date, number), and cell protection.
- **Graphics styles** in drawings and presentations include line, area, shadowing, transparency, font, connectors, dimensioning, and other attributes.
- **Presentation styles** include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of Apache OpenOffice, as listed in Table 1.

Apache OpenOffice comes with many predefined styles. You can use the styles as provided, modify them, or create new styles, as described in this chapter.

### Table 1. Styles available in Apache OpenOffice components

<table>
<thead>
<tr>
<th>Style Type</th>
<th>Writer</th>
<th>Calc</th>
<th>Draw</th>
<th>Impress</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paragraph</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Frame</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Numbering</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cell</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Presentation</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Graphics</td>
<td>(included in Frame styles)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

### Applying styles

Apache OpenOffice provides several ways for you to apply styles.

### Using the Styles and Formatting window

1) Click the **Styles and Formatting** icon located at the left-hand end of the object bar, or click **Format > Styles and Formatting**, or press **F11**. The Styles and Formatting window shows the types of styles available for the Apache OpenOffice component you are using. Figure 19 shows the window for Writer, with Page Styles visible.
You can move this window to a convenient position on the screen or dock it to an edge (hold down the Ctrl key and drag it by the title bar to where you want it docked).

2) Click on one of the icons at the top left of the Styles and Formatting window to display a list of styles in a particular category.

3) To apply an existing style (except for character styles), position the insertion point in the paragraph, frame, or page, and then double-click on the name of the style in one of these lists. To apply a character style, select the characters first.

Tip
At the bottom of the Styles and Formatting window is a dropdown list. In Figure 19 the window shows Automatic, meaning the list includes only styles applied automatically by Apache OpenOffice. You can choose to show all styles or other groups of styles, for example only custom styles.

Figure 19: The Styles and Formatting window for Writer, showing paragraph styles

Using Fill Format mode
Use Fill Format to apply a style to many different areas quickly without having to go back to the Styles and Formatting window and double-click every time. This method is quite useful when you need to format many scattered paragraphs, cells, or other items with the same style.

1) Open the Styles and Formatting window and select the style you want to apply.

2) Click the Fill Format mode icon.

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To apply a character style, hold down the mouse button while selecting the characters, Clicking on a word applies the character style for that word. Repeat step 3 until you made all the changes for that style.

4) To quit Fill Format mode, click the Fill Format mode icon again or press the Esc key.

Caution
When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to accidentally right-click and thus undo actions you want to keep.
Using the Apply Style list

After you have used a style at least once in a document, the style name appears on the Apply Style list at the left-hand end of the Formatting toolbar, next to the Styles and Formatting icon.

You can open this list and click once on the style you want, or you can use the up and down arrow keys to move through the list and then press Enter to apply the highlighted style.

Tip Select More... at the bottom of the list to open the Styles and Formatting window.

![Figure 20: The Apply Style list on the Formatting toolbar](image)

Using keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, in Writer Control+0 applies the Text body style, Control+1 applies the Heading 1 style, and Control+2 applies the Heading 2 style. You can modify these shortcuts and create your own; see Chapter 11 (Setting up and Customizing Apache OpenOffice) for instructions.

Modifying styles

Apache OpenOffice provides several ways to modify styles (both the predefined styles and custom styles that you create):

- Changing a style using the Style dialog
- Updating a style from a selection
- Use AutoUpdate (paragraph and frame styles only)
- Load or copy styles from another document or template

Tip Any changes you make to a style are effective only in the current document. To change styles in more than one document, you need to change the template or copy the styles into the other documents as described on page 37.
Changing a style using the Style dialog

To change an existing style using the Style dialog, right-click on the required style in the Styles and Formatting window and select Modify from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each style dialog has several tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection

To update a style from a selection:

1) Open the Styles and Formatting window.
2) In the document, select an item that has the format you want to adopt as a style.

Caution

Make sure that there are unique properties in this paragraph. For example, if there are two different font sizes or font styles, that particular property will remain the same as before.

3) In the Styles and Formatting window, select the style you want to update (single-click, not double-click), then long-click on the arrow next to the New Style from Selection icon and click on Update Style.

Using AutoUpdate

AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a paragraph or frame using this style in your document automatically updates the style itself.

Tip

If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled.

Updating styles from a document or template

You can update styles by copying or loading them from a template or another document. See “Copying and moving styles” on page 37.
Creating new (custom) styles

You may want to add some new styles. You can do this in two ways:

- Creating a new style using the Style dialog
- Creating a new style from a selection

Creating a new style using the Style dialog

To create a new style using the Style dialog, right-click in the Styles and Formatting window and select New from the pop-up menu.

If you want your new style to be linked with an existing style, first select that style and then right-click and select New.

If you link styles, then when you change the base style (for example, by changing the font from Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you want; other times you do not want the changes to apply to all the linked styles. It pays to plan ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles. See the chapters on styles in the user guides for details.

Creating a new style from a selection

You can create a new style by copying an existing manual format. This new style applies only to this document; it will not be saved in the template.

1) Open the Styles and Formatting window and choose the type of style you want to create.
2) In the document, select the item you want to save as a style.
3) In the Styles and Formatting window, click on the New Style from Selection icon.
4) In the Create Style dialog, type a name for the new style. The list shows the names of existing custom styles of the selected type. Click OK to save the new style.

![Create Style dialog](image)

*Figure 22: Naming a new style created from a selection*
Dragging and dropping to create a style

You can drag and drop a text selection into the Styles and Formatting window to create a new style.

**Writer**
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are active, the paragraph style will be added to the list. If Character Styles are active, the character style will be added to the list.

**Calc**
Drag a cell selection to the Styles and Formatting window to create cell styles.

**Draw/Impress**
Select and drag drawing objects to the Styles and Formatting window to create graphics styles.

Copying and moving styles

You can copy or move styles from one template or document into another template or document, in two ways:

- Using the Template Management dialog
- Loading styles from a template or document

Using the Template Management dialog

To copy or move styles using the Template Management dialog:

1) Click **File > Templates > Organize**.
2) In the Template Management dialog (Figure 23), set the lists at the bottom to either Templates or Documents, as needed. The default is Templates on the left and Documents on the right.

**Tip**
To copy styles from a file that is not open, click the **File** button. When you return to this dialog, both lists show the selected file as well as all the currently open documents.

3) Open the folders and find the templates from and to which you want to copy. Double-click on the name of the template or document, and then double-click the Styles icon to show the list of individual styles (Figure 24).
4) To copy a style, hold down the *Ctrl* key and drag the name of the style from one list to the other.

**Caution**
If you do not hold down the *Control* key when dragging, the style will be moved from one list to the other. The style will be deleted from the list you are dragging it from.

5) Repeat for each style you want to copy. If the receiving template or document has many styles, you may not see any change unless you scroll down in the list. When you are finished, click **Close**.
Loading styles from a template or document

You can copy styles by loading them from a template or another document:

1) Open the document you want to copy styles into.
2) In the Styles and Formatting window, long-click on the arrow next to the New Style from Selection icon, and then click on Load Styles (see Figure 21).
3) On the Load Styles dialog (Figure 25), find and select the template you want to copy styles from.
4) Select the categories of styles to be copied. Select **Overwrite** if you want the styles being copied to replace any styles of the same names in the document you are copying them into.

5) Click **OK** to copy the styles. You will not see any change on screen.

---

**Note**
To copy the styles from another document, click the **From File** button to open a window from which you can select the required document.

**Caution**
If your document has a table of contents, and if you have used custom styles for headings, the heading levels associated with outline levels (in **Tools > Outline Numbering**) will revert to the defaults of Heading 1, Heading 2, and so on when you load styles this way. You will need to change these back to your custom heading styles. This is a bug.

---

**Deleting styles**

You cannot remove (delete) any of Apache OpenOffice’s predefined styles from a document or template, even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the styles are not in use. If an unwanted style is in use, you will want to replace it with a substitute style.

To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting window and click **Delete** on the pop-up menu.

If the style is in use, you receive a warning message.

If the style is not in use, you receive a confirmation message; click **Yes**.

---

**Using a template to create a document**

To use a template to create a document:

1) From the main menu, choose **File > New > Templates and Documents**. The Templates and Documents dialog opens.

2) In the box on the left, click the **Templates** icon if it is not already selected. A list of template folders appears in the center box.
3) Double-click the folder that contains the template that you want to use. A list of all the templates contained in that folder appears in the center box.

4) Select the template that you want to use. You can preview the selected template or view the template’s properties:

   - To preview the template, click the **Preview** icon. A preview of the template appears in the box on the right.

   - To view the template’s properties, click the **Document Properties** icon. The template’s properties appear in the box on the right.

5) Click **Open**. The Templates and Documents dialog closes and a new document based on the selected template opens in Apache OpenOffice. You can then edit and save the new document just as you would any other document.

![Figure 26: Templates and Documents window](image)

### Creating a template

You can create your own templates in two ways: from a document, and using a wizard.

#### Creating a template from a document

To create a template from a document:

1) Open a new or existing document of the type you want to make into a template (text document, spreadsheet, drawing, presentation).

2) Add the content and styles that you want.

3) From the main menu, choose **File > Templates > Save**. The Templates dialog opens (see Figure 27).

4) In the **New template** field, type a name for the new template.

5) In the **Categories** list, click the category to which you want to assign the template. The category you choose has no effect on the template itself; it is simply the folder in which you save the template. Choosing an appropriate category makes it easier to find the template.
when you want to use it. For example, you might save Impress templates under the **Presentations** category.

To learn more about template folders, see “Organizing templates” on page 45.

6) Click **OK** to save the new template.

![Figure 27: Saving a new template](image)

Any settings that can be added to or modified in a document can be saved in a template. For example, below are some of the settings (although not a full list) that can be included in a Writer document and then saved as a template for later use:

- Printer settings: which printer, single sided / double sided, and paper size, and so on
- Styles to be used, including character, page, frame, numbering and paragraph styles
- Format and settings regarding indexes, tables, bibliographies, table of contents

Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 11 (Setting Up and Customizing Apache OpenOffice) for more information.

**Creating a template using a wizard**

You can use wizards to create templates for letters, faxes, agendas, presentations, and Web pages.

For example, the Fax Wizard guides you through the following choices:

- Type of fax (business or personal)
- Document elements like the date, subject line (business fax), salutation, and complementary close
- Options for sender and recipient information (business fax)
- Text to include in the footer (business fax)

To create a template using a wizard:

1) From the main menu, choose **File > Wizards > [type of template required]**. (See Figure 28.)
2) Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is very similar.
3) In the last section of the wizard, you can specify the name and location for saving the template. The default location is your user templates directory, but you can choose a different location if you prefer.

---

*Chapter 2 Using Styles and Templates*
4) Finally, you have the option of creating a new document from your template immediately, or manually changing the template. For future documents, you can re-use the template created by the wizard, just as you would use any other template.

![Figure 28. Creating a template using a wizard](image)

**Editing a template**

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to documents that were created from that template.

**Note** You can only reapply styles. You cannot reapply content.

To edit a template:

1) From the main menu, choose **File > Templates > Edit**. A standard file browser window opens.
2) Select the template that you want to edit.
3) Edit the template just as you would any other document. To save your changes, choose **File > Save** from the main menu.

**Updating a document from a changed template**

The next time you open a document that was created from the changed template, the following message appears.

![Figure 29. Update styles message](image)

Click **Update Styles** to apply the template’s changed styles to the document. Click **Keep Old Styles** if you do not want to apply the template’s changed styles to the document (but see Caution notice below).
Caution

If you choose **Keep Old Styles** in the message box shown in Figure 29, that message will not appear again the next time you open the document after changing the template it is based on. You will not get another chance to update the styles from the template, although you can use the Template Changer extension (see page 45) to reactivate the template.

---

### Adding templates using the Extension Manager

The Extension Manager provides an easy way to install collections of templates, graphics, macros, or other add-ins that have been “packaged” into files with a .OXT extension. See Chapter 11 (Setting up and Customizing Apache OpenOffice) for more about the Extension Manager.

This Web page lists many of the available extensions: [http://extensions.services.openoffice.org/](http://extensions.services.openoffice.org/).

To install an extension, follow these steps:

1. Download an extension package and save it anywhere on your computer.
2. In Apache OpenOffice, select **Tools > Extension Manager** from the menu bar. In the Extension Manager dialog, click **Add**.
3. A file browser window opens. Find and select the package of templates you want to install and click **Open**. The package begins installing. You may be asked to accept a license agreement.
4. When the package installation is complete, the templates are available for use through **File > New > Templates and Documents** and the extension is listed in the Extension Manager.

![Extension Manager](image)

*Figure 30: Newly-added package of templates*
Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet, Presentation, or Drawing) from the main menu, Apache OpenOffice creates the document from the Default template for that type of document. You can, however, set a custom template to be the default. You can reset the default later if you choose.

Setting a custom template as the default

You can set any template to be the default, as long as it is in one of the folders displayed in the Template Management dialog.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template Management dialog opens.
2) In the box on the left, select the folder containing the template that you want to set as the default, then select the template.
3) Click the Commands button and choose Set As Default Template from the drop-down menu.

The next time that you create a document by choosing File > New, the document will be created from this template.

Although many important settings can be changed in the Options dialog (see Chapter 11), for example default fonts and page size, more advanced settings (such as page margins) can only be changed by replacing the default template with a new one.

Resetting the default template

To re-enable Apache OpenOffice’s Default template for a document type as the default:

1) In the Template Management dialog, click any folder in the box on the left.
2) Click the Commands button and choose Reset Default Template from the drop-down menu.

The next time that you create a document by choosing File > New, the document will be created from Apache OpenOffice’s Default template for that document type.

Associating a document with a different template

At times you might want to associate a document with a different template, or perhaps you are working with a document that did not start from a template.

One of the major advantages of using templates is the ease of updating styles in more than one document, as described on page 42. If you update styles by loading a new set of styles from a different template (as described on page 38), the document has no association with the template from which the styles were loaded—so you cannot use this method. What you need to do is associate the document with the different template.

You can do this in two ways. In both cases, for best results the names of styles should be the same in the existing document and the new template. If they are not, you will need to use Search and Replace to replace old styles with new ones. See Chapter 3 (Getting Started with Writer) for more about replacing styles using Search and Replace.
**Method 1**
This method includes any graphics and wording (such as legal notices) that exists in the new template, as well as including styles. If you do not want this material, you need to delete it.

1) Use **File > New > Templates and Documents**. Choose the template you want. If the template has unwanted text or graphics in it, delete them.
2) Open the document you want to change. (It opens in a new window.) Press Control+A to select everything in the document. Paste into the blank document created in step 1.
3) Update the table of contents, if there is one. Save the file.

**Method 2 (Writer only)**
This method does not include any graphics or text from the new template; it simply includes styles from the new template and establishes an association between the template and the document.

1) Download the Template Changer extension from [http://extensions.services.openoffice.org/](http://extensions.services.openoffice.org/) and install it as described on page 43.
2) Close and reopen Apache OpenOffice. Now the **File > Templates** menu has two new choices in Writer: **Assign Template (current document)** and **Assign Template (folder)**. In Calc, Impress, and Draw, only the **Assign Template (folder)** choice is available.
3) Open the document whose template you want to change. Choose **File > Templates > Assign Template (current document)**.
4) In the Select Template window, find and select the required template and click **Open**.
5) Save the document. If you now look in **File > Properties**, you will see the new template listed at the bottom of the General page.

**Organizing templates**
Apache OpenOffice can only use templates that are in Apache OpenOffice template folders. You can create new Apache OpenOffice template folders and use them to organize your templates. For example, you might have one template folder for report templates and another for letter templates. You can also import and export templates.

To begin, choose **File > Templates > Organize** from the main menu. The Template Management dialog opens.

---

**Note**
All the actions made by the **Commands** button in the Template Management dialog can be made as well by right-clicking on the templates or the folders.

---

**Creating a template folder**
To create a template folder:

1) In the Template Management dialog, click any folder.
2) Click the **Commands** button and choose **New** from the drop-down menu. A new folder called **Untitled** appears.
3) Type a name for the new folder, and then press **Enter**. Apache OpenOffice saves the folder with the name that you entered.

**Deleting a template folder**
You cannot delete template folders supplied with Apache OpenOffice or installed using the Extension Manager; you can only delete template folders that you have created.
To delete a template folder that you have created:

1) In the Template Management dialog, select the folder that you want to delete.
2) Click the **Commands** button and choose **Delete** from the drop-down menu. A message box appears and asks you to confirm the deletion. Click **Yes**.

### Moving a template

To move a template from one template folder to another template folder:

1) In the Template Management dialog, double-click the folder that contains the template you want to move. A list of the templates contained in that folder appears underneath the folder name.
2) Click the template that you want to move and drag it to the desired folder. If you do not have the authority to delete templates from the source folder, this action copies the template instead of moving it.

### Deleting a template

You cannot delete templates supplied with Apache OpenOffice or installed using the Extension Manager; you can only delete templates that you have created or imported.

To delete a template:

1) In the Template Management dialog, double-click the folder that contains the template you want to delete. A list of the templates contained in that folder appears underneath the folder name.
2) Click the template that you want to delete.
3) Click the **Commands** button and choose **Delete** from the drop-down menu. A message box appears and asks you to confirm the deletion. Click **Yes**.

### Importing a template

If the template that you want to use is in a different location, you must import it into an Apache OpenOffice template folder.

To import a template into a template folder:

1) In the Template Management dialog, select the folder into which you want to import the template.
2) Click the **Commands** button and choose **Import Template** from the drop-down menu. A standard file browser window opens.
3) Find and select the template that you want to import and click **Open**. The file browser window closes and the template appears in the selected folder.
4) If you want, type a new name for the template, and then press **Enter**.

### Exporting a template

To export a template from a template folder to another location:

1) In the Template Management dialog, double-click the folder that contains the template you want to export. A list of the templates contained in that folder appears underneath the folder name.
2) Click the template that you want to export.
3) Click the **Commands** button and choose **Export Template** from the drop-down menu. The **Save As** window opens.
4) Find the folder into which you want to export the template and click **Save**.
Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer. There are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other pages in the document. For example, the first page of a letterhead typically has a different header, or the first page of a report might have no header or footer, while the other pages do. With Apache OpenOffice, you can define the page style for the first page and specify the style for the following pages to be applied automatically.

As an example, we can use the First Page and Default page styles that come with Apache OpenOffice. Figure 31 shows what we want to happen: the first page is to be followed by the default page, and all the following pages are to be in the Default page style. Details are in Chapter 4 (Formatting Pages) in the Writer Guide.

![Figure 31: Flow of page styles](image)

Dividing a document into chapters

In a similar way, you can divide a document into chapters. Each chapter might start with the First Page style, with the following pages using the Default page style, as above. At the end of the chapter, insert a manual page break and specify the next page to have the First Page style to start the next chapter, as shown in Figure 32.

![Figure 32: Dividing a document into chapters using page styles](image)

Changing page orientation within a document

A Writer document can contain pages in more than one orientation. A common scenario is to have a landscape page in the middle of a document, whereas the other pages are in a portrait orientation. This can also be done with page breaks and page styles.
Different headers on right and left pages

Page styles can be set up to have the facing left and right pages *mirrored* or only right (first pages of chapters are often defined to be right-page only) or only left. When you insert a header on a page style set up for mirrored pages or right-and-left pages, you can have the contents of the header be the same on all pages or be different on the right and left pages. For example, you can put the page number on the left-hand edge of the left pages and on the right-hand edge of the right pages, put the document title on the right-hand page only, or make other changes.

Controlling page breaks automatically

Writer automatically flows text from one page to the next. If you do not like the default settings, you can change them. For example, you can require a paragraph to start on a new page or column and specify the style of the new page. A typical use is for chapter titles to always start on a new right-hand (odd-numbered) page.

Compiling an automatic table of contents

To compile an automatic table of contents, first apply styles to the headings you want to appear in the contents list, then use **Tools > Outline Numbering** to tell Writer which styles go with which level in the table of contents. See Chapter 3 for more information.

Defining a sequence of styles

You can set up one paragraph style so that when you press *Enter* at the end of that paragraph, the following paragraph automatically has the style you wish applied to it. For example, you could define a *Heading 1* paragraph to be followed by a *Text Body* paragraph. A more complex example would be: *Title* followed by *Author* followed by *Abstract* followed by *Heading 1* followed by *Text Body*. By setting up these sequences, you can avoid manually applying styles in most cases.
Chapter 3
Getting Started with Writer

Word Processing with Apache OpenOffice

What is Writer?

Writer is the word processor component of Apache OpenOffice. In addition to the usual features of a word processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic generation of tables of contents and indexes, mail merge and others), Writer provides these important features:

- Templates and styles (see Chapter 2)
- Page layout methods, including frames, columns, and tables
- Embedding or linking of graphics, spreadsheets, and other objects
- Built-in drawing tools
- Master documents—to group a collection of documents into a single document
- Change tracking during revisions
- Database integration, including a bibliography database
- Export to PDF, including bookmarks (see Chapter 9)
- And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 33. The menus and toolbars are described in Chapter 1 (Introducing Apache OpenOffice).

Some other features of the Writer interface are covered in this chapter.
Status bar

The Writer status bar provides information about the document and convenient ways to quickly change some document features.

![Status bar][1]

**Figure 34: Left end of status bar**

### Page number

Shows the current page number, the sequence number of the current page (if different), and the total number of pages in the document. For example, if you restarted page numbering at 1 on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of bookmarks; click on the required one.

To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the sequence number of the required page. After a brief delay, the display jumps to the selected page.

### Page style

Shows the style of the current page. To change the page style, right-click on this field. A list of page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog opens.

### Language

Shows the language for the selected text.

Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose **None (Do not check spelling)** to exclude the text from a spelling check or choose **More**... to open the Character dialog.

---

[1]: screenshot.png

*Figure 33: The main Writer workspace in Print Layout view*
Insert mode
Click to toggle between Insert and Overwrite modes when typing.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection. Ext is an alternative to Shift+click when selecting text. See “Working with text” on page 54 for more information about ADD and BLK.

Unsaved changes
An asterisk (*) appears here if changes to the document have not been saved.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to view the certificate.

Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or table) is selected, information about that item appears in this field. Double-clicking in this area opens a relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect varies with the combination of window width and zoom factor in use. You can edit the document in any view.
Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.

Changing document views
Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access these and other choices, go to the View menu and click on the required view. (When in Full Screen view, press the Esc key to return to either Print or Web Layout view.)

When in Print Layout, you can use both the Zoom slider and the View Layout icons on the status bar. In Web Layout, you can use the Zoom slider.

You can also choose View > Zoom from the menu bar to display the Zoom & View Layout dialog, where you can set the same options as on the Status bar. In Web Layout view, most of the choices are not available.

Moving quickly through a document
In addition to the navigation features of the Status bar (described above), you can use the main Navigator window and the Navigation toolbar as described in Chapter 1 (Introducing Apache OpenOffice).

In Writer, you can also display the Navigation toolbar by clicking on the small Navigation icon near the lower right-hand corner of the window below the vertical scroll bar, as shown in Figure 38.
The Navigation toolbar (Figure 39) shows icons for all the object types shown in the Navigator, plus some extras (for example, the results of a Find command).

Click an icon to select that object type. Now all the Previous and Next icons (in the Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected type. This is particularly helpful for finding items like index entries, which can be difficult to see in the text. The names of the icons (shown in the tooltips) change to match the selected category; for example, Next Graphic, Next Bookmark, or Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.

Working with documents

Chapter 1 (Introducing Apache OpenOffice) includes instructions on starting new documents, opening existing documents, saving documents, and password-protecting documents. Chapter 2 (Using Styles and Templates) covers how to create a document from a template.

Saving as a Microsoft Word file

If you need to exchange files with users of Microsoft Word who are unwilling or unable to receive *.odt files, you can save a document as a Microsoft Word file.

1) Important—First save your document in the file format used by Writer (.odt). If you do not, any changes you made since the last time you saved will appear only in the Microsoft Word version of the document.

2) Then choose File > Save As. On the Save As dialog, in the File type (or Save as type) drop-down menu, select the type of Word format you need. Click Save.

Caution

Some formatting may be lost when you save in formats other than OpenDocument Formats. You may wish to test some typical files to see if yours save correctly in other formats.
From this point on, all changes you make to the document will occur only in the Microsoft Word document. You have changed the name and file type of your document. If you want to go back to working with the .odt version of your document, you must open it again.

**Tip**
To have Apache OpenOffice save documents by default in the Microsoft Word file format, go to **Tools > Options > Load/Save**. See “Choosing options for loading and saving documents” in Chapter 11 (Setting Up and Customizing Apache OpenOffice).

**Working with text**

Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in any other program. Apache OpenOffice also has some convenient ways to select items that are not next to each other, select a vertical block of text, and paste unformatted text.

**Selecting items that are not consecutive**

To select nonconsecutive items (as shown in Figure 41) using the mouse:

1. Select the first piece of text.
2. Hold down the `Control` key and use the mouse to select the next piece of text.
3. Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, or whatever).

**Note**
Macintosh users: substitute the `Command` key when instructions in this chapter say to use the `Control` key.
To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the topic “Navigating and selecting with the keyboard” in the Help.)

2) Press \texttt{Shift+F8}. This puts Writer in “Add” mode. The word ADD appears on the status bar.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the \texttt{Shift} key and select the next piece of text.

4) Repeat as often as needed.

Now you can work with the selected text. Press \texttt{Esc} to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might see in text pasted from e-mails, program listings, or other sources), using Writer’s block selection mode. To change to block selection mode, use \texttt{Edit > Selection Mode > Block Area}, or click several times in the status bar on STD until it changes to BLK.

Now highlight the selection, using mouse or keyboard, as shown below.

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You can use the mouse or the keyboard for these operations. You can copy or move text within a document, or between documents, by dragging or by using menu selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.

To \textit{move} (cut and paste) selected text using the mouse, drag it to the new location and release it. To \textit{copy} selected text, hold down the \texttt{Ctrl} key while dragging. The text retains the formatting it had before dragging.
When you paste text, the result depends on the source of the text and how you paste it. If you click on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from Web sites and other sources may also be placed into frames or tables. If you do not like the results, click the Undo icon or press Control+Z.

To make the pasted text take on the formatting of the surrounding text where it is being pasted:

- Choose Edit > Paste Special, or
- Click the triangle to the right of the Paste icon, or
- Click the Paste icon without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of the text (or other object) to be pasted. See Figure 43 for an example with text on the clipboard.

![Figure 43: Paste Special menu](image)

**Finding and replacing text and formatting**

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find & Replace dialog. In the dialog, you can:

- Find and replace words and phrases
- Use wildcards and regular expressions to fine-tune a search
- Find and replace specific formatting
- Find and replace paragraph styles

**Using the Find toolbar**

If the Find toolbar is not visible, you can display it using View > Toolbars > Find.

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next occurrence of that term. Click the Find Next or Find Previous buttons (up and down arrows) as needed.

**Using the Find & Replace dialog**

To display the Find & Replace dialog, use the keyboard shortcut Ctrl+F or choose Edit > Find & Replace from the menu bar. Optionally, click the More Options button to expand the dialog; the button changes to Fewer Options.
To use the Find & Replace dialog:

1) Type the text you want to find in the **Search for** box.
2) To replace the text with different text, type the new text in the **Replace with** box.
3) You can select various options such as matching the case, matching whole words only, or doing a search for similar words.
4) When you have set up your search, click **Find**. To replace text, click **Replace** instead.

For more information on using Find & Replace, see the **Writer Guide**.

**Tip**

If you click **Find All**, Writer selects all instances of the search text in the document. Similarly, if you click **Replace All**, Writer replaces all matches.

**Caution**

Use **Replace All** with caution; otherwise, you may end up with some hilarious (and highly embarrassing) mistakes. A mistake with **Replace All** might require a manual, word-by-word, search to fix.
Inserting special characters

A special character is one not found on a standard English keyboard. For example, © ¾ æ ŋ ò ø ç are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.
2) Choose Insert > Special Character to open the Special Characters dialog.
3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then click OK. The selected characters are shown in the lower left of the dialog. As you select a character, it is shown on the lower right, along with its numerical code.

Note Different fonts include different special characters. If you do not find a particular special character, try changing the Font selection.

Inserting dashes and non-breaking spaces and hyphens

To prevent two words from being separated at the end of a line, press Control+Shift+spacebar after the first word to insert a non-breaking space.

In cases where you do not want the hyphen to appear at the end of a line, for example in a number such as 123-4567, you can press Control+Shift+minus sign to insert a non-breaking hyphen.

To enter en and em dashes, you can use the Replace dashes option on the Options tab under Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with the corresponding dash.

– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at least one character, a space, one or two hyphens, another space, and at least one more letter, then a space. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at least one character, two hyphens, and at least one more character, then a space. The two hyphens will be replaced by an em-dash.

See the Help for more details. For other methods of inserting dashes, see the Writer Guide.
Setting tab stops and indents

The horizontal ruler shows both the default tab stops and any tab stops that you have defined. Tab settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent icons on the Formatting toolbar) as well as indentation of parts of a paragraph (by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other people. If you use the default tab spacing and then send the document to someone else who has chosen a different default tab spacing, tabbed material will change to use the other person's settings. This may cause major formatting problems. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of the ruler that is not between the left and right indent icons to open the Indents & Spacing page of the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to open the Tabs page of the Paragraph dialog.

A better strategy is to define tabs for the paragraph style. See Chapters 6 and 7 in the Writer Guide for more information.

Tip

Using tabs to space out material on a page is not recommended. Depending on what you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval

Note

Any changes to the default tab setting will affect the existing default tab stops in any document you open afterward, as well as tab stops you insert after making the change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options > OpenOffice.org Writer > General.

![Figure 46: Selecting a default tab stop interval](image)

You can also set or change the measurement unit for rulers in the current document by right-clicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The selected setting applies only to that ruler.

![Figure 47: Changing the measurement unit for a ruler](image)
Checking spelling and grammar

Writer provides a spelling checker, which can be used in two ways.

**AutoSpellcheck** checks each word as it is typed and displays a wavy red line under any misspelled words. When the word is corrected, the line disappears.

To perform a separate spelling check on the document (or a text selection) click the **Spelling and Grammar** button. This checks the document or selection and opens the Spelling and Grammar dialog if any misspelled words are found.

Here are some more features of the spelling checker:

- You can right-click on a word with a wavy underline to open a context menu. If you select from the suggested words on the menu, the selection will replace the misspelled word in your text. Other menu options are discussed below.
- You can change the dictionary language (for example, Spanish, French or German) on the Spelling and Grammar dialog.
- You can add a word to the dictionary. Click **Add** in the Spelling and Grammar dialog and pick the dictionary to add it to.
- Click the **Options** button on the Spelling and Grammar dialog to open a dialog similar to the one in **Tools > Options > Language Settings > Writing Aids** described in Chapter 11. There you can choose whether to check uppercase words and words with numbers, and you can manage custom dictionaries, that is, add or delete dictionaries and add or delete words in a dictionary.
- On the Font tab of the Paragraph Styles dialog, you can set paragraphs to be checked in a specific language (different from the rest of the document). See Chapter 7 (Working with Styles) in the **Writer Guide** for information on how to manage the language settings of a style.

Writer does not include a grammar checker, but you can install an extension such as Language Tool (from [http://www.languagetool.org/](http://www.languagetool.org/)) and access it from **Tools > Spelling and Grammar**. (See Chapter 11 for more about installing extensions.)

Language Tool adds a new menu item and submenu to the Tools menu, from which you can configure the tool and check or recheck the document.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the same document or if you write documents in various languages.

The main advantage of changing the language is that you can then use the correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement tables, thesaurus, and hyphenation rules.

You can also set the language for a paragraph or a group of characters as **None**. This option is especially useful when you insert text such as web addresses or programming language snippets that you do not want to check for spelling.

Specifying the language in character and paragraph styles is the preferred method, because styles allow a greater level of control and make changing the language much faster. On the Font tab of the Paragraph Styles dialog, you can specify that certain paragraphs be checked in a language that is different from the language of the rest of the document. See Chapter 7 (Working with Styles) in the **Writer Guide** for information on how to manage the language settings of a style.

You can set the language for the whole document, for individual paragraphs, or even for individual words and characters, all from **Tools > Language** on the menu bar.
Another way to change the language of a whole document is to use Tools > Options > Language Settings > Languages. In the Default languages for documents section of the Options dialog, you can choose a different language for all the text.

The spelling checker works only for those languages in the list that have the symbol next to them. If you do not see the symbol next to your preferred language, you can install the additional dictionary using Tools > Languages > More dictionaries online.

The language used for checking spelling is also shown in the status bar, next to the page style in use.

Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it corrects automatically. For example, “hte” will be changed to “the”.

Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define which strings of text are corrected and how. In most cases, the defaults are fine.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect > While Typing.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click Delete.

To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and click New.

See the different tabs of the dialog for the wide variety of other options available to fine-tune AutoCorrect.

Tip

AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be autocorrected to ©. You can add your own special characters.

Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete the word for you. To accept the suggestion, press Enter. Otherwise continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and deselect Enable word completion.

You can customize word completion from the Word Completion page of the AutoCorrect dialog:

• Add (append) a space automatically after an accepted word
• Show the suggested word as a tip (hovering over the word) rather than completing the text as you type
• Change the maximum number of words remembered for word completion and the length of the smallest words to be remembered
• Delete specific entries from the word completion list
• Change the key that accepts a suggested entry—the options are Right arrow, End key, Return (Enter), and Space bar

Note

Automatic word completion only occurs after you type a word for the second time in a document.
Using AutoText

Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key combination for easy retrieval. For example, rather than typing “Senior Management” every time you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” and press F3.

Creating AutoText

To store some text as AutoText:
1) Type the text into your document.
2) Select the text.
3) Choose Edit > AutoText (or press Control+F3).
4) In the AutoText dialog, type a name for the AutoText in the Name box. Writer will suggest a one-letter shortcut, which you can change.
5) In the large box to the left, choose the category for the AutoText entry, for example My AutoText.
6) Click the AutoText button on the right and select New (text only) from the menu.
7) Click Close to return to your document.

Tip
If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 14 (Working with Fields) in the Writer Guide for more information.

Inserting AutoText

To insert AutoText, type the shortcut and press F3.

Formatting text

Using styles is recommended

Styles are central to using Writer. Styles enable you to easily format your document consistently, and to change the format with minimal effort. A style is a named set of formatting options. Writer defines several types of styles, for different types of elements: characters, paragraphs, pages, frames, and lists. See Chapter 2 (Using Styles and Templates) in this book and Chapters 6 and 7 in the Writer Guide.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 48 shows the Formatting toolbar as a floating toolbar, customized to show only the icons for paragraph formatting. The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > OpenOffice.org > View.
### Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 49 shows the Formatting toolbar, customized to include only the icon for character formatting.

The appearance of the icons may vary with your operating system and the selection of icon size and style in **Tools > Options > OpenOffice.org > View**.

---

**Tip**

To remove manual formatting, select the text and choose **Format > Default Formatting**, or right-click and choose **Default Formatting**.

### Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on the Options page of the AutoCorrect dialog (**Tools > AutoCorrect Options**).

**Tip**

If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.

Some common unwanted or unexpected formatting changes include:

- **Horizontal lines.** If you type three or more hyphens (---), underscores (___) or equal signs (===) on a line and then press **Enter**, the paragraph is replaced by a horizontal line as wide as the page. The line is actually the lower border of the preceding paragraph.

- **Bulleted and numbered lists.** A bulleted list is created when you type a hyphen (-), star (*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list...
is created when you type a number followed by a period (.), followed by a space or tab at the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on the list.

**Creating numbered or bulleted lists**

There are several ways to create numbered or bulleted lists:

- Use autoformatting, as described above.
- Use list (numbering) styles, as described in Chapters 6 (Introduction to Styles) and 7 (Working with Styles) in the Writer Guide.
- Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure 48): select the paragraphs in the list, and then click the appropriate icon on the toolbar.

**Note**

It is a matter of personal preference whether you type your information first, then apply Numbering/Bullets, or apply them as you type.

**Using the Bullets and Numbering toolbar**

You can create nested lists (where one or more list items has a sub-list under it, as in an outline) by using the buttons on the Bullets and Numbering toolbar (Figure 50). You can move items up or down the list, or create sub-points, and even change the style of bullets. Use View > Toolbars > Bullets and Numbering to see the toolbar.

The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > OpenOffice.org > View.

**Note**

If numbering or bullets are being applied automatically in a way that you find inappropriate, you can switch them off temporarily by unchecking Format > AutoCorrect > While Typing.
Hyphenating words

You have several choices regarding hyphenation: let Writer do it automatically (using its hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t hyphenate at all.

Automatic hyphenation

To turn automatic hyphenation of words on or off:

1) Press $F11$ (§+T on Mac) to open the Styles and Formatting window.
2) On the Paragraph Styles page (Figure 51), right-click on Default and select Modify.
3) On the Paragraph Style dialog (Figure 52), go to the Text Flow page.
4) Under Hyphenation, select or deselect the Automatically option. Click OK to save.

Note

Turning on hyphenation for the Default paragraph style affects all other paragraph styles that are based on Default. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default are not affected. See Chapter 2 (Styles and Templates) for more about styles based on other styles.

You can also set hyphenation choices through Tools > Options > Language Settings > Writing Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.
To change the minimum number of characters for hyphenation, the minimum number of characters before a line break, or the minimum number of characters after a line break, select the item, and then click the **Edit** button in the Options section.

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on through paragraph styles.

**Manual hyphenation**

To manually hyphenate words, *do not* use a normal hyphen, which will remain visible even if the word is no longer at the end of a line when you add or delete text or change margins or font size. Instead, use a *conditional hyphen*, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press `Control+hyphen`. The word will be hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switched off.

**Formatting pages**

Writer provides several ways for you to control page layouts: page styles, columns, frames, tables, and sections. For more information, see Chapter 4 (Formatting Pages) in the **Writer Guide**.

| Tip | Page layout is usually easier if you show text, object, table, and section boundaries in **Tools > Options > OpenOffice.org > Appearance**, and paragraph ends, tabs, breaks, and other items in **Tools > Options > OpenOffice.org Writer > Formatting Aids**. |

**Which layout method to choose?**

The best layout method varies depending on what the final document should look like and what sort of information will be in the document. Here are some examples.

For a book similar to this user guide, with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and tables to place figures beside descriptive text when necessary.
For an index or other document with two columns of text, where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence (also known as “snaking columns” of text), use page styles (with two columns). If the title of the document (on the first page) is full-page width, put it in a single-column section.

For a newsletter with complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout. Place articles in linked frames and anchor graphics to fixed positions on the page if necessary.

For a document with terms and translations to appear side-by-side in what appear to be columns, use a table to keep items lined up, and so you can type in both “columns”.

Creating headers and footers

A header is an area that appears at the top of a page. A footer appears at the bottom of the page. Information such as page numbers inserted into a header or footer displays on every page of the document with that page style.

To insert a header, choose Insert > Header > Default (or the page style, if not Default).

Other information such as document titles and chapter titles is often put into the header or footer. These items are best added as fields. That way, if something changes, the headers and footers are updated automatically. Here is one common example.

To insert the document title into the header:

1) Choose File > Properties > Description and type a title for your document.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.
4) Choose Insert > Fields > Title. The title should appear on a gray background (which does not show when printed and can be turned off).
5) To change the title for the whole document, go back to File > Properties > Description.

Fields are covered in detail in Chapter 14 (Working with Fields) in the Writer Guide.

For more about headers and footers, see Chapter 4 (Formatting Pages) and Chapter 6 (Introduction to Styles) in the Writer Guide.

Numbering pages

To automatically number pages:

1) Insert a header or footer, as described in “Creating headers and footers” on page 68.
2) Place the cursor in the header or footer where you want the page number to appear and choose Insert > Fields > Page Number.

Including the total number of pages

To include the total number of pages (as in “page 1 of 12”):

1) Type the word “page” and a space, then insert the page number as above.
2) Press the spacebar once, type the word “of” and a space, then choose Insert > Fields > Page Count.

Note

The Page Count field inserts the total number of pages in the document, as shown on the Statistics tab of the document’s Properties window (File > Properties). If you restart page numbering anywhere in the document, then the total page count may not be what you want. See Chapter 4 (Formatting Pages) in the Writer Guide for more information.

Restarting page numbering

Often you will want to restart the page numbering at 1, for example on the page following a title page or a table of contents. In addition, many documents have the “front matter” (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.
Method 1:
1) Place the cursor in the first paragraph of the new page.
2) Choose Format > Paragraph.
3) On the Text Flow tab of the Paragraph dialog, select Breaks.
4) Select Insert and then With Page Style and specify the page style to use.
5) Specify the page number to start from, and then click OK.

Tip
Method 1 is also useful for numbering the first page of a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog (Figure 54).
3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.

![Insert Break dialog](image)

Figure 54: Restarting page numbering after a manual page break

Changing page margins
You can change page margins in two ways:
- Using the page rulers—quick and easy, but does not have fine control
- Using the Page Style dialog—can specify margins to two decimal places

Note
If you change the margins using the rulers, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it. Because the page style is affected, the changed margins apply to all pages using that style.

To change margins using the rulers:
1) The gray sections of the rulers are the margins. Put the mouse cursor over the line between the gray and white sections. The pointer turns into a double-headed arrow.
2) Hold down the left mouse button and drag the mouse to move the margin.
Tip

The small arrows on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. Place the mouse pointer between the arrows and, when the pointer turns into a double-headed arrow, you can move the margin (the indent arrows will move with it).

To change margins using the Page Style dialog:

1) Right-click anywhere on the page and select **Page** from the pop-up menu.
2) On the **Page** tab of the dialog, type the required distances in the Margins boxes.

Adding comments to a document

Authors and reviewers often use comments (formerly called “notes”) to exchange ideas, ask for suggestions, or mark items needing attention.

To insert a comment in the text, place the cursor in the place the comment refers to and choose **Insert > Comment** or press *Ctrl+Alt+N*. The anchor point of the comment is connected by a dotted line to a box on the right-hand side of the page where you can type the text of the comment. Writer automatically adds at the bottom of the comment the author’s name and a time stamp indicating when the comment was created. Figure 56 shows an example of text with comments from two different authors.

Figure 56: Example of comments
Choose **Tools > Options > User Data** to configure the name you want to appear in the Author field of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different background color.

Right-clicking on a comment pops up a menu where you can delete the current comment, all the comments from the same author, or all the comments in the document. From this menu, you can also apply some basic formatting to the text of the comment. You can also change the font type, size, and alignment from the main menu.

To navigate from one comment to another, open the Navigator (F5), expand the Comments section, and click on the comment text to move the cursor to the anchor point of the comment in the document. Right-click on the comment to quickly edit or delete it.

You can also navigate through the comments using the keyboard. Use **Ctrl+Alt+Page Down** to move to the next comment and **Ctrl+Alt+Page Up** to move to the previous comment.

---

**Creating a table of contents**

Writer’s table of contents feature lets you build an automated table of contents from the headings in your document. Before you start, make sure that the headings are styled consistently. For example, you can use the *Heading 1* style for chapter titles and the *Heading 2* and *Heading 3* styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are all you need. Creating a quick table of contents is simple:

1. When you create your document, use the following paragraph styles for different heading levels (such as chapter and section headings): *Heading 1*, *Heading 2*, *Heading 3*, and so on. These are what will appear in your table of contents.
2. Place the cursor where you want the table of contents to be inserted.
3. Choose **Insert > Indexes and Tables > Indexes and Tables**.
4. Change nothing in the Insert Index/Table dialog. Click **OK**.

If you add or delete text (so that headings move to different pages) or you add, delete, or change headings, you need to update the table of contents.

To do this:

1. Place the cursor within the table of contents.
2. Right-click and choose **Update Index/Table** from the pop-up menu.

---

**Note**

If you cannot place your cursor in the table of contents, choose **Tools > Options > OpenOffice.org Writer > Formatting Aids**, and then select **Enable** in the **Cursor in protected areas** section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose **Edit Index/Table** from the pop-up menu. Chapter 12 (Creating Tables of Contents, Indexes and Bibliographies) of the *Writer Guide* describes in detail all the customizations you can choose.

---

**Creating indexes and bibliographies**

Indexes and bibliographies work in a similar way to tables of contents. Chapter 12 (Creating Tables of Contents, Indexes and Bibliographies) in the *Writer Guide* describes the process in detail.
In addition to alphabetical indexes, other types of indexes supplied with Writer include those for illustrations, tables, and objects, and you can even create a user-defined index. For example, you might want an index containing only the scientific names of species mentioned in the text, and a separate index containing only the common names of species. Before creating some types of indexes, you first need to create index entries embedded in your Writer document.

**Adding images and other graphics**

Graphics in Writer are of three basic types:

- Image files, including photos, drawings, scanned images, and others
- Diagrams created using Apache OpenOffice’s drawing tools
- Charts created using Apache OpenOffice’s Chart facility

See Chapter 10 (Graphics, the Gallery, and Fontwork) in this book and Chapter 8 (Working with Graphics) in the *Writer Guide*.

**Adding tables, spreadsheets, and charts**

Tables are a useful way to organize and present large amounts of information. They can often be used as an alternative to spreadsheets. Tables can also be used as a page layout tool to position text in areas of a document, as described in Chapter 4 (Formatting Pages) of the *Writer Guide*.

To insert a new table, position the cursor where you want the table to appear, then use any of the following methods to open the Insert Table dialog, where you can specify the properties for the new table:

- From the main menu, choose **Insert > Table**.
- From the main menu, choose **Table > Insert > Table**.
- Press **Ctrl+F12** on the keyboard.
- From the Standard toolbar, click the **Table** icon.

You can also click the small arrow to the right of the Table icon and select the number of cells to directly insert a table with the default table properties.

You can create a table from text, or convert a table to text, using **Table > Convert** from the menu bar.

You can edit the contents of these tables in the same way as you edit any other text.

Chapter 9 (Working with Tables) in the *Writer Guide* describes how to format tables, add or delete columns and rows, merge and split tables and cells, add and sort data, and perform basic spreadsheet functions in a table of data.

**Creating a table from a Calc spreadsheet**

You can insert a table from a Calc spreadsheet into a Writer document:

1) Open the Calc spreadsheet containing the cell range that you want to insert.
2) In the spreadsheet, select the cells.
3) Choose **Edit > Copy** or press **Ctrl+C**.
4) In the Writer document, choose **Edit > Paste** or press **Ctrl+V**. The cell range is pasted as an object.
Alternatively, you can open both the Calc and Writer documents and drag and drop the cells from Calc to Writer:

1) In the spreadsheet, select the cells.
2) Click and hold the mouse button in the selected cells.
3) Drag the selected cells into the text document.

To edit a table created from a Calc spreadsheet, double-click on it. The table opens in Calc.

Creating a chart

You can create a chart in three ways:

- Insert a chart based on data from cells in Calc or Writer.
  These charts update automatically when the source data changes.
- Insert a chart with a default data set, and then use the Data Table dialog to enter your own data for that chart.
  These charts can be created in Writer, Impress, and Draw.
- Copy a chart from Calc or Writer into another document.
  These charts are snapshots of the data at the time of copying. They do not change when the source data changes.

To create a chart based on the values in a Writer table:

1) Click inside the Writer table.
2) Choose Insert > Object > Chart. A chart preview and the Chart Wizard are displayed.
3) Follow the instructions in the Chart Wizard to create the chart.

To create a chart based on values of its own:

1) If you have not selected any cells, choose Insert > Object > Chart to insert a chart with default data.
2) You can change the default data values by double-clicking on the chart and then choosing View > Chart Data Table.

For more about working with charts, see the Calc Guide.

Adding a movie or sound

To insert a movie or sound file into your document:

1) Click where you want to insert the file.
2) Choose Insert > Movie and Sound.
3) In the File Open dialog, select the file that you want to insert.
   The file types listed in this dialog are not supported by all operating systems.
4) Click Open.

Alternatively, you can choose Tools > Media Player to open the Media Player. Use the Media Player to preview all supported media files. Click the Apply button in the Media Player window to insert the current media file into your document.

To play a movie or sound file:

1) Click the object icon for the movie or sound file in your document.
   If the icon is arranged on the background, hold down Ctrl while you click.
2) The Media Playback toolbar is shown. Click Play.
You can also use the Media Playback toolbar to pause, stop, or loop, as well as to adjust the volume or mute the playback of the file. For movie files, the toolbar also provides a slider for selecting the zoom factor for the playback.

**Printing**


**Using mail merge**

Writer provides very useful features to create and print:

- Multiple copies of a document to send to a list of different recipients (form letters)
- Mailing labels
- Envelopes

All these facilities use a registered data source (a spreadsheet or database containing the name and address records and other information).

Chapter 11 (Using Mail Merge) in the *Writer Guide* describes the process.

**Tracking changes to a document**

You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, or under a different name, or both), then use Writer to combine the two files and show the differences. Choose Edit > Compare Document. This technique is particularly useful if you are the only person working on the document, as it avoids the increase in file size and complexity caused by the other methods.

2) Save versions that are stored as part of the original file. However, this method can cause problems with documents of non-trivial size or complexity, especially if you save a lot of versions. Avoid this method if you can.

3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you have added or deleted material, or changed formatting. Choose Edit > Changes > Record. Later, you or another person can review and accept or reject each change. Right-click on an individual change and choose Accept Change or Reject Change from the pop-up menu, or choose Edit > Changes > Accept or Reject to view the list of changes and accept or reject them. Details are in the *Writer Guide*.

**Tip**

Not all changes are recorded. For example, changing a tab stop from align left to align right, and changes in formulas (equations) or linked graphics are not recorded.
Using fields

Fields are extremely useful features of Writer. They are used for data that changes in a document (such as the current date or the total number of pages) and for inserting document properties such as name, author, and date of last update. Fields are the basis of cross-referencing (see below); automatic numbering of figures, tables, headings, and other elements; and a wide range of other functions—far too many to describe here. See Chapter 14 (Working with Fields) in the Writer Guide for details.

Linking to another part of a document

If you type in cross-references to other parts of a document, those references can easily get out of date if you reorganize the order of topics, add or remove material, or reword a heading. Writer provides two ways to ensure that your references are up to date, by inserting links to other parts of the same document or to a different document:

- Hyperlinks
- Cross-references

The two methods have the same result if you Control+click the link when the document is open in Writer: you are taken directly to the cross-referenced item. However, they also have major differences:

- The text in a hyperlink does not automatically update if you change the text of the linked item (although you can change it manually), but changed text does automatically update in a cross-reference.
- When using a hyperlink, you do not have a choice of the content of the link (for example text or page number), but when using a cross-reference, you have several choices, including bookmarks.
- To hyperlink to an object such as a graphic, and have the hyperlink show useful text such as Figure 6, you need to either give such an object a useful name instead of leaving it as the default name (Graphics6), or you need to use the Hyperlink dialog to modify the visible text. In contrast, cross-references to figures with captions automatically show useful text, and you have a choice of several variations of the name.
- If you save a Writer document to HTML, hyperlinks remain active but cross-references do not. (Both remain active when the document is exported to PDF.)

Using hyperlinks

The easiest way to insert a hyperlink to another part of the same document is by using the Navigator:

1) Open the document containing the items you want to cross-reference.
2) Open the Navigator by clicking its icon, choosing View > Navigator, or pressing F5.
3) Click the arrow next to the Drag Mode icon, and choose Insert as Hyperlink.
4) In the list at the bottom of the Navigator, select the document containing the item that you want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the item is inserted in the document as an active hyperlink.

You can also use the Hyperlink dialog to insert and modify hyperlinks within and between documents.
Using cross-references

If you type in references to other parts of the document, those references can easily get out of date if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-references with automatic ones and, when you update fields, all the references will update automatically to show the current wording or page numbers. The Cross-references tab of the Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items such as steps in a procedure. You can also create your own reference items; see “Setting References” in Chapter 14 (Working with Fields) in the Writer Guide for instructions.

To insert a cross-reference to a heading, figure, bookmark, or other item:

1) In your document, place the cursor where you want the cross-reference to appear.

2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references tab, in the Type list, select the type of item to be referenced (for example, Heading or Figure). You can leave this page open while you insert many cross-references.

3) Click on the required item in the Selection list, which shows all the items of the selected type. In the Format list, choose the format required. Usually this will be Reference (to insert the full text of the heading or caption), Category and Number (to insert the word “Figure” or “Table” and its number, but without the caption text), Numbering (to insert only the figure or table number, without the word “Figure” or “Table”), or Page (to insert the number of the page the referenced text is on). Click Insert.
Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described above.

1) Select the text you want to bookmark. Click Insert > Bookmark.
2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type a name for this bookmark in the top box, and then click OK.
Using master documents

Master documents are typically used for producing long documents such as a book, a thesis, or a long report; or when different people are writing different chapters or other parts of the full document, so you don't need to share files. A master document joins separate text documents into one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and other tables or lists.

Yes, master documents do work in Writer. However, until you become familiar with them, you may think that master documents are unreliable or difficult to use. See Chapter 13 (Working with Master Documents) in the *Writer Guide*.

Creating fill-in forms

A standard text document displays information: a letter, report, or brochure, for example. Typically the reader may edit everything or nothing in any way. A form has sections that are not to be edited, and other sections that are designed for the reader to make changes. For example, a questionnaire has an introduction and questions (which do not change) and spaces for the reader to enter answers.

Forms are used in three ways:

- To create a simple document for the recipient to complete, such as a questionnaire sent out to a group of people who fill it in and return it.
- To link into a database or data source and allow the user to enter information. Someone taking orders might enter the information for each order into a database using a form.
- To view information held in a database or data source. A librarian might call up information about books.

Writer offers several ways to fill information into a form, including check boxes, option buttons, text boxes, pull-down lists and spinners. See Chapter 15 (Using Forms in Writer) in the *Writer Guide*.
What is Calc?

Calc is the spreadsheet component of Apache OpenOffice. You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce certain results.

Alternatively you can enter data and then use Calc in a ‘What if…’ manner by changing some of the data and observing the results without having to retype the entire spreadsheet.

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex calculations on data
• Database functions, to arrange, store, and filter data
• Dynamic charts; a wide range of 2D and 3D charts
• Macros, for recording and executing repetitive tasks
• Ability to open, edit, and save Microsoft Excel spreadsheets
• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and PostScript

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in Apache OpenOffice, you must first edit the code in the OpenOffice.org Basic IDE editor. See Chapter 12 in the Calc Guide.

Spreadsheets, sheets and cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by its row number and column letter.

Cells hold the individual elements—text, numbers, formulas, and so on—that make up the data to display and manipulate.

Each spreadsheet can have many sheets, and each sheet can have many individual cells. In Calc 3.4, each sheet can have a maximum of 1,048,576 rows and 1024 columns.

Parts of the main Calc window

When Calc is started, the main window looks similar to Figure 60.
Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the spreadsheet is newly created, its name is *Untitled X*, where *X* is a number. When you save a spreadsheet for the first time, you are prompted to enter a name of your choice.

Menu bar

Under the Title bar is the Menu bar. (On a Mac, the Menu bar is at the top of the screen, above the Title bar, the same location as for other Mac applications.) When you choose one of the menus, a submenu appears with other options. You can modify the Menu bar, as discussed in Chapter 11 (Setting up and Customizing Apache OpenOffice).

![Parts of the Calc window](image)

Figure 60: Parts of the Calc window

Toolbars

Three toolbars are located under the Menu bar by default: the Standard toolbar, the Formatting toolbar, and the Formula Bar.

The icons (buttons) on these toolbars provide a wide range of common commands and functions. You can also modify these toolbars, as discussed in Chapter 11 (Setting Up and Customizing Apache OpenOffice).

In the Formatting toolbar, the three boxes on the left are the **Apply Style**, **Font Name**, and **Font Size** lists. They show the current setting for the selected cell or area. (The Apply Style list may not be visible by default.) Click the down-arrow to the right of each box to open the list.

![Apply Style, Font Name and Font Size lists](image)

Figure 61. Apply Style, Font Name and Font Size lists
**Formula bar**

On the left hand side of the Formula bar is a small text box, called the **Name Box**, with a letter and number combination in it, such as D7. This combination, called the cell reference, is the column letter and row number of the selected cell.

To the right of the Name box are the **Function Wizard**, **Sum**, and **Function** buttons.

Clicking the **Function Wizard** button opens a dialog from which you can search through a list of available functions. This can be very useful because it also shows how the functions are formatted.

![Formula Bar Diagram](image)

Figure 62. Formula Bar

In a spreadsheet the term **function** covers much more than just mathematical functions. See Chapter 7 in the *Calc Guide* for more details.

Clicking the **Sum** button inserts a formula into the current cell that totals the numbers in the cells above the current cell. If there are no numbers above the current cell, then the cells to the left are placed in the Sum formula.

Clicking the **Function** button inserts an equals (=) sign into the selected cell and the Input line, thereby enabling the cell to accept a formula.

When you enter new data into a cell, the Sum and Equals buttons change to **Cancel** and **Accept** buttons.

The contents of the current cell (data, formula, or function) are displayed in the **Input line**, which forms the remainder of the Formula Bar. You can edit the contents of the current cell on the Input line or in the cell itself. To edit on the Input line, click in the line, then type your changes. To edit within the current cell, just double-click the cell.

**Individual cells**

The main section of the screen displays the cells in the form of a grid, with each cell being at the intersection of a column and a row.

At the top of the columns and at the left end of the rows are a series of gray boxes containing letters and numbers. These are the column and row headers. The columns start at A and go on to the right, and the rows start at 1 and go down.

These column and row headers form the cell references that appear in the Name Box on the Formula Bar (Figure 62). You can turn these headers off by selecting **View > Column & Row Headers**.

**Sheet tabs**

At the bottom of the grid of cells are the sheet tabs. These tabs enable access to each individual sheet, with the visible (active) sheet having a white tab. You can choose colors for the different sheet tabs by right-clicking the space, choosing Tab Color, and choosing a color from the palette.

Clicking on another sheet tab displays that sheet, and its tab turns white. You can also select multiple sheet tabs at once by holding down the **Control** key while you click the names.
Status bar

At the very bottom of the Calc window is the status bar, which provides information about the spreadsheet and convenient ways to quickly change some of its features. Most of the fields are similar to those in other components of Apache OpenOffice; see Chapter 1 (Introducing Apache OpenOffice) in this book and Chapter 1 (Introducing Calc) in the Calc Guide.

Opening and saving CSV files

Chapter 1 (Introducing Apache OpenOffice) includes instructions on starting new Calc documents, opening existing documents, and saving documents.

A special case for Calc is opening and saving comma-separated-values (CSV), which are text files that contain the cell contents of a single sheet. Each line in a CSV file represents a row in a spreadsheet. Commas, semicolons, or other characters are used to separate the cells. Text is entered in quotation marks, numbers are entered without quotation marks.
Opening a CSV file

To open a CSV file in Calc:

1) Choose File > Open.
2) Locate the CSV file that you want to open.
3) If the file has a *.csv extension, select the file and click Open.
4) If the file has another extension (for example, *.txt), select the file, select Text CSV (*csv;*txt;*xls) in the File type box (scroll down into the spreadsheet section to find it) and then click Open.
5) On the Text Import dialog (Figure 66), select the Separator options to divide the text in the file into columns.
   You can preview the layout of the imported data at the bottom of the dialog. Right-click a column in the preview to set the format or to hide the column.
   If the CSV file uses a text delimiter character that is not in the Text delimiter list, click in the box, and type the character.
6) Click OK to open the file.

Figure 66: Text Import dialog, with Comma (,) selected as the separator and double quotation mark (") as the text delimiter.
**Saving as a CSV file**

To save a spreadsheet as a comma separate value (CSV) file:

1) Choose **File > Save As**.
2) In the **File name** box, type a name for the file.
3) In the **File type** list, select **Text CSV (.csv)** and click **Save**.
   You may see the message box shown below. Click **Keep Current Format**.

4) In the **Export of text files** dialog, select the options you want and then click **OK**.

![Image of Save as CSV dialog]

**Figure 67: Choosing options when exporting to Text CSV**

**Navigating within spreadsheets**

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You can generally use whatever method you prefer.

**Going to a particular cell**

**Using the mouse**
Place the mouse pointer over the cell and click.

**Using a cell reference**
Click on the little inverted black triangle just to the right of the Name Box (Figure 62). The existing cell reference will be highlighted. Type the cell reference of the cell you want to go to.
and press Enter. Or just click into the Name box, backspace over the existing cell reference and type in the cell reference you want and press Enter.

**Using the Navigator**

To open the Navigator, click its icon on the Standard toolbar, or press F5, or choose View > Navigator on the Menu bar, or double-click on the Sheet Sequence Number in the Status Bar. Type the cell reference into the top two fields, labeled Column and Row, and press Enter. In Figure 68 the Navigator would select cell A7.

You can dock the Navigator to either side of the main Calc window or leave it floating. (To dock or float the Navigator, hold down the Control key and double-click in an empty area near the icons in the Navigator dialog.)

![Figure 68: The Navigator in Calc](image)

The Navigator displays lists of all the objects in a document, grouped into categories. If an indicator (plus sign or arrow) appears next to a category, at least one object of this kind exists. To open a category and see the list of items, click on the indicator.

To hide the list of categories and show only the icons at the top, click the Contents icon. Click this icon again to show the list.

**Moving from cell to cell**

In the spreadsheet, one cell normally has a darker black border. This black border indicates where the focus is (see Figure 69). If a group of cells is selected, they have a highlight color (usually gray), with the focus cell having a dark border.

**Using the mouse**

To move the focus using the mouse, simply move the mouse pointer to the cell where you want the focus to be and click the left mouse button. This changes the focus to the new cell. This method is most useful when the two cells are a large distance apart.
Using the Tab and Enter keys

- Pressing `Enter` or `Shift+Enter` moves the focus down or up, respectively.
- Pressing `Tab` or `Shift+Tab` moves the focus to the right or to the left, respectively.

![Figure 69](image)

(Left) One selected cell and (right) a group of selected cells

Using the arrow keys

Pressing the arrow keys on the keyboard moves the focus in the direction of the arrows.

Using Home, End, Page Up and Page Down

- `Home` moves the focus to the start of a row.
- `End` moves the focus to the column furthest to the right that contains data.
- `Page Down` moves the display down one complete screen and `Page Up` moves the display up one complete screen.
- Combinations of Control and Alt with Home, End, Page Down, Page Up, and the cursor keys move the focus of the current cell in other ways. See the Help or Appendix A (Keyboard Shortcuts) in the Calc Guide for details.

**Tip**

Use one of the four Alt+Arrow key combinations to resize a cell.

Customizing the Enter key

You can customize the direction in which the `Enter` key moves the focus, by selecting Tools > Options > OpenOffice.org Calc > General.

The four choices for the direction of the `Enter` key are shown on the right hand side of Figure 70. It can move the focus down, right, up, or left. Depending on the file being used or on the type of data being entered, setting a different direction can be useful.

The `Enter` key can also be used to switch into and out of editing mode. Use the first two options under Input settings in Figure 70 to change the `Enter` key settings.
Moving from sheet to sheet

Each sheet in a spreadsheet is independent of the others, though they can be linked with references from one sheet to another. There are three ways to navigate between different sheets in a spreadsheet.

**Using the Navigator**
When the Navigator is open (Figure 68), double-clicking on any of the listed sheets selects the sheet.

**Using the keyboard**
Pressing `Control+Page Down` moves one sheet to the right and pressing `Control+Page Up` moves one sheet to the left.

**Using the mouse**
Clicking on one of the sheet tabs at the bottom of the spreadsheet selects that sheet.

If you have a lot of sheets, then some of the sheet tabs may be hidden behind the horizontal scrollbar at the bottom of the screen. If this is the case, then the four buttons at the left of the sheet tabs can move the tabs into view. Figure 71 shows how to do this.

Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary; you can name a sheet as you wish.

**Note**
The sheet tab arrows that appear in Figure 71 only appear if you have some sheet tabs that are hidden by the horizontal scrollbar. Otherwise, they will appear faded as in Figure 60.
Selecting items in a sheet or spreadsheet

Selecting cells
Cells can be selected in a variety of combinations and quantities.

Single cell
Left-click in the cell. The result will look like the left side of Figure 69. You can verify your selection by looking in the Name box.

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.
To select a range of cells by dragging the mouse:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

The result of any of these methods looks like the right side of Figure 69.

Tip
You can also directly select a range of cells using the Name box. Click into the Name Box as described in "Using a cell reference" on page 84. To select a range of cells, enter the cell reference for the upper left-hand cell, followed by a colon (:), and then the lower right-hand cell reference. For example, to select the range that would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Control key and click or click-and-drag to select a range.
4) Repeat as necessary.

Selecting columns and rows
Entire columns and rows can be selected very quickly in Apache OpenOffice.

Single column or row
To select a single column, click on the column identifier letter (see Figure 60).
To select a single row, click on the row identifier number.
Multiple columns or rows
To select multiple columns or rows that are contiguous:
   1) Click on the first column or row in the group.
   2) Hold down the Shift key.
   3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
   1) Click on the first column or row in the group.
   2) Hold down the Control key.
   3) Click on all of the subsequent columns or rows while holding down the Control key.

Entire sheet
To select the entire sheet, click on the small box between the A column header and the 1 row header. You can also press Control+A to select the entire sheet.

Selecting sheets
You can select either one or multiple sheets. It can be advantageous to select multiple sheets at times when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The active sheet becomes white (see Figure 73).

Multiple contiguous sheets
To select multiple contiguous sheets:
   1) Click on the sheet tab for the first desired sheet.
   2) Move the mouse pointer over the sheet tab for the last desired sheet.
   3) Hold down the Shift key and click on the sheet tab.
All the tabs between these two sheets will turn white. Any actions that you perform will now affect all highlighted sheets.

Multiple non contiguous sheets
To select multiple non contiguous sheets:
   1) Click on the sheet tab for the first sheet.
   2) Move the mouse pointer over the second sheet tab.
   3) Hold down the Control key and click on the sheet tab.
   4) Repeat as necessary.
The selected tabs will turn white. Any actions that you perform will now affect all highlighted sheets.

All sheets
Right-click any one of the sheet tabs and choose Select All Sheets from the pop-up menu.
Working with columns and rows

Inserting columns and rows
Columns and rows can be inserted individually or in groups.

Note When you insert a single new column, it is inserted to the left of the highlighted column. When you insert a single new row, it is inserted above the highlighted row.
Cells in the new columns or rows are formatted like the corresponding cells in the column or row before (or to the left of) which the new column or row is inserted.

Single column or row
Using the Insert menu:
1) Select the cell, column or row where you want the new column or row inserted.
2) Choose either Insert > Columns or Insert > Rows.

Using the mouse:
1) Select the cell, column or row where you want the new column or row inserted.
2) Right-click the header of the column or row.
3) Choose Insert Rows or Insert Columns.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button on the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above.

Deleting columns and rows
Columns and rows can be deleted individually or in groups.

Single column or row
A single column or row can only be deleted by using the mouse:
1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Columns or Delete Rows from the pop-up menu.

Multiple columns or rows
Multiple columns or rows can be deleted at once rather than deleting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button on the first one and then dragging across the required number of identifiers.
2) Proceed as for deleting a single column or row above.
Working with sheets

Like any other Calc element, sheets can be inserted, deleted, and renamed.

Inserting new sheets

There are several ways to insert a new sheet. The first step for all of the methods is to select the sheets that the new sheet will be inserted next to. Then any of the following options can be used.

- Choose Insert > Sheet from the menu bar.
- Right-click on the sheet tab and choose Insert Sheet.
- Click in an empty space at the end of the line of sheet tabs.

![Figure 73. Creating a new sheet](image)

Each method will open the Insert Sheet dialog (Figure 74). Here you can select whether the new sheet is to go before or after the selected sheet and how many sheets you want to insert. If you are inserting only one sheet, there is the opportunity to give the sheet a name.

![Figure 74. Insert Sheet dialog](image)

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by using either the mouse (drag and drop) or a dialog. Drag and drop does not work if you wish to move or copy a sheet to a different spreadsheet; instead, you need to use the dialog.

Using the mouse

To move a sheet to a different position within the same spreadsheet, click on the sheet tab and drag it left or right. Two little triangles indicate where the sheet will be dropped (see Figure 75). The
mouse pointer (not shown in the illustration) may change to include an indicator; the indicator symbol varies with your operating system.

![Sheet1 Sheet2 Sheet3](image)

*Figure 75: Dragging a sheet to move it*

To *copy* a sheet within the same spreadsheet, hold down the *Control* key (*Option* key on Mac) while you click on the sheet tab and drag it. The mouse pointer may change to include a plus sign or other indicator; the symbol varies with your operating system.

**Using a dialog**

The Move/Copy dialog provides the opportunity to specify exactly where you want the sheet to go (in the same or a different document), at the same time as moving or copying occurs.

**Note**

When moving or copying sheets between different spreadsheets, be sure that both documents are open.

Follow these steps:

1. In the current document, right-click on the sheet tab you wish to move or copy.
2. Select *Move/Copy Sheet* from the context menu.
3. On the Move/Copy Sheet dialog (Figure 76):
   - Select or deselect the *Copy* option at the bottom.
   - **To document**: select the document in which you want to place the sheet. By default, the field will show the current document. If you have another spreadsheet open, its name will appear in the drop-down list along with *-new document-*.
   - **Insert before**: select the position within the target document.
4. When you are done, click *OK*.

![Move/Copy Sheet dialog](image)

*Figure 76: Move/Copy Sheet dialog*
Caution

If you choose -new document- as the location, a new spreadsheet will be created. This may cause conflicts with formulas linked to other sheets in the previous location. If you accidentally move a sheet, you can fix it by moving or copying the sheet back to the original location.

This caution also apply for moving sheets to other existing documents.

Deleting sheets

Sheets can be deleted individually or in groups.

Single sheet
Right-click on the tab of the sheet you want to delete and choose Delete Sheet from the pop-up menu, or chose Edit > Sheet > Delete from the menu bar.

Multiple sheets
To delete multiple sheets, select them as described earlier, then either right-click over one of the tabs and select Delete Sheet from the pop-up menu, or choose Edit > Sheet > Delete from the menu bar.

Renaming sheets

The default name for the a new sheet is SheetX, where X is a number. While this works for a small spreadsheet with only a few sheets, it becomes awkward when there are many sheets.

To give a sheet a more meaningful name, you can:

• Enter the name in the Name box when you create the sheet, or
• Right-click on a sheet tab and choose Rename Sheet from the pop-up menu; replace the existing name with a better one.
• Double-click on a sheet tab to pop up the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number. Apart from the first character of the sheet name, allowed characters are letters, numbers, spaces, and the underline character. Attempting to rename a sheet with an invalid name will produce an error message.

Viewing Calc

Using zoom
Use the zoom function to change the view to show more or fewer cells in the window. For more about zoom, see Chapter 1 (Introducing Apache OpenOffice) in this book.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of a spreadsheet or both. Then when scrolling around within the sheet, any frozen columns and rows remain in view.

Figure 77 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 14 and the heavier vertical line between columns C and H denote the frozen areas. Rows 4
through 13 and columns D through G have been scrolled off the page. The first three rows and columns remained because are frozen into place.

You can set the freeze point at a row, a column, or both a row and a column as in Figure 77.

**Freezing single rows or columns**

1) Click on the header for the row below where you want the freeze or for the column to the right of where you want the freeze.

2) Choose Window > Freeze.

   A dark line appears, indicating where the freeze is put.

**Freezing a row and a column**

1) Click into the cell that is immediately below the row you want frozen and immediately to the right of the column you want frozen.

2) Choose Window > Freeze.

   Two lines appear on the screen, a horizontal line above this cell and a vertical line to the left of this cell. Now as you scroll around the screen, everything above and to the left of these lines will remain in view.

**Unfreezing**

To unfreeze rows or columns, choose Window > Freeze. The check mark by Freeze will vanish.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Safety Poster</td>
<td>Safety Quiz 2</td>
</tr>
<tr>
<td>2</td>
<td>Total</td>
<td>Date</td>
</tr>
<tr>
<td>3</td>
<td>Average</td>
<td>Possible</td>
</tr>
<tr>
<td>14</td>
<td>78.6%</td>
<td>Smith, John</td>
</tr>
<tr>
<td>15</td>
<td>67.9%</td>
<td>Klein, Mike</td>
</tr>
<tr>
<td>16</td>
<td>72.7%</td>
<td>Johnson, Tom</td>
</tr>
<tr>
<td>17</td>
<td>82.6%</td>
<td>Doe, John</td>
</tr>
<tr>
<td>18</td>
<td>86.4%</td>
<td>Doe, Jane</td>
</tr>
<tr>
<td>19</td>
<td>67.3%</td>
<td>Kaplan, Peter</td>
</tr>
<tr>
<td>20</td>
<td>83.9%</td>
<td>Newton, Isaac</td>
</tr>
<tr>
<td>21</td>
<td>80.8%</td>
<td>Sharak, Robert</td>
</tr>
<tr>
<td>22</td>
<td>73.1%</td>
<td>Matthews, Brittany</td>
</tr>
<tr>
<td>23</td>
<td>79.4%</td>
<td>Murphy, Kathleen</td>
</tr>
</tbody>
</table>

*Figure 77. Frozen rows and columns*

**Splitting the screen**

Another way to change the view is by splitting the window, also known as splitting the screen. The screen can be split either horizontally or vertically or both. You can therefore have up to four portions of the spreadsheet in view at any one time.

Why would you want to do this? Imagine you have a large spreadsheet and one of the cells has a number in it which is used by three formulas in other cells. Using the split screen technique, you can position the cell containing the number in one section and each of the cells with formulas in the other sections. Then you can change the number in the cell and watch how it affects each of the formulas.
Splitting the screen horizontally

To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of the screen, and place it over the small button at the top with the black triangle. Immediately above this button you will see a thick black line.

2) Move the mouse pointer over this line and it turns into a line with two arrows, as in Figure 80.

3) Hold down the left mouse button. A gray line appears, running across the page. Drag the mouse downwards and this line follows.

4) Release the mouse button and the screen splits into two views, each with its own vertical scroll bar. You can scroll the upper and lower parts independently.

Notice in Figure 78, the Beta and the A0 values are in the upper part of the window and other calculations are in the lower part. Thus you can make changes to the Beta and A0 values and watch their affects on the calculations in the lower half of the window.
### Tip
You can also split the screen using a menu command. Click in a cell immediately below and to the right of where you wish the screen to be split, and choose `Window > Split`.

### Splitting the screen vertically
To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the bottom of the screen and place it over the small button on the right with the black triangle. Immediately to the right of this button is a thick black line.

![Split screen bar](image)

*Figure 81: Split bar on horizontal scroll bar*

2) Move the mouse pointer over this line and it turns into a line with two arrows.

3) Hold down the left mouse button, and a gray line appears, running up the page. Drag the mouse to the left and this line follows.

4) Release the mouse button and the screen is split into two views, each with its own horizontal scroll bar. You can scroll the left and right parts of the window independently.

### Removing split views
To remove a split view, do any of the following:

- Double-click on each split line.
- Click on and drag the split lines back to their places at the ends of the scroll bars.
- Choose `Window > Split` to remove all split lines at the same time.

### Entering data using the keyboard
Most data entry in Calc can be accomplished using the keyboard.

### Entering numbers
Click in the cell and type in the number using the number keys on either the main keyboard or the numeric keypad.

To enter a negative number, either type a minus (–) sign in front of it or enclose it in parentheses (brackets), like this: (1234).

By default, numbers are right-aligned and negative numbers have a leading minus symbol.

### Note
If a number beginning with 0 is entered in to a cell, Calc will drop the 0 (for example 01234 becomes 1234).
To enter a number and retain the leading 0, right-click on the cell and choose **Format Cells > Numbers**. In the Format Cells dialog (Figure 82), under **Options** select the required number of **Leading zeros**.

The number selected for leading zeros needs to be one higher than the digits in a number. For example, if the number is 1234, the number entered for the leading zero will be 5.

**Entering text**

Click in the cell and type the text. Text is left-aligned by default.

**Entering numbers as text**

A number can be entered as text to preserve a leading zero by entering an apostrophe before the number, like this: ‘01481.

The data is now regarded as text by Calc and displayed exactly as entered. Typically, formulas will treat the entry as a zero and functions will ignore it. Take care that the cell containing the number is not used in a formula.

---

**Note**

If “smart quotes” are used for apostrophes, the apostrophe remains visible in the cell.

To choose the type of apostrophe, use **Tools > AutoCorrect > Custom Quotes**. The selection of the apostrophe type affects both Calc and Writer.

**Entering dates and times**

Select the cell and type the date or time. You can separate the date elements with a slant (/) or a hyphen (–) or use text such as 10 Oct 03. Calc recognizes a variety of date formats. You can separate time elements with colons such as 10:43:45.
Deactivating automatic changes
Calc automatically applies many changes during data input, unless you deactivate those changes. You can also immediately undo any automatic changes with Ctrl+Z.

AutoCorrect changes
Automatic correction of typing errors, replacement of straight quotation marks by curly (custom) quotes, and starting cell content with an uppercase (capital letter) are controlled by Tools > AutoCorrect Options. Go to the Custom Quotes, Options, or Replace tabs to deactivate any of the features that you do not want. On the Replace tab, you can also delete unwanted word pairs and add new ones as required.

AutoInput
When you are typing in a cell, Calc automatically suggests matching input found in the same column. To turn the AutoInput on and off, set or remove the check mark in front of Tools > Cell Contents > AutoInput.

Automatic date conversion
Calc automatically converts certain entries to dates. To ensure that an entry that looks like a date is interpreted as text, type an apostrophe at the beginning of the entry. The apostrophe is not displayed in the cell.

Speeding up data entry
Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for removing some of the drudgery from input.

The most basic ability is to drop and drag the contents of one cell to another with a mouse. Calc also includes several other tools for automating input, especially of repetitive material. They include the Fill tool, selection lists, and the ability to input information into multiple sheets of the same document.

Using the Fill tool on cells
At its simplest, the Fill tool is a way to duplicate existing content. Start by selecting the cell to copy, then drag the mouse in any direction (or hold down the Shift key and click in the last cell you want to fill), and then choose Edit > Fill and the direction in which you want to copy: Up, Down, Left or Right.

Caution
Choices that are not available are grayed out, but you can still choose the opposite direction from what you intend, which could cause you to overwrite cells accidentally.

Tip
A shortcut way to fill cells is to grab the “handle” in the lower right-hand corner of the cell and drag it in the direction you want to fill. If the cell contains a number, the number will fill in series. If the cell contains text, the same text will fill in the direction you chose.
Using a fill series

A more complex use of the Fill tool is to use a fill series. The default lists are for the full and abbreviated days of the week and the months of the year, but you can create your own lists as well.

To add a fill series to a spreadsheet, select the cells to fill, choose Edit > Fill > Series. In the Fill Series dialog (Figure 84), select AutoFill as the Series type, and enter as the Start value an item from any defined series. The selected cells then fill in the other items on the list sequentially, repeating from the top of the list when they reach the end of the list.

You can also use Edit > Fill > Series to create a one-time fill series for numbers by entering the start and end values and the increment. For example, if you entered start and end values of 1 and 7 with an increment of 2, you would get the sequence of 1, 3, 5, 7.

In all these cases, the Fill tool creates only a momentary connection between the cells. Once they are filled, the cells have no further connection with one another.
Defining a fill series

To define your own fill series:

1) Go to **Tools > Options > OpenOffice.org Calc > Sort Lists**. This dialog shows the previously-defined series in the *Lists* box on the left, and the contents of the highlighted list in the *Entries* box.

2) Click **New**. The *Entries* box is cleared.

3) Type the series for the new list in the *Entries* box (one entry per line). Click **Add**. The new list will now appear in the *Lists* box.

4) Click **OK** at the bottom of the dialog to save the new list.
Using selection lists

Selection lists are available only for text, and are limited to using only text that has already been entered in the same column.

To use a selection list, select a blank cell and press Ctrl+D. A drop-down list appears of any cell in the same column that either has at least one text character or whose format is defined as Text. Click on the entry you require.

Validating cell contents

When creating spreadsheets for other people to use, you may want to make sure they enter data that is valid or appropriate for the cell. You can also use validation in your own work as a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but they are limited to predefined information. To validate new data entered by a user, select a cell and use Data > Validity to define the type of contents that can be entered in that cell. For example, a cell might require a date or a whole number, with no alphabetic characters or decimal points; or a cell may not be left empty.

Depending on how validation is set up, the tool can also define the range of contents that can be entered and provide help messages that explain the content rules you have set up for the cell and what users should do when they enter invalid content. You can also set the cell to refuse invalid content, accept it with a warning, or start a macro when an error is entered.

See Chapter 2 (Entering, Editing, and Formatting Data) in the Calc Guide for more information.

Editing data

Editing data is done in much the same way as entering data. The first step is to select the cell containing the data to be edited.

Removing data from a cell

Data can be removed (deleted) from a cell in several ways.

Removing data only

The data alone can be removed from a cell without removing any of the formatting of the cell. Click in the cell to select it, and then press the Backspace key.

Removing data and formatting

The data and the formatting can be removed from a cell at the same time. Press the Delete key (or right-click and choose Delete Contents, or use Edit > Delete Contents) to open the Delete Contents dialog. From this dialog, the different aspects of the cell can be deleted. To delete everything in a cell (contents and format), check Delete all.
Replacing all the data in a cell

To remove data and insert new data, simply type over the old data. The new data will retain the original formatting.

Changing part of the data in a cell

Sometimes it is necessary to change the contents of a cell without removing all of the contents, for example if the phrase “See Dick run” is in a cell and it needs to be changed to “See Dick run fast.” It is often useful to do this without deleting the old cell contents first.

The process is the similar to the one described above, but you need to place the cursor inside the cell. You can do this in two ways.

Using the keyboard

After selecting the appropriate cell, press the F2 key and the cursor is placed at the end of the cell. Then use the keyboard arrow keys to move the cursor through the text in the cell.

Using the mouse

Using the mouse, either double-click on the appropriate cell (to select it and place the cursor inside it for editing), or single-click to select the cell and then move the mouse pointer up to the input line and click into it to place the cursor for editing.

Formatting data

The data in Calc can be formatted in several ways. It can either be edited as part of a cell style so that it is automatically applied, or it can be applied manually to the cell. Some manual formatting can be applied using toolbar icons. For more control and extra options, select the appropriate cell or cells, right-click on it, and select Format Cells. All of the format options are discussed below.

Note

All the settings discussed in this section can also be set as a part of the cell style. See Chapter 4 (Using Styles and Templates in Calc) in the Calc Guide for more information.
Formatting multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line breaks. Each method is useful for different situations.

**Using automatic wrapping**

To set text to wrap at the end of the cell, right-click on the cell and select **Format Cells** (or choose **Format > Cells** from the menu bar, or press **Ctrl+1**). On the **Alignment** tab (Figure 89), under Properties, select **Wrap text automatically** and click **OK**. The results are shown in Figure 90.

![Format Cells > Alignment dialog](image)

**Figure 89: Format Cells > Alignment dialog**

| This cell is not set to wrap text automatically. So they text will just keep going. |   |
| This cell is set to wrap text automatically. The cell will fit more text without getting wider |

**Figure 90: Automatic text wrap**

**Using manual line breaks**

To insert a manual line break while typing in a cell, press **Ctrl+Enter**. This method does not work with the cursor in the input line. When editing text, first double-click the cell, then single-click at the position where you want the line break.

When a manual line break is entered, the cell width does not change. Figure 91 shows the results of using two manual line breaks after the first line of text.
Figure 91: Cell with manual line breaks

This line contains manual line breaks.

Lines can be spaced out this way.

Also, the cell width doesn't change but the text can go on.

Figure 92: Shrinking font size to fit cells

Shrinking text to fit the cell

The font size of the data in a cell can automatically adjust to fit in a cell. To do this, select the **Shrink to fit cell size** option in the Format Cells dialog (Figure 89). Figure 92 shows the results.

<table>
<thead>
<tr>
<th>2</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The quick brown fox jumps over the lazy dog.</td>
<td>The quick brown fox jumps over the lazy dog.</td>
</tr>
<tr>
<td>3</td>
<td>The quick brown fox jumps over the lazy dog.</td>
<td>The quick brown fox jumps over the lazy dog.</td>
</tr>
<tr>
<td>4</td>
<td>The quick brown fox jumps over the lazy dog.</td>
<td>The quick brown fox jumps over the lazy dog.</td>
</tr>
</tbody>
</table>

Figure 93: Number format icons. Left to right: currency, percentage, date, exponential, standard, add decimal place, delete decimal place.

Formatting numbers

Several different number formats can be applied to cells by using icons on the Formatting toolbar. Select the cell, then click the relevant icon.

For more control or to select other number formats, use the **Numbers** tab (Figure 94) of the Format Cells dialog:

- Apply any of the data types in the Category list to the data.
- Control the number of decimal places and leading zeros.
- Enter a custom format code.

The Language setting controls the local settings for the different formats such as the date order and the currency marker.
Formatting the font

To quickly choose the font used in a cell, select the cell, then click the arrow next to the Font Name box on the Formatting toolbar and choose a font from the list.

Tip

To choose whether to show the font names in their font or in plain text, go to Tools > Options > OpenOffice.org > View and select or deselect the Show preview of fonts option in the Font Lists section. For more information, see Chapter 11 (Setting Up and Customizing Apache OpenOffice).

To choose the size of the font, click the arrow next to the Font Size box on the Formatting toolbar. For other formatting, you can use the Bold, Italic, or Underline icons.

To choose a font color, click the arrow next to the Font Color icon to display a color palette. Click on the required color.

(To define custom colors, use Tools > Options > OpenOffice.org > Colors. See Chapter 11.)

To specify the language of the cell (useful because it allows different languages to exist in the same document and be spell checked correctly), use the Font tab of the Format Cells dialog. Use the Font Effects tab to set other font characteristics. See Chapter 4 (Using Styles and Templates in Calc) of the Calc Guide for more information.

Formatting the cell borders

To add a border to a cell (or group of selected cells) click on the Borders icon on the formatting toolbar, and select one of the border options displayed in the palette.
To quickly choose a line style and color for the borders of a cell, click the small arrows next to the Line Style and Line Color icons on the Formatting toolbar. In each case, a palette of choices is displayed.

For more controls, including the spacing between the cell borders and the text, use the Borders tab of the Format Cells dialog. There you can also define a shadow. See Chapter 4 (Using Styles and Templates in Calc) of the Calc Guide for details.

**Note**
The cell border properties apply to a cell, and can only be changed if you are editing that cell. For example, if cell C3 has a top border (which would be equivalent visually to a bottom border on C2), that border can only be removed by selecting C3. It cannot be removed in C2.

**Formatting the cell background**
To quickly choose a background color for a cell, click the small arrow next to the Background Color icon on the Formatting toolbar. A palette of color choices, similar to the Font Color palette, is displayed.

(To define custom colors, use Tools \> Options \> OpenOffice.org \> Colors. See Chapter 11 for more information.)

You can also use the Background tab of the Format Cells dialog. See Chapter 4 (Using Styles and Templates in Calc) of the Calc Guide for details.

**Autoformatting cells and sheets**
You can use the AutoFormat feature to quickly apply a set of cell formats to a sheet or a selected cell range.

1) Select the cells, including the column and row headers, that you want to format.

2) Choose Format \> AutoFormat.

![AutoFormat dialog box](image)

**Figure 95: Choosing an AutoFormat**
Note  The AutoFormat feature can only be applied if the selected set of cells consist of at least 3 columns and 3 rows and includes the column and row headers.

3) To select which properties (number format, font, alignment, borders, pattern, autofit width and height) to include in an AutoFormat, click More. Select or deselect the required options.
4) Click OK.

If you do not see any change in color of the cell contents, choose View > Value Highlighting from the menu bar.

Defining a new AutoFormat

You can define a new AutoFormat that is available to all spreadsheets.

1) Format a sheet (in the style for the new AutoFormat).
2) Choose Edit > Select All.
3) Choose Format > AutoFormat. The Add button is now active.
4) Click Add.
5) In the Name box of the Add AutoFormat dialog, type a meaningful name for the new format.
6) Click OK to save. The new format is now available in the Format list in the AutoFormat dialog.

Formatting spreadsheets using themes

Calc comes with a predefined set of formatting themes that you can apply to your spreadsheets. It is not possible to add themes to Calc, and they cannot be modified. However, you can modify their styles after you apply them to a spreadsheet.

To apply a theme to a spreadsheet:

1) Click the Choose Themes icon in the Tools toolbar. If this toolbar is not visible, you can show it using View > Toolbars > Tools.
   The Theme Selection dialog appears. This dialog lists the available themes for the whole spreadsheet.

2) In the Theme Selection dialog, select the theme that you want to apply to the spreadsheet. As soon as you select a theme, some of the properties of the custom styles are applied to the open spreadsheet and are immediately visible.
3) Click OK. If you wish, you can now go to the Styles and Formatting window to modify specific styles. These modifications do not change the theme; they only change the appearance of this specific spreadsheet document.
Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. For example, in a table of numbers, you can show all the values above the average in green and all those below the average in red.

Conditional formatting depends upon the use of styles, and the AutoCalculate feature (Tools > Cell Contents > AutoCalculate) must be enabled. See Chapter 2 (Entering, Editing, and Formatting Data) in the Calc Guide for details.

Hiding and showing data

When elements are hidden, they are neither visible nor printed, but can still be selected for copying if you select the elements around them. For example, if column B is hidden, it is copied when you select columns A and C. When you need a hidden element again, you can reverse the process, and show the element.

To hide or show sheets, rows, and columns, use the options on the Format menu or the right-click (context) menu. For example, to hide a row, first select the row, and then choose Format > Row > Hide (or right-click and choose Hide).

To hide or show selected cells, choose Format > Cells from the menu bar (or right-click and choose Format Cells). On the Format Cells dialog, go to the Cell Protection tab.

Outline group controls

If you are continually hiding and showing the same cells, you can simplify the process by creating outline groups, which add a set of controls for hiding and showing the cells in the group that are quick to use and always available.

If the contents of cells falls into a regular pattern, such as four cells followed by a total, then you can use Data > Group and Outline > AutoOutline to have Calc add outline controls based on the pattern. Otherwise, you can set outline groups manually by selecting the cells for grouping, then choosing Data > Group and Outline > Group. On the Group dialog, you can choose whether to group the selected cells by rows or columns.

When you close the dialog, the outline group controls are visible between either the row or column headers and the edges of the editing window. The controls resemble the tree-structure of a file-manager in appearance, and can be hidden by selecting Data > Outline > Hide Details. They are strictly for on screen use, and do not print.
The basic outline controls have plus or minus signs at the start of the group to show or hide hidden cells. However, if outline groups are nested, the controls have numbered buttons for hiding different levels.

If you no longer need a group, place the mouse cursor in any cell in it and select Data > Group and Outline > Ungroup. To remove all groups on a sheet, select Data > Group and Outline > Remove.

**Filtering which cells are visible**

A filter is a list of conditions that each entry has to meet in order to be displayed. You can set three types of filters from the Data > Filter submenu.

**Automatic filters** add a drop-down list to the top row of a column that contains commonly used filters. They are quick and convenient and are useful with text and with numbers, because the list includes every unique entry in the selected cells.

In addition to these unique entries, automatic filters include the option to display all entries, the ten highest numerical values, and all cells that are empty or not-empty, as well as a standard filter. The automatic filters are somewhat limited. In particular, they do not allow regular expressions, so you cannot use them to display cell contents that are similar, but not identical.

**Standard filters** are more complex than automatic filters. You can set as many as three conditions as a filter, combining them with the operators AND and OR. Standard filters are mostly useful for numbers, although a few of the conditional operators, such as = and < > can also be useful for text.

Other conditional operators for standard filters include options to display the largest or smallest values, or a percentage of them. Useful in themselves, standard filters take on added value when used to further refine automatic filters.

**Advanced filters** are structured similarly to standard filters. The differences are that advanced filters are not limited to three conditions, and their criteria are not entered in a dialog. Instead, advanced filters are entered in a blank area of a sheet, then referenced by the advanced filter tool to apply them.

**Sorting records**

Sorting arranges the visible cells on the sheet. In Calc, you can sort by up to three criteria, which are applied one after another. Sorts are handy when you are searching for a particular item, and become even more powerful after you have filtered data.

In addition, sorting is often useful when you add new information. When a list is long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows in the proper places. After you have added information, you can then sort it to update the sheet.
Highlight the cells to be sorted, then select **Data > Sort** to open the Sort dialog (or click the Sort Ascending or Sort Descending toolbar buttons). Using the dialog, you can sort the selected cells using up to three columns, in either ascending (A-Z, 1-9) or descending (Z-A, 9-1) order.

On the **Options** tab of the Sort dialog, you can choose the following options:

- **Case sensitive**
  If two entries are otherwise identical, one with an upper case letter is placed before one with a lower case letter in the same position.

- **Range contains column labels**
  Does not include the column heading in the sort.

- **Include formats**
  A cell’s formatting is moved with its contents. If formatting is used to distinguish different types of cells, then use this option.

- **Copy sort results to**
  Sets a spreadsheet address to which to copy the sort results. If a range is specified that does not have the necessary number of cells, then cells are added. If a range contains cells that already have content, then the sort fails.

- **Custom sort order**
  Select the box, then choose one of the sort orders defined in **Tools > Options > Spreadsheet > Sort Lists** from the drop-down list.

- **Direction**
  Sets whether rows or columns are sorted. The default is to sort by columns unless the selected cells are in a single column.

### Using formulas and functions

You may need more than numbers and text on your spreadsheet. Often the contents of one cell depend on the contents of other cells. Formulas are equations using numbers and variables to get a result. The variables are cell locations that hold the data you need for the equation.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All you have to do is add the arguments, and the calculation is automatically made for you. Functions help you create the formulas needed to get the results that you are looking for.

Refer to Chapter 7 in the *Calc Guide* for more information.

### Analyzing data

Calc includes several tools to help you analyze the information in your spreadsheets, ranging from features for copying and reusing data, to creating subtotals automatically, to varying information to help you find the answers you need. These tools are divided between the Tools and Data menus.

One of the most useful of these tools is the PivotTable (called DataPilot in Calc 3.3). This is a tool for combining, comparing, and analyzing large amounts of data easily. Using the PivotTable, you can view different summaries of the source data, display the details of areas of interest, and create reports, whether you are a beginner, an intermediate or advanced user. Refer to Chapter 8 in the *Calc Guide* for more information.
Other analysis options include:

**Consolidation**
Data > Consolidate provides a way to combine data from two or more ranges of cells into a new range while running one of several functions (such as Sum or Average) on the data.

**Subtotals**
Use Data > Subtotals to calculate subtotals for up to three columns.

**Scenarios**
Tools > Scenarios opens a dialog for testing “what-if” questions, such as different interest rates on a loan.

**Goal seek**
Use Tools > Goal Seek if you know the result you want, but need to discover what values will produce this result.

**Solver**
Tools > Solver is similar to Goal Seek, but you can use more than one variable. The Solver is designed to minimize or maximize the result according to a set of rules that you define.

All of these options are further discussed in Chapter 9 in the *Calc Guide*.

**Printing**

Printing from Calc is much the same as printing from other Apache OpenOffice components (see Chapter 9), but some details are different, especially regarding preparation for printing.

**Using print ranges**
Print ranges have several uses, including printing only a specific part of the data or printing selected rows or columns on every page. For more about using print ranges, see Chapter 6 (Printing, Exporting, and E-mailing) in the *Calc Guide*.

**Defining a print range**
To define a new print range or modify an existing print range:
1) Highlight the range of cells that comprise the print range.
2) Choose Format > Print Ranges > Define.

The page break lines display on the screen.

**Tip**
You can check the print range by using File > Page Preview. Calc will only display the cells in the print range.

**Adding to the print range**
After defining a print range, you can add more cells to it. This allows multiple, separate areas of the same sheet to be printed, while not printing the whole sheet. After you have defined a print range:
1) Highlight the range of cells to be added to the print range.
2) Choose Format > Print Ranges > Add. This adds the extra cells to the print range.

The page break lines no longer display on the screen.
**Removing a print range**

It may become necessary to remove a defined print range, for example if the whole sheet needs to be printed later.

Choose **Format > Print Ranges > Remove**. This removes all defined print ranges on the sheet. After the print range is removed, the default page break lines will appear on the screen.

**Editing a print range**

At any time, you can directly edit the print range, for example to remove or resize part of the print range. Choose **Format > Print Ranges > Edit**.

**Selecting the page order, details, and scale**

To select the page order, details, and scale to be printed:

1. Choose **Format > Page** from the main menu.
2. Select the **Sheet** tab.
3. Make your selections, and then click **OK**.

![Page Style: Default](image)

*Figure 98. The Sheet tab of the Page Style dialog*

**Page Order**

When a sheet will print on more than one page (of paper) you can set the order in which pages print. This is especially useful in a large document; for example, controlling the print order can save time if you have to collate the document a certain way. The two available options are shown below.
Details
You can specify which details to print. These details include:

- Row and column headers
- Sheet grid—prints the borders of the cells as a grid
- Comments—prints the comments defined in your spreadsheet on a separate page, along with the corresponding cell reference
- Objects and graphics
- Charts
- Drawing objects
- Formulas—prints the formulas contained in the cells, instead of the results
- Zero Values—prints cells with a zero value

Note
Remember that since the print detail options are a part of the page’s properties, they are also a part of the page style’s properties. Therefore, different page styles can be set up to quickly change the print properties of the sheets in the spreadsheet.

Scale
Use the scale features to control the number of pages the data will print on. This can be useful if a large amount of data needs to be printed compactly or if you want the text enlarged to make it easier to read.

- Reduce/Enlarge printout—scales the data in the printout either larger or smaller. For example if a sheet would normally print out as four pages (two high and two wide), a scaling of 50% would print as one page (both width and height are halved).
- Fit print range(s) on number of pages—defines exactly how many pages the printout will take up. This option will only reduce a printout, it will not enlarge it. To enlarge a printout, the reduce/enlarge option must be used.
- Fit print range(s) to width/height—defines how high and wide the printout will be, in pages.

Printing rows or columns on every page
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each printed page.

For example, if the top two rows of the sheet as well as column A need to be printed on all pages, do the following:

1) Choose Format > Print Ranges > Edit. On the Edit Print Ranges dialog, type the rows in the text entry box under Rows to repeat. For example, to repeat rows 1 and 2, type $1:$2. This automatically changes Rows to repeat from, - none - to - user defined -.
2) To repeat, type the columns in the text entry box under Columns to repeat. For example, to repeat column A, type $A. In the Columns to repeat list, - none - changes to - user defined -.
3) Click OK.
**Note**

You do not need to select the entire range of the rows to be repeated; selecting one cell in each row works.

---

![Image of Edit Print Ranges dialog box](image)

*Figure 99: Specifying repeating rows*

**Page breaks**

While defining a print range can be a powerful tool, it may sometimes be necessary to manually adjust Calc's printout. To do this, you can use a *manual break*. A manual break helps to ensure that your data prints properly. You can insert a horizontal page break above, or a vertical page break to the left of, the active cell.

**Inserting a page break**

To insert a page break:

1. Navigate to the cell where the page break will begin.
2. Select **Insert > Manual Break**.
3. Select **Row Break** or **Column Break** depending on your need.

The break is now set.

**Row break**

Selecting **Row Break** creates a page break above the selected cell. For example, if the active cell is H15, then the break is created between rows 14 and 15.

**Column break**

Selecting **Column Break** creates a page break to the left of the selected cell. For example, if the active cell is H15, then the break is created between columns G and H.

**Tip**

To see page break lines more easily on screen, you can change their color. Choose **Tools > Options > OpenOffice.org > Appearance** and scroll down to the Spreadsheet section.

**Deleting a page break**

To remove a page break:

1. Navigate to a cell that is next to the break you want to remove.
2. Select **Edit > Delete Manual Break**.
3. Select **Row Break** or **Column Break** depending on your need.

The break is now removed.
Note

Multiple manual row and column breaks can exist on the same page. When you want to remove them, you have to remove each one individually. This may be confusing at times, because although there may be a column break set on the page, when you go to Edit > Manual Break, Column break may be grayed out. In order to remove the break, you have to be in the cell next to the break. For example, if you set the column break while you are in H15, you cannot remove it if you are in cell D15. However, you can remove it from any cell in column H.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet outside of the sheet area. Headers are set in the same way as footers.

Headers and footers are assigned to a page style. You can define more than one page style for a spreadsheet and assign different page styles to different sheets. For more about page styles, see Chapter 4 (Using Styles and Templates) in the Calc Guide.

Setting a header or footer

To set a header or footer:

1) Navigate to the sheet that you want to set the header or footer for. Choose Format > Page.
2) On the Page Style dialog, select the Header (or Footer) tab. See Figure 100.
3) Select the Header on option.

![Figure 100: Header dialog](image)

From here you can also set the margins, the spacing, and height for the header or footer. You can check the AutoFit height box to automatically adjust the height of the header or footer.

Margin

Changing the size of the left or right margin adjusts how far the header or footer is from the side of the page.
Spacing
Spacing affects how far above or below the sheet the header or footer will print. So, if spacing is set to 1.00", then there will be 1 inch between the header or footer and the sheet.

Height
Height affects how big the header or footer will be.

Header or footer appearance
To change the appearance of the header or footer, click the More button in the header dialog. This opens the Border/Background dialog (Figure 101).

From this dialog you can set the background and border of the header or footer. For more information see Chapter 4 (Using Styles and Templates) in the Calc Guide.

![Figure 101: Header/Footer Border/Background](image.png)

Setting the contents of the header or footer
The header or footer of a Calc spreadsheet has three columns for text. Each column can have different contents.

To set the contents of the header or footer, click the Edit button in the header or footer dialog shown in Figure 101 to display the dialog shown in Figure 102.

Areas
Each area in the header or footer is independent and can have different information in it.

Header
You can select from several preset choices in the Header drop-down list, or specify a custom header using the buttons below the area boxes. (To format a footer, the choices are the same.)
Figure 102: Edit contents of header or footer

**Custom header**

Click in the area (Left, Center, Right) that you want to customize, then use the buttons to add elements or change text attributes.

- ![Open Text Attributes dialog](image)
- ![Insert total number of pages](image)
- ![Insert File Name field](image)
- ![Insert Date field](image)
- ![Insert Sheet Name field](image)
- ![Insert Time field](image)
- ![Insert current page number](image)
Getting Started with Impress

Presentations in Apache OpenOffice

What is Impress?

Impress is the presentation (slide show) program included in Apache OpenOffice. You can create slides that contain many different elements, including text, bulleted and numbered lists, tables, charts, and a wide range of graphic objects such as clipart, drawings and photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background styles.

This chapter includes instructions, screenshots, and hints to guide you through the Impress environment while designing your presentations. Although more difficult designs are mentioned throughout this chapter, explanations for creating them are in the Impress Guide. If you have a working knowledge of how to create slide shows, we recommend you use the Impress Guide for your source of information.

To use Impress for more than very simple slide shows requires some knowledge of the elements which the slides contain. Slides containing text use styles to determine the appearance of that text. Creating drawings in Impress is similar to the Draw program included in Apache OpenOffice. For this reason, we recommend that you also see Chapter 2 (Using Styles and Templates) and Chapter 6 (Getting Started with Draw) in this book. You may also wish to consult the Draw Guide for more details on how to use the drawing tools.

Starting Impress

You can start Impress in several ways:

- From the Apache OpenOffice Start Center, if no component is open, click on the Presentation icon.
- From the system menu, the standard menu from which most applications are started. On Windows, it is called the Start menu or use the Apache OpenOffice Quickstarter. On Gnome, it is called the Applications menu. On KDE it is identified by the KDE logo. On Mac OS X, it is the Applications menu. Details vary with your operating system; see Chapter 1 (Introducing Apache OpenOffice).
- From any open component of AOO. Click the triangle to the right of the New icon on the main toolbar and select Presentation from the drop-down menu or choose File > New > Presentation from the menu bar.

Note

When AOO was installed on your computer, in most cases a menu entry for each component was added to your system menu. The exact name and location of these menu entries depend on the operating system and graphical user interface.
When you start Impress for the first time, the Presentation Wizard is shown. Here you can choose from the following options:

- **Empty presentation**, which gives you a blank document
- **From template**, which is a presentation designed with a template of your choice
- **Open existing presentation**
- **Click Create** to open the main Impress window.

For detailed instructions about how to use the Presentation Wizard, see “Creating a new presentation” on page 128.

If you prefer not to use the Presentation Wizard in future, you can select **Do not show this wizard again**. You can enable the wizard again later under **Tools > Options > OpenOffice.org Impress > General > New document**, and select the **Start with wizard** option.

### The main Impress window

The main Impress window has three parts: the **Slides pane**, **Workspace**, and **Tasks pane**. Additionally, several toolbars can be displayed or hidden during the creation of a presentation.

![Main window of Impress; ovals indicate the Hide/Show markers](image)

**Tip**

You can close the **Slides pane** or the **Tasks pane** by clicking the X in the upper right corner of the pane or by choosing **View > Slide Pane** or **View > Tasks Pane** to deselect the pane. To reopen a pane, choose **View > Slide Pane** or **View > Tasks Pane** again.

You can also maximize the Workspace area by clicking on the Hide/Show marker in the middle of the vertical separator line (indicated by ovals in Figure 103). Using the Hide/Show marker hides, but does not close, the Slides and Tasks panes. To restore the pane, click again on its Hide/Show marker.
**Slides pane**

The *Slides pane* contains thumbnail pictures of the slides in your presentation, in the order they will be shown unless you change the slide show order. Clicking a slide in this pane selects it and places it in the *Workspace*. When a slide is in the Workspace, you can make changes any way you like.

Several additional operations can be performed on one or more slides simultaneously in the Slides pane:

- Add new slides to the presentation.
- Mark a slide as hidden so that it will not be shown as part of the presentation.
- Delete a slide from the presentation if it is no longer needed.
- Rename a slide.
- Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut and paste).

It is also possible to perform the following operations, although there are more efficient methods than using the Slides pane:

- Change the slide transition following the selected slide or after each slide in a group of slides.
- Change the sequence of slides in the presentation.
- Change the slide design.
- Change slide layout for a group of slides simultaneously.

**Tasks pane**

The *Tasks pane* has five sections. To expand the section you wish to use, click on the title bar of each section. Only one section at a time can be expanded.

**Master Pages**

Here you define the page (slide) style for your presentation. Impress includes several designs of Master Pages (slide masters). One of them—Default—is blank, and the rest have background and styled text.

**Tip**

Press *F11* to open the Styles and Formatting window, where you can modify the styles used in any slide master to suit your purpose. This can be done at any time.

**Layout**

The layouts included in Impress are shown here. You can choose the one you want and use it as it is, or you can modify it to meet your own requirements. However, it is not possible to save custom layouts.

**Table Design**

The standard table styles are provided in this section. You can further modify the appearance of a table with the options to show or hide specific rows and columns, or to apply a banded appearance to the rows and columns.

**Custom Animation**

A variety of animations can be used to emphasize or enhance different elements of each slide. The Custom Animation section provides an easy way to add, change, or remove animations.
**Slide Transition**

The Slide Transition section provides access to a number of slide transition options. The default is set to *No Transition*, in which the following slide simply replaces the existing one. However, many additional transitions are available. You can also specify the transition speed (slow, medium, fast), choose between an automatic or manual transition, and choose how long the selected slide should be shown (automatic transition only).

**Workspace**

The *Workspace* (normally in the center) has five tabs: *Normal*, *Outline*, *Notes*, *Handout*, and *Slide Sorter*. These five tabs are called View buttons. The Workspace below the View buttons changes depending on the chosen view. The workspace views are described in detail on page 124.

![Workspace tabs](image)

*Figure 104: Workspace tabs*

**Toolbars**

Many toolbars can be used during slide creation; they can be displayed or hidden by clicking *View > Toolbars* and selecting from the menu.

You can also select the icons that you wish to appear on each toolbar. For more information, refer to Chapter 1 (Introducing OpenOffice.org) in this book.

Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the *Draw Guide* for details on the functions available and how to use them.

**Status bar**

The *Status bar*, located at the bottom of the Impress window, contains information that you may find useful when working on a presentation. For details on the contents and use of these fields, see Chapter 1 (Introducing OpenOffice.org) in this book and Chapter 1 (Introducing Impress) in the *Impress Guide*.

![Status bar](image)

*Figure 105: Status bar*
From left to right, you will find:

- Information area, which changes depending on the selection. For example:

  | Text area          | Text Edit: Paragraph x, Row y, Column z |
  | Charts, spreadsheets | Embedded object (OLE) “ObjectName” selected |
  | Graphics           | Bitmap with transparency selected       |

- Cursor position—the position of the cursor or of the top left corner of the selection measured from the top left corner of the slide, followed by the width and height of the selection or text box where the cursor is located.

- Unsaved changes—an icon indicating that the file needs saving. Double clicking on this flag opens the file save dialog.

- Digital signature—an icon indicating whether the document is digitally signed. After the file has been saved, double clicking on this flag opens the digital signatures dialog.

- Slide number—the slide number currently displayed in the Workspace and the total number of slides in the presentation.

- Page (slide) style—the style associated with the slide, handout, or notes page currently in the Workspace. Double clicking on the style name opens the slide design dialog.

- Zoom slider—adjusts the zoom percentage of the Workspace displayed.

- Zoom percentage—indicates the zoom percentage of the Workspace displayed. Double clicking on zoom percentage opens the zoom and layout dialog.

You can hide the information in the Status Bar by selecting View > Status Bar from the main menu.

**Navigator**

The Navigator displays all objects contained in a document. It provides another convenient way to move around a document and find items in it. To display the Navigator, click its icon on the Standard toolbar, choose View > Navigator on the menu bar, or press Ctrl+Shift+F5.

The Navigator is more useful if you give your slides and objects (pictures, spreadsheets, and so on) meaningful names, instead of leaving them as the default “Slide 1” and “Shape 2”.

![Navigator](image-url)
Workspace views

Each of the workspace views is designed to ease the completion of certain tasks; it is therefore useful to familiarize yourself with them in order to quickly accomplish those tasks.

**Note**

Each Workspace view displays a different set of toolbars when selected. These toolbar sets can be customized by going to **View > Toolbars**, then check or uncheck the toolbar you want to add or remove.

Normal view

*Normal view* is the main view for working with individual slides. Use this view to format and design and to add text, graphics, and animation effects.

To place a slide in the slide design area (Normal view), click the slide thumbnail in the Slides pane or double-click it in the Navigator (page 123).

Outline view

*Outline view* contains all the slides of the presentation in their numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text contained in the default text boxes in each slide is shown, so if your slide includes other text boxes or drawing objects, the text in these objects is not displayed. Slide names are also not included.

![Outline view](image)

*Figure 107: Outline view*

Use Outline view for the following purposes.

1) Making changes in the text of a slide:
   - Add and delete the text in a slide just as in the Normal view.
   - Move the paragraphs of text in the selected slide up or down by using the up and down arrow buttons (Move Up or Move Down) on the Text Formatting toolbar (highlighted in Figure 108).
   - Change the outline level for any of the paragraphs in a slide using the left and right arrow buttons (Promote or Demote) on the Text Formatting toolbar.
   - Both move a paragraph and change its outline level using a combination of these four arrow buttons.

2) Compare slides with your outline (if you have prepared one in advance). If you notice from your outline that another slide is needed, you can create it directly in the Outline view or you can return to the Normal view to create it.

![Text Formatting toolbar](image)

*Figure 108: Text Formatting toolbar*
Notes view

Use the Notes view (Figure 109) to add notes to a slide. These notes are not seen when the presentation is shown.

1) Click the Notes tab in the Workspace.
2) Select the slide to which you want to add notes.
   - Click the slide in the Slides pane, or
   - Double-click the slide's name in the Navigator.
3) In the text box below the slide, click on the words Click to add notes and begin typing.

![Figure 109: Notes view](image)

You can resize the Notes text box using the colored resizing handles which appear when you click on the edge of the box. You can also move the box by placing the pointer on the border, then clicking and dragging. To make changes in the text style, press the F11 key to open the Styles and Formatting window.

Handout view

Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab in the workspace, then choose Layouts in the Tasks pane. You can then choose to print 1, 2, 3, 4, 6, or 9 slides per page.

Use this view also to customize the information printed on the handout. Refer to Chapter 10 of the Impress Guide for instructions on printing slides, handouts, and notes.

Select from the main menu Insert > Page Number or Insert > Date and Time and in the dialog box that opens click on the Notes and Handouts tab. Use this dialog to select the elements you want to appear on each handout page and their contents. More details on how to use this dialog are provided in the Impress Guide.

![Figure 110: Handout layouts](image)
Figure 111: Dialog to set the page information for handouts and notes

**Slide Sorter view**

*Slide Sorter* view contains all of the slide thumbnails. Use this view to work with a group of slides or with only one slide.

Figure 112: Slide Sorter view
Customizing Slide Sorter view
To change the number of slides per row:

1) Check **View > Toolbars > Slide Sorter** and **Slide View** to show or hide the slide sorter and view toolbars.
2) Adjust the number of slides (up to a maximum of 15).

![Figure 113: Slide Sorter and Slide View toolbars](image)

Moving a slide using Slide Sorter
To move a slide in a presentation in the Slide Sorter:

1) Click the slide and the slide is highlighted (see Figure 112).
2) Drag and drop it to the location you want.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

- Use the **Control (Ctrl)** key: Click on the first slide and, while pressing the Control key, select the other desired slides.
- Use the **Shift** key: Click on the first slide, and while pressing the Shift key, select the final slide in the group. This selects all of the other slides between the first and the last.
- Use the mouse: Click slightly to one side (left or right) of the first slide to be selected. Hold down the left mouse button and drag the mouse pointer until all of the slides you want selected are highlighted.

To move a group of slides:

1) Select a group of slides.
2) Drag and drop the group to their new location.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane.

To make changes, right-click a slide and choose any of the following from the pop-up menu:

- Add a new slide after the selected slide.
- Delete Slide: deletes the selected slide.
- Rename Slide: allows you to rename the selected slide.
- Slide Layout: allows you to change the layout of the selected slide.
- Slide Transition: allows you to change the transition of the selected slide.
  - For one slide, click the slide to select it and then add the desired transition.
  - For more than one slide, select the group of slides and add the desired transition.
- Hide Slide: hidden slides are not shown in the slide show.
- Cut: removes the selected slide and saves it to the clipboard.
- Copy: copies the selected slide to the clipboard without removing it.
- Paste: inserts a slide from the clipboard. This option will also allow you to specify whether you want to paste the copied slide Before or After the selected slide.
Creating a new presentation

This section describes how to start a new presentation using the Presentation Wizard.

Tip

The first thing to do is decide on the purpose of the presentation and plan the presentation. Although you can make changes as you go, having an idea of who the audience will be, the structure, the content, and how the presentation will be delivered, will save you a lot of time from the start.

When you start Impress, the Presentation Wizard appears.

![Image of Presentation Wizard]

Figure 114. Choosing the type of presentation

1) Under **Type**, choose one of the options. These options are covered in the *Impress Guide*.
   - **Empty presentation** creates a blank presentation.
   - **From template** uses a template design already created as the basis for a new presentation. The wizard changes to show a list of available templates. Choose the template you want.
   - **Open existing presentation** continues work on a previously created presentation. The wizard changes to show a list of existing presentations. Choose the presentation you want.

2) Click **Next**. Figure 115 shows the Presentation Wizard step 2 as it appears if you selected **Empty Presentation** at step 1. If you selected **From template**, an example slide is shown in the Preview box.
3) Choose a design under **Select a slide design.** The slide design section gives you two main choices: *Presentation Backgrounds* and *Presentations*. Each one has a list of choices for slide designs. If you want to use one of these other than *<Original>*, click it to select it.

- The types of *Presentation Backgrounds* are shown in Figure 115. By clicking an item, you will see a preview of the slide design in the Preview window. Impress contains three choices under *Presentations*: *<Original>*, *Introducing a New Product*, and *Recommendation of a Strategy*.
- *<Original>* is for a blank presentation slide design.
- Both *Introducing a New Product* and *Recommendation of a Strategy* have their own prepackaged slide designs. Each design appears in the Preview window when its name is clicked.

**Note**  
*Introducing a New Product* and *Recommendation of a Strategy* can also be used to create a presentation by choosing **From template** in the first step (Figure 114).

4) Select how the presentation will be used under **Select an output medium.** Most often, presentations are created for computer screen display. Select *Screen*. You can change the page format at any time.

**Note**  
The Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not suitable for modern widescreen displays. You can change the slide size at any time switching to Normal view and selecting **Format > Page**.

5) Click **Next**. The **Presentation Wizard** step 3 appears (Figure 116).

- Choose the desired slide transition from the *Effect* drop-down menu.
- Select the desired speed for the transition between the different slides in the presentation from the *Speed* drop-down menu. *Medium* is a good choice for now.

6) Click **Create**. A new presentation is created.
Tip
You can accept the default values for both Effect and Speed unless you are skilled at creating presentations. Both of these values can be changed later while working with Slide transitions and animations. These two features are explained in more detail in Chapter 9 of the Impress Guide.

Note
If you selected From template on step 1 of the Wizard, the Next button will be active on step 3 and other pages will be available. These pages are not described here.

Caution
Remember to save frequently while working on the presentation, to prevent any loss of information should something unexpected occur. You might also want to activate the AutoRecovery function (Tools > Options > Load/Save > General). Make sure Save AutoRecovery information every is selected and that you have entered a recovery frequency.

Formatting a presentation
A new presentation contains only one empty slide. In this section we will start adding new slides and preparing them for the intended contents.

Inserting slides
This can be done in a variety of ways; take your pick.

- Insert > Slide.
- Right-click on the present slide, and select Slide > New Slide from the pop-up menu.
- Click the Slide icon in the Presentation toolbar.
Sometimes, rather than starting from a new slide you want to duplicate a slide you have already inserted. To duplicate a slide, select the slide you want from the Slides pane and then choose **Insert > Duplicate Slide**.

**Selecting a layout**

In the Tasks pane, select the Layout drawer to display the available layouts. The Layouts differ in the number of elements a slide will contain, from a blank slide to a slide with six contents boxes and a title.

![Available slide layouts](image)

The first slide in a presentation is normally a title slide. The **Title Slide** (which also contains a section for a subtitle) or **Title Only** are suitable layouts for the first slide, while for most of the slides you will probably use the **Title, Contents** layout.

To create the title, click on **Click to add title** (assuming the **Blank Slide** layout was not used) and then type the title text. To adjust the formatting of the title, modify the **Title** presentation style; see Chapter 2 in the *Impress Guide* for instructions.

If you are using the **Title Slide** layout, click on **Click to add text** to add a subtitle. Proceed as above to make adjustments to the formatting if required modifying the **Subtitle** presentation style instead.

---

**Note**

Text and graphic elements can be readjusted at any time during the preparation of the presentation, but changing the layout of a slide that already contains some contents can have a dramatic effect. It is therefore recommended that you pay particular attention to the layout you select. If you do need to change the layout after contents have been added, the contents are not lost though they may need to be reformatted.
Tip

To view the names for the included layouts, use the Tooltip feature: position the cursor on an icon in the Layout section (or on any toolbar icon) and its name will be displayed in a small rectangle.

If tooltips are not enabled, choose Tools > Options > OpenOffice.org > General > Help and select the Tips option. If the Extended tips option is also selected, you will get more detailed tooltip information, but the tooltip names themselves will not be provided.

To select or change the layout, place the slide in the work area and select the desired layout from the layout drawer in the Task Pane.

Several layouts contain one or more content boxes. Each of these boxes can be configured to contain one of the following elements: Text, Movie, Picture, Chart or Table.

You can choose the type of contents by clicking on the corresponding icon that is displayed in the middle of the contents box as shown in Figure 118. If instead you intend to use the contents box for text, just click anywhere on the box to get a cursor.

![Figure 118: Selecting contents type](image)

To select or change the layout, place the slide in the work area and select the desired layout from the layout drawer in the Task Pane.

If you have selected a layout with one or more contents boxes, this is a good time to decide what type of contents you want to insert.

Modifying the slide elements

At this stage, the slide contains elements that were included in the slide master, as well those elements included in the selected slide layout. It is however unlikely that the predefined layouts will suit all your needs. You may want to remove any elements that are not required or insert objects such as text and graphics.

Although Impress does not have the functionality to create new layouts, it allows you to resize and move the layout elements. It is also possible to add slide elements without being limited to the size and position of the layout boxes.
To resize a contents box, click on the outer frame so that the 8 resizing handles are displayed. To move it place the mouse cursor on the frame so that the cursor changes shape. You can now click the left mouse button and drag the contents box to its new position on the slide.

To remove any unwanted elements, do this:
1) Click the element to highlight it. The colored resizing handles show it is highlighted.
2) Press the Delete key to remove it.

**Caution**  Changes to any of the layouts included in Impress can only be made using View > Normal, which is the default. Attempting any changes by modifying a slide master, although possible, may result in unpredictable results and requires extra care as well as a certain amount of trial and error.

### Adding text to a slide

To add text to a slide that contains a text frame, click on Click to add text in the text frame and then type your text. The Outline styles are automatically applied to the text as you insert it. You can change the outline level of each paragraph as well as its position within the text by using the arrow buttons on the Text Formatting toolbar (see “Outline view” on page 124). For more information on text, see “Adding and formatting text” on page 134.

### Adding pictures or objects to a slide

To add any pictures or objects to a slide, for example a picture, clipart, drawing, photograph, or spreadsheet, click on Insert then select from the drop down menu what type of insert you require. For more information, see “Adding pictures, tables, charts, media files, and other objects” on page 138.

### Modifying the appearance of all slides

To change the background and other characteristics of all slides in the presentation, you need to modify the master page or choose a different master page as explained in “Working with master pages and styles” on page 141.

A Slide Master is a slide with a specified set of characteristics that acts as a template and is used as the starting point for creating other slides. These characteristics include the background, objects in the background, formatting of any text used, and any background graphics.

**Note**  Apache OpenOffice uses three interchangeable terms for this one concept. Master slide, slide master, and master page. These terms all refer to a slide that is used to create other slides. This guide, however, uses only the term slide master, except when describing the user interface.

Impress has included a range of slide masters, found in the Master Pages section of the Tasks pane. You can also create and save additional slide masters or add more from other sources. See Chapter 2 in the Impress Guide for information on creating and modifying slide masters.

If all you need to do is to change the background, you can take a shortcut:
1) Select Format > Page and go to the Background tab.
2) Select the desired background between solid color, gradient, hatching and bitmap.
3) Click OK to apply it.

A dialog box will open asking if the background should be applied to all the slides. If you click yes, Impress will automatically modify the master page for you.
Inserting and correctly formatting a background is beyond the scope of this chapter, but you can find all the information you need in Chapter 4 of the *Draw Guide* or in Chapter 6 of the *Impress Guide*.

**Modifying the slide show**

By default the slide show will display all the slides in the same order as they appear in the slide sorter, without any transition between slides, and you need some keyboard or mouse interaction to move from one slide to the next.

You can use the Slide Show menu to change the order of the slides, choose which ones are shown, automate moving from one slide to the next, and other settings. To change the slide transition, animate slides, add a soundtrack to the presentation, and make other enhancements, you need to use functions in the Task pane. See the *Impress Guide* for details on how to use all of these features.

**Adding and formatting text**

Many of your slides are likely to contain some text. This section gives you some guidelines on how to add text and how to change its appearance. Text in slides is contained in *text boxes*. For more information on adding and formatting text, see Chapter 3 in the *Impress Guide*.

There are two types of text boxes that you can add to a slide:

- Choose a predefined layout from the *Layouts* section of the Tasks pane and do not select any special contents type. These text boxes are called *AutoLayout* text boxes.

- Create a text box using the text tool in the Drawing toolbar or the Text toolbar.

**Using text boxes created from the Layout pane**

Make sure Normal view is selected:

1) Click in the text box that reads **Click to add text**.
2) Type or paste your text in the text box.

These text boxes are known as AutoLayout text boxes.

**Using text boxes created from the text tool**

Make sure Normal view is selected:

1) Click on the **Text** icon on the Drawing toolbar or press F2. If the Drawing toolbar with the text icon is not visible, choose **View > Toolbars > Drawing**.
2) Click and drag to draw a box for the text on the slide. Do not worry about the vertical size and position as the text box will expand if needed as you type.
3) Release the mouse button when finished. The cursor appears in the text box, which is now in edit mode (gray hashed border shown in Figure 119).
4) Type or paste your text in the text box.
5) Click outside the text box to deselect it.

You can move, resize, and delete text boxes. For more information, see Chapter 3 in the *Impress Guide*.
Using text boxes created from the Text toolbar

Make sure Normal view is selected:

1) Click on the Text icon on the Text toolbar (Figure 120). If the Text toolbar with the text icon is not visible, choose View > Toolbars > Text.

2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the height because the text box will expand as you type.

3) Release the mouse button when finished. The cursor appears in the text box, which is now in edit mode (a hashed border; see Figure 119).

4) Type or paste your text into the text box.

5) Click outside the text box to deselect it.

Note

In addition to the normal text boxes where text is horizontally aligned, it is possible to insert text boxes where the text is aligned vertically. This choice is available only when Asian languages are enabled in Tools > Options > Language Settings > Languages. Click on the button in the drawing toolbar or text toolbar to create a vertical text box.
Quick font resizing

Impress has icons on the Text Formatting toolbar to increase or decrease font size of selected text. The amount by which the font size changes depends on the standard sizes available for the font in use.

Pasting text

Text may be inserted into the text box by copying it from another document and pasting it into Impress. However, the pasted text will probably not match the formatting of the surrounding text or that of the other slides in the presentation. This may be what you want on some occasions; however in most cases you want to make sure that the presentation style is consistent and does not become a patchwork of different paragraph styles, font types, bullet points and so on. There are several ways to ensure consistency; these methods are explained below.

Pasting unformatted text

It is normally good practice to paste text without formatting and apply the formatting later. To paste without formatting, either press Control+Shift+V and then select Unformatted text from the dialog that appears, or click on the small black triangle next to the paste symbol in the standard toolbar and select Unformatted text. The unformatted text will be formatted with the outline style at the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.

Formatting pasted text

If you are pasting the text into an AutoLayout area, you need to apply the appropriate outline style to the text to give it the same look and feel as the rest of the presentation.

1) Paste the text in the desired position. Do not worry if it does not look right; it will in a minute.
2) Select the text you have just pasted.
3) Select Format > Default formatting from the menu bar.
4) Use the four arrow buttons in the Text Formatting toolbar (highlighted in Figure 108) to move the text to the appropriate position and give it the appropriate outline level. The button with the arrow pointing left promotes the list entry by one level (for example from Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the up and down arrow buttons move the list entry.
5) Apply manual formatting as required to sections of the text (to change font attributes, tabs, and so on).

If you are pasting text in a text box, you can still use styles to quickly format the text. Note that one and only one graphic style can be applied to the copied text. To do that:

1) Paste the text in the desired position.
2) Select the text you have just pasted.
3) Select the desired graphic style.
4) Apply manual formatting as required to sections of the text.

Creating bulleted and numbered lists

The procedure to create a bulleted or numbered list is quite different depending on the type of text box used, although the tools to manage the list and customize the appearance are the same.
In text boxes created automatically by Impress (called AutoLayout), the outline styles available are by default bulleted lists, while for normal text boxes an additional step is required to create a bulleted list.

**Creating lists in AutoLayout text boxes**

Every text box included in the available layouts is already formatted as a bulleted list, therefore to create a bulleted list the only necessary steps are:

1. From the Layout pane, choose a slide design that contains a text box. Those are easily recognizable from the thumbnail.
2. Click in the text box that reads **Click to add an outline**.
3. Type the text, then press **Enter** to start a new bulleted line.

The methods for switching between bulleted and numbered lists are explained in “Changing the appearance of the list” on page 138.

**Tip**

Press **Shift + Enter** to start a new line without creating a new bullet or number. The new line will have the same indentation of the previous line. To switch off bullets altogether, click the bullets button on the text formatting toolbar. If the text formatting toolbar is not showing, enable it selecting **View > Toolbar > Text Formatting** on the menu bar.

**Creating lists in other text boxes**

To create a list in a text box, follow these steps:

1. Place the cursor in the text box.
2. Click the **Bullets On/Off** button on the text formatting toolbar.
3. Type the text and press **Enter** to start a new bulleted line.
4. The default list type is a bulleted list. Methods for changing the appearance of the list are explained on page 138.

**Creating a new outline level**

1. If necessary, press **Enter** to begin a new line.
2. Press **Tab** or click the indentation arrows in the text formatting toolbar. Each time you press **Tab** or click the right arrow, the line indents to the next outline level. Pressing **Enter** creates a new line at the same level as the previous one. To return to the previous level, press **Shift+Tab** or click the left arrow.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 3 style, and so on. As a consequence, a change in the level also produces other changes (for example font size, bullet type, and so on).

**Note**

Do not try to change the outline level by selecting the text and then clicking the desired outline style as you would in Writer. Due to the way that presentation styles work, it is not possible to apply them in this way.
Changing the appearance of the list

You can fully customize the appearance of a list, changing the bullet type or numbering for the entire list or for single entry. All of the changes can be made using the Bullets and Numbering dialog, which is accessed by selecting **Format > Bullets and Numbering** or by clicking on the **Bullets and Numbering** icon on the text formatting toolbar.

For the entire list:

1) Select the entire list or click on the gray border of the text box so that the colored resizing handles are displayed.

2) Select **Format > Bullets and Numbering** or click on the **Bullets and Numbering** icon on the text formatting toolbar.

   - If a bullet list is needed, select the desired bullet style from the default styles available on the **Bullets** page.
   - If a graphics style is needed, select one from those available on the **Graphics** page.
   - If a numbered list is needed, select one of the default numbering styles on the **Numbering type** page.

![Figure 121: Bullets and Numbering dialog](image)

For a single line in the list, click anywhere in the line to place the cursor in it and then follow steps 2 and 3 in the previous instruction set.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is to modify the Outline styles. Changes made to the outline style will apply to all the slides using them. Sometimes this is what you want; sometimes it is not, so some care must be taken.

Adding pictures, tables, charts, media files, and other objects

As we have seen, in addition to text, a contents box can contain also pictures, tables, charts, and movies. This section provides a quick overview of how to work with these objects; for a more detailed description, you are invited to consult the **Impress Guide**.
Adding pictures

To add a picture to a contents box:

• Go to Insert > Picture on the main menu bar and then select either From file or Scan.
• Alternatively, and after inserting a new slide, click the Insert Picture icon and select the file from the Insert Picture dialog that opens. To see a preview of the picture, check Preview at the bottom of the Insert Picture dialog (Figure 122).
• Move the picture to the desired location.

The picture will resize itself to fill the area of the contents box. Follow the directions in the Caution note below when manually resizing a graphic.

![Insert picture dialog](image)

**Figure 122. Insert picture dialog**

**Caution**

When resizing a graphic, right-click the picture. Select Position and Size from the context menu and make sure that Keep ratio is selected. Then adjust the height or width to the size you need. (As you adjust one dimension, both dimensions will change.) Failure to do so will cause the picture to become distorted. Remember also that resizing a bitmap image will reduce its quality; it is better to create an image of the desired size outside of Impress.

Adding tables

For displaying tabular data, you can insert basic tables directly into your slides by choosing the Table contents type. It is also possible to add a table outside a contents box in a number of ways:

• Go to Insert > Table on the main menu bar.
• Click on the Table icon on the main toolbar or table toolbar.
• After inserting a new slide, click the Insert Table icon.
• Select a style option from the Table Design section of the Tasks pane.
• Alternatively, click on the Table Design icon on the table toolbar to open the Table Design section of the Tasks pane and then select a style.

The first three methods above opens the Insert Table dialog, where you can select the required number of columns and rows. Alternatively, clicking on the black arrow next to the Table icon
displays a graphic allowing you to drag and select the number of required rows and columns for your table.

Figure 123. Creating a table with the Insert Table dialog

**Note**

Selecting from any of the styles in the Table Design section of the Tasks pane creates a table based on that style. If you create a table by another method, you can still apply a style of your choice later.

With the table selected, the Table toolbar should appear. If it does not, you can access it by selecting **View > Toolbars > Table**. The Table toolbar offers many of the same icons as the table toolbar in Writer, with the exception of functions like Sort and Sum for performing calculations. For those functions, you need to use a spreadsheet inserted from Calc (discussed below).

After the table is created, you can modify it in much the same way as you would modify a table in Writer: adding and deleting rows and columns, adjusting width and spacing, adding borders, background colors and so on. Detailed information on working with tables and the Table Properties dialog can be found in Chapter 3 of the *Impress Guide* and Chapter 9 of the *Writer Guide*.

By modifying the style of the table from the Table Design section of the Tasks pane, you can quickly change the appearance of the table or any newly created tables based on the Style options you select. You can choose to add emphasis to a header and total row as well as the first and last columns of the table, and apply a banded appearance to the rows and columns.

Having completed the table design, entering data into the cells is similar to working with text box objects. Click in the cell you wish to add data to, and begin typing. To move around cells quickly, use the following key options:

- The **arrow keys** move the cursor to the next table cell if the cell is empty, otherwise they move the cursor to the next character in the cell.
- The **Tab** key moves to the next cell, skipping over the contents of the cell; **Shift+Tab** move backwards from cell to cell.

**Adding charts**

To insert a chart in a slide you can either use **Insert > Chart** from the main menu bar, clicking on the Chart icon in the main toolbar, or, after inserting a new slide, clicking on the Insert Chart icon. Impress will insert a default chart and open the Chart dialog. To modify the chart type, insert your own data and change the formatting refer to the *Impress Guide*.

**Adding media files**

You can insert various types of media files, such as music and movie clips, into your slide by selecting the **Insert Movie** icon in an empty contents box. A media player will open at the bottom of the screen and you can preview the media. When an audio file is inserted, the contents box will show a loudspeaker image.
Adding graphics, spreadsheets, and other objects

Graphics, such as shapes, callouts, arrows, and so on, are often useful to complement the text on a slide. These objects are handled much the same way as graphics in Draw. For more information, see Chapter 6 (Getting Started with Draw) in this book, the Draw Guide, or Chapters 4, 5, and 6 in the Impress Guide.

Spreadsheets embedded in Impress include most of the functionality of spreadsheets in Calc and are therefore capable of performing extremely complex calculations and data analysis. If you need to analyze your data or apply formulas, these operations are best performed in a Calc spreadsheet and the results displayed in an embedded Impress spreadsheet or even better in a native Impress table.

Alternatively, choose Insert > Object > OLE Object from the menu bar. This opens a spreadsheet in the middle of the slide and the menus and toolbars change to those used in Calc so that you can start adding data, though you may first need to resize the visible area on the slide. You can also insert an already existing spreadsheet and use the viewport to select the data that you want to display on your slide.

Impress offers the capability of inserting in a slide various other types of objects such Writer documents, Math formulas, or even another presentation. For details on using these objects, refer to Chapter 7 of the Impress Guide.

Working with master pages and styles

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style in Writer and it controls the basic formatting of all slides based on it. A slide show can have more than one slide master.

Note

Apache OpenOffice uses three terms for a slide that is used to create other slides: master slide, slide master, and master page. This book uses the term slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers and footers; placement and size of text frames; and the formatting of text.

Styles

All of the characteristics of slide masters are controlled by styles. The styles of any new slide you create are inherited from the slide master from which it was created. In other words, the styles of the slide master are available and applied to all slides created from that slide master. Changing a style in a slide master results in changes to all the slides based on that slide master, but you can modify individual slides without affecting the slide master.

Note

Although it is highly recommended to use the slide masters whenever possible, there are occasions where manual changes are needed for a particular slide, for example to enlarge the chart area when the text and chart layout is used.
Slide masters have two types of styles associated with them: *presentation styles* and *graphic styles*. The prepackaged presentation styles can be modified, but new presentation styles cannot be created. In the case of graphic styles, you can modify the prepackaged ones and also create new ones.

**Presentation styles** affect three elements of a slide master: background, background objects (such as icons, decorative lines, and text frames), and text placed on the slide. Text styles are further divided into *Notes*, *Outline 1* through *Outline 9*, *Subtitle*, and *Title*. The outline styles are used for the different levels of the outline to which they belong. For example, Outline 2 is used for the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 2.

**Graphic styles** affect many of the elements of a slide. Notice that text styles exist in both the presentation and graphic style selections.

**Slide masters**

Impress comes with a collection of slide masters. These slide masters are shown in the Master Pages section of the Tasks pane (Figure 124). This section has three subsections: *Used in This Presentation*, *Recently Used*, and *Available for Use*. Click the + sign next to the name of a subsection to expand it to show thumbnails of the slides, or click the – sign to collapse the subsection to hide the thumbnails.

Each of the slide masters shown in the *Available for Use* list is from a template of the same name. If you have created your own templates, or added templates from other sources, slide masters from those templates will also appear in this list.

![Figure 124: Available master pages (slides masters)](image)

**Creating a slide master**

You can create a new slide master is similar to modifying the default slide master.

To start, enable editing of slide masters by selecting *View > Master > Slide Master* and the *Master View* toolbar opens. You can also right-click on the slide master in the Master Pages
section of the tasks pane and select **Edit Master** to open the Master View toolbar. On the Master View toolbar, click the **New Master** icon (highlighted in Figure 125).

![Master View toolbar](image)

*Figure 125: Master View toolbar*

A second slide master appears in the Slides pane. Modify this slide master to suit your requirements. It is also recommended that you rename this new slide master: right-click on the slide in the Slides pane and select **Rename master** from the pop-up menu. When you are done, close the Master View toolbar to return to normal slide editing mode.

**Applying a slide master**

In the Tasks Pane, make sure the Master Pages section is showing (Figure 124).

To apply one of the slide masters to all slides in your presentation, click on it in the list.

To apply a different slide master to one or more selected slides:

1) In the Slide Pane, select the slides you want to change.

2) In the Tasks Pane, right-click on the slide master you want to apply to the selected slides, and click **Apply to Selected Slides** on the pop-up menu.

**Loading additional slide masters**

Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong to different templates. For example, you may need a completely different layout for the first slide of the presentation, or you may want to add to your presentation a slide from a different presentation (based on a template available on the hard disk).

The Slide Design dialog makes this possible. Access this dialog either from the menu bar (**Format > Slide design**) or from the pop-up menu that appears when right-clicking on a slide in the Slides pane.

![Slide Design](image)

*Figure 126: Slide Design*
The main window in the dialog shows the slide masters already available for use. To add more:

1) Click the **Load** button.
2) Select in the Load Slide Design dialog (Figure 127) the template from which to load the slide master and click **OK**.
3) Click **OK** again to close the slide design dialog.

The slide masters in the template you selected are now shown also in the Master Pages section of the Tasks pane in the *Available for use* subsection.

**Note**
The slide masters you have loaded will also be available the next time you load the presentation. If you want to delete the unused slide masters, click the corresponding checkbox in the Slide Design dialog. If the slide master was not used in the presentation, it is removed from the list of available slide masters anyway.

**Tip**
To limit the size of the presentation file, you may want to minimize the number of slide masters used.

![Figure 127: Load Slide Design dialog for selecting templates](image)

**Modifying a slide master**
The following items can be changed on a slide master:

- Background (color, gradient, hatching, or bitmap)
- Background objects (for example, add a logo or decorative graphics)
- Size, placement, and contents of header and footer elements to appear on every slide
- Size and placement of default frames for slide titles and content

Before working on the slide master, make sure that the Styles and Formatting dialog is open.

To select the slide master for modification:

1) Select **View > Master > Slide Master** from the menu bar. This unlocks the properties of the slide master so you can edit it.
2) Click **Master Pages** in the Tasks pane. This gives you access to the slide masters.
3) Click on the slide master you want to modify among the ones available.
4) Make changes as required, then click the **Close Master View** icon on the Master View toolbar. For details, see Chapter 2 of the *Impress Guide*.
5) Save the file before continuing.
Caution

Any changes made to one slide when in Master View mode will appear on all slides using this slide master. Always make sure you close Master View and return to Normal view before working on any of the presentation slides. Select View > Normal from the menu bar, or clicking Close Master View in the Master View toolbar to return to the normal slide view.

The changes made to one of the slides in Normal view (for example, changes to the bullet point style, the color of the title area, and so on) will not be overridden by subsequent changes to the slide master. There are cases, however, where it is desirable to revert a manually modified element of the slide to the style defined in the slide master: to do that, select that element and choose Format > Default Formatting from the menu bar.

Using a slide master to add text to all slides

Some of the supplied slide masters have text objects in the footer. You can add other text objects to the master page for your slides to act as a header or a footer.

1) Choose View > Master > Slide Master from the menu bar.
2) On the Drawing toolbar, select the Text icon or press F2.
3) Click once and drag in the master page to draw a text object, and then type or paste your text into the object or add fields as described below.
4) Choose View > Normal when you are finished.

The Impress slide master comes with three pre-configured areas: for date, footer, and slide number.

To add page (slide) numbers or date and time to the slide footers in your presentation, select Insert > Page Number or Insert > Date and Time to open the Header and Footer dialog (Figure 128) where you can select and configure these areas on the slide.

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, choose Format > Page and then select a format from the list in the Layout Settings area.

To change the paragraph style, modify the Background Objects Presentation style.

To add other information, such as the author of the presentation or the name of the file, use Insert > Fields and select the required field from the submenu. If you want to edit this field in your slide, select it and choose Edit > Fields. See Chapter 2 (Adding and Formatting Text) in the Impress Guide for more information.

Tip

To change the author information, go to Tools > Options > OpenOffice.org > User Data.
The fields you can use in Impress are:

- Date (fixed)
- Date (variable): updates automatically when you reload the file
- Time (fixed)
- Time (variable): updates automatically when you reload the file
- Author: first and last names listed in the OpenOffice.org user data
- Page number (slide number)
- File name

### Adding comments to a presentation

Impress supports comments similar to those in Writer and Calc.

In Normal View, choose **Insert > Comment** from the menu bar. A small box containing your initials appears in the upper left-hand corner of the slide, with a larger text box beside it. Impress automatically adds your name and the current date at the bottom of the text box.

Type or paste your comment into the text box. You can optionally apply some basic formatting to the comment by selecting it, right-clicking, and choosing from the pop-up menu. From this menu, you can apply formatting to selected text, delete the current comment, delete all comments from the same author, or delete all comments in the presentation.

You can move the small comment markers to anywhere you wish on the slide. Typically you might place it on or near an object you refer to in the comment.

To show or hide the comment markers, choose **View > Comments**.

Select **Tools > Options > User Data** to configure the name you want to appear in the Author field of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different background color for their comments.
Setting up the slide show

As mentioned in “Modifying the slide show” on page 134, Impress allocates reasonable default settings for slide shows, while at the same time allowing for customizing many aspects of the slide show experience. This section covers only some aspects; advanced techniques are explained in Chapter 9 (Slide Shows) in the Impress Guide.

Most of the tasks are best done in Slide Sorter view where you can see most of the slides simultaneously. Choose View > Slide Sorter from the menu bar or click the Slide Sorter tab at the top of the workspace.

One slide set – multiple presentations

In many situations, you may find that you have more slides than the time available to present them or you may want to provide a rapid overview without dwelling on the details. Rather than having to create a new presentation, you can use two tools that Impress offers: hiding slides and custom slide shows.

To hide a slide, right-click on the slide thumbnail either in the Slide pane or in the Workspace area. If you are using the Slide Sorter view and choose Hide Slide from the pop-up menu. Hidden slides are marked by a slashed slide number.

If you want to reorder the presentation, choose Slide Show > Custom Slide Show. Click on the New button to create a new sequence of slides and save it.

You can have as many slide shows as you want from a single slide set.

Slide transitions

Slide transition is the animation that is played when a slide is changed for the next slide in the presentation. You can configure the slide transition from the Slide Transition drawer in the Tasks pane. Select the desired transition, the speed of the animation, and whether the transition should
happen when you click the mouse (preferred) or automatically after a certain number of seconds. Click **Apply to all slides** unless you prefer to have different transitions in the presentation.

---

**Tip**  
The Slide transition section has a very useful choice: *Automatic preview*. Select its checkbox and when you make any changes in a slide transition, the new slide is previewed in the Slide Design area, including its transition effect.

---

**Automatic slides advance**

You can set the presentation to automatically advance to the next slide after a set amount of time from the Slide Transition section in the Task pane. Go to **Advance slide** and select **Automatically after**, then choose the required amount of time in seconds that each slide will be displayed. Click on the **Apply to All Slides** button to apply the same display time to all slides.

To apply a different display time to each slide in your presentation, choose **Slide Show > Rehearse Timings**. Start the slide show and a small timer is displayed in the bottom left corner. When you are ready to advance to the next slide, mouse click on the display background or press the right arrow on your keyboard. Impress will memorize the timings for each slide and advance to the slide automatically after each timing ends when you run the slide show.

To automatically restart a slide show after the last slide has been displayed, go to **Slide Show > Slide Show Settings** on the menu bar. Select **Auto** and the timing of the pause between slide shows. Click **OK** when you have finished.

---

**Running a slide show**

To run a slide show, do one of the following:

- Click **Slide Show > Slide Show** on the menu bar.
- Click the **Slide Show** icon on the Presentation toolbar.
- Press **F5** on the keyboard.

If the slide transition is **Automatic after x seconds**, let the slide show run by itself.

If the slide transition is **On mouse click**, do one of the following to move from one slide to the next:

- Use the arrow keys on the keyboard to go to the next slide or to go back to the previous one.
- Click the mouse to move to the next slide.
- Press the spacebar on the keyboard to advance to the next slide.

Right-click anywhere on the screen to open a menu from which you can navigate the slides and set other options.

To exit the slide show at any time including at the end, press the **Esc** key.
What is Draw?

Draw is a vector graphics drawing program, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display an image as simple geometric elements such as lines, circles, and polygons rather than a collections of pixels (points on the screen). Vector graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the Apache OpenOffice suite, and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as copying and pasting the image. You can also work with drawings directly from within Writer or Impress, using a subset of the functions and tools from Draw.

Draw's functionality is extensive; even though it was not designed to rival high-end graphics applications, it possesses more functions than most drawing tools that are integrated with office productivity suites.

A few examples of drawing functions are:

- Layer management
- Magnetic grid point system
- Dimensions and measurement display
- Connectors for making organization charts
- 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects)
- Drawing and page style integration
- Bézier curves

This chapter introduces some of Draw's features, but it does not attempt to cover all of them. See the Draw Guide and the application Help for more information.

Parts of the main Draw window

The components of the main Draw window are shown in Figure 130.

You can surround the drawing area with toolbars and information areas. The number and position of the visible tools vary with the task in hand and user preferences. Therefore, your setup may look different. For example, many users put the main Drawing toolbar on the left-hand side of the workspace, not at the bottom as shown here.
You can split drawings in Draw over several pages. Multipage drawings are used mainly for presentations. The *Pages* pane, on the left side of the Draw window in Figure 130 gives an overview of the pages that you create. If the Pages pane is not visible on your setup, you can enable it from the View menu (*View > Page Pane*).

![Initial Draw window](image)

**Figure 130. Initial Draw window**

**Rulers**

You should see rulers (bars with numbers) on the upper and left-hand side of the workspace. The rulers show the size of a selected object on the page (see the gray double lines, highlighted in Figure 131). When no object is selected, they show the location of the mouse pointer, which helps to accurately position drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines, making it easier to position objects. The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse.

To modify the unit of measurement of a ruler, right-click on the ruler and select one of the measurement units. The two rulers can have different units.
Status bar

The Status bar is located at the bottom of the screen (in all Apache OpenOffice components); it includes several Draw-specific fields.

For details on the contents and use of these fields, see Chapter 1 (Introducing Apache OpenOffice) in this book and Chapter 1 (Introducing Draw) in the *Draw Guide*.

**Note**

The sizes are given in the current measurement unit (not to be confused with the ruler units). This unit is defined in *Tools > Options > OpenOffice.org Draw > General*, where you can also change the scale of the page. Another way to change the scale is to double-click on the number shown in the status bar.

![Figure 133: Left end of the Draw status bar](image)

![Figure 134: Right end of Draw status bar](image)

**Toolbars**

To display or hide the various Draw toolbars, choose *View > Toolbars*. On the menu that appears, select which toolbars you want to display. For more about working with toolbars, see Chapter 1 (Introducing Apache OpenOffice) in this book.

The tools available in the Draw toolbars are explained in the following sections. The appearance of the toolbar icons may vary depending on your operating system and the selection of icon size and style in *Tools > Options > OpenOffice.org > View*.

**Standard toolbar**

The Standard toolbar is the same for all Apache OpenOffice components and is not described in detail in this chapter.

**Line and Filling toolbar**

The Line and Filling toolbar lets you modify the main properties of a drawing object. See page 164 for details.
**Text Formatting toolbar**
If the selected object is text, the toolbar changes to the Text Formatting toolbar, which is similar to the Formatting toolbar in Writer. For more information, see Chapter 3 (Getting Started with Writer) in this book.

**Drawing toolbar**
The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes and for organizing them on the page.

**Options toolbar**
Use the Options toolbar to activate or deactivate various drawing aids. To display the Options toolbar, select **View > Toolbars > Options**.

![Figure 135: Options toolbar](image)

**Choosing and defining colors**

**Color Bar**
To display the Color Bar, use **View > Toolbars > Color Bar**. The toolbar then appears at the bottom of the workspace.

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in the panel corresponds to transparency (no color).

You can access several specialized color palettes in Draw, as well as change individual colors to your own taste. To do this, choose **Format > Area** or the **pouring can** icon on the Line and Filling toolbar. This opens the Area dialog. Choose the **Colors** tab.

To load another palette, click on the **Load Color List** button (circled). The file selector dialog asks you to choose one of the standard Apache OpenOffice palettes (files with the file extension *.soc*). For example, *web.soc* is a color palette that is particularly adapted to creating drawings that are going to appear in Web pages. The colors will correctly display on workstations with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical values in the fields provided to the right of the color palette. You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), and RGB (Red, Green, Blue).

Click on the **Edit** button to open the Color dialog, where you can set individual colors. See “Color options” in Chapter 11 (Setting Up and Customizing Apache OpenOffice) in this book. Many more input possibilities are available in this dialog.

For a more detailed description of color palettes and their options, see Chapter 8 (Tips and Tricks), in the **Draw Guide**.
Positioning objects with snap functions

In Draw, objects can be accurately and consistently positioned using grid points, special snap points and lines, object frames, individual points on objects, or page edges. This function is known as Snap.

The snap function is easier to work with at the highest practical zoom value. You can use two different snap functions at the same time, for example snapping to a guide line and to the page edge. It is best, however, to activate only those functions that you really need.

This section summaries the snap-to-grid function. For more detailed information about the snap functions, see Chapter 8 (Tips and Tricks) and Chapter 10 (Advanced Draw Techniques) in the Draw Guide.

Snap to grid

Use this function to move an object exactly to a grid point (see Figure 137). Switch this function on and off with View > Grid > Snap to Grid and on the Options toolbar with the icon.
Showing the grid
To make the grid visible, choose View > Grid > Display Grid. Alternatively, turn the grid on (or off) with the icon on the Options toolbar.

Configuring the grid
The color, spacing, and resolution of the grid points can be individually chosen for each axis. The spacing between the lines is defined in the Grid options dialog (Tools > Options > OpenOffice.org Draw > Grid).

![Grid options dialog](image)

Figure 138: Setting grid options

In the dialog shown in Figure 262, you can set the following parameters:

- Vertical and horizontal spacing of the dots in the grid. You can also change the unit of measurement used in the general Draw options (Tools > Options > OpenOffice.org Draw > General).
- The resolution is the size of the squares or rectangles in the grid. If the resolution is 1 cm horizontal, 2 cm vertical, the grid consists of rectangles 2 cm high and 1 cm wide.
- Subdivisions are additional points that appear along the sides of each rectangle or square in the grid. Objects snap to subdivisions as well as to the corners of the grid.
- The pixel size of the snap area defines how close you need to bring an object to a snap point or line before it will snap to it.

Changing the color of the grid points
The default grid dots are light gray, which can be hard to see. To change the color of the grid points, choose Tools > Options > OpenOffice.org > Appearance.

In the Drawing / Presentation section, you can change the color of the grid points. On the Color Settings pulldown menu, select a more suitable/visible color, for example black.
Positioning objects with guiding lines

To simplify the positioning of objects it is possible to make visible guiding lines—extensions of the edges of the object—while it is being moved. These guiding lines have no snap function.

The guiding lines can be activated or deactivated under Tools > Options > OpenOffice.org Draw > View > Guides when moving, or by clicking on the icon on the Options toolbar.

The basic drawing shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing Toolbar. This section describes only a few of the basic shapes. These shapes include; rectangles and squares, circles, ellipses, and arcs, 3D objects, curves, lines and arrows, text, and connectors. All shapes in Draw are called objects. See the Draw Guide for a complete description of the shapes available.

Note

When you draw a basic shape or select one for editing, the Info field at the left side in the status bar changes to reflect the present action: Line created, Text frame xxyy selected, and so on.

Figure 140 shows part of the Drawing toolbar with the icons needed in the following sections. The Text icon is also included.

Figure 140: Part of the Drawing toolbar
**Drawing a straight line**

Click on the **Line** icon on the Drawing toolbar and position the mouse pointer where you want to start the line. Drag the mouse while keeping the button pressed. Release the mouse button at the point where you want to end the line.

A selection handle appears at each end of the line, showing that this is the currently selected object.

![Figure 141: Drawing a straight line](image)

To restrict the angle of the line to a multiple of 45 degrees (0, 45, 90, 135, and so on), hold down the **Shift** key while you draw the line.

To snap the end of the line to the nearest grid point, hold down the **Control** key while drawing the line.

**Note**

The effect of the **Ctrl** key depends on the settings of the **Snap to Grid** option on the **View > Grid** menu:

- **Snap to Grid on**: **Ctrl** deactivates the snap option for this activity.
- **Snap to Grid off**: **Ctrl** activates the snap option for this activity.

To extend the line symmetrically in both directions from the starting point, hold down the **Alt** key while drawing the line.

To change line attributes (for example, the color or line type), select the line by clicking on it, then use the tools in the Line and Filling toolbar; or for more control, right-click on the line and choose **Line** to open the Line dialog.

**Drawing an arrow**

Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines: Lines with arrowheads. The information field on the status bar shows them only as lines. Click on the **Line Ends with Arrow** icon to draw an arrow.

**Choosing line endings**

Several types of line endings (arrows, circles, squares, and others) are available in Draw. Choose **View > Toolbars > Arrows**, or click on the small black triangle on the **Lines and Arrows** icon on the Drawing toolbar, to open a toolbar with ten tools for drawing lines and arrows. The last-used command is stored on the toolbar to make it quicker to call it up again.
Drawing a rectangle or square

Drawing a rectangle is similar to drawing a straight line, except that you click on the Rectangle icon from the Drawing toolbar, and the (imaginary) line drawn by the mouse corresponds to a diagonal of the rectangle. The rectangle changes shape as you drag the mouse around.

![Figure 143: Drawing a rectangle](image)

Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting from its center. To combine the effects, hold down both the Shift and Alt keys simultaneously.

Drawing a circle or ellipse

To draw an ellipse (also called an oval) or a circle, use the Ellipse icon from the Drawing toolbar. (A circle is simply an ellipse with both axes the same length.) The ellipse drawn is the largest ellipse that fits inside the (imaginary) rectangle drawn with the mouse.

![Figure 144: Drawing an ellipse](image)

Here are some other ways to draw an ellipse or circle:

- To draw a circle, hold down the Shift key while dragging the mouse.
• To draw an ellipse with the starting point at the center (instead of the corner), hold down the Alt key while dragging the mouse.
• To draw a circle with the starting point at the center, hold down both the Alt and Shift keys while dragging the mouse.
• To draw an ellipse or circle that snaps to the nearest grid points, hold down the Ctrl key while dragging the mouse.

**Note** If you first press and hold down the Ctrl key and then click on one of the icons for Line, Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in the work area; the size, shape, and color are all standard values. These attributes can be changed later, if desired.

**Drawing curves**

The tools for drawing curves or polygons are on the toolbar that appears when you click arrow next to the Curve icon on the Drawing toolbar. This toolbar contains eight tools (see Figure 145). If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the function.

**Note** Hovering the mouse pointer over this icon gives a tooltip of Curve. If you convert the icon to a floating toolbar, however, the title is Lines, as shown in Figure 145.

---

**Polygons**

Draw the first line from the start point with the left mouse button held down. As soon as you release the mouse button, a first corner point is drawn; move the mouse to see how the second line will look. Every mouse click sets another corner point. A double-click ends the drawing. A filled polygon automatically joins the last point to the first point to close off the figure and fills it with the current standard fill color. A polygon without filling will not be closed at the end of the drawing.

**Polygon 45°**

Like ordinary polygons, these are formed from lines but with angles of 45 or 90 degrees between them.

**Freeform line**

With this tool you can draw just like with a pencil. Press and hold the left mouse button and drag the mouse. It is not necessary to end the drawing with a double-click. Just release the
mouse button and the drawing is completed. If you have selected Freeform Line, Filled, the end point is joined automatically to the start point and the object is filled with the appropriate color.

**Curves and filled curves**

For a description of the handling of curves and filled curves, see Chapter 10 (Advanced Draw Techniques) in the *Draw Guide*.

**Writing text**

Use the Text tool to write text and select the font, color, size, and other attributes. Click at the location where you want to position the text or click and drag to create a larger text frame. Press Enter to move the cursor to the next line.

When you have finished typing text, click outside the text frame. Double-click on the text at any time to edit it.

When you use the Text tool, the Text formatting toolbar is visible; it includes the usual paragraph attributes: indents, first line, and tab stops.

You can create Graphics styles that you can reuse for other text frames. Select Format > Styles and Formatting or press F11 to open the Styles and Formatting window. Graphics styles affect all of the text within a text frame. To style parts of the text, use direct formatting with the toolbar.

Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object. You can rotate the frame and write the text at any angle. These options are available by right-clicking on the object.

Use the Callout tool, located on the Drawing toolbar, to create callouts (also known as captions or figure labels).

If you double-click on an object or press F2 (or the Text icon in the Drawing toolbar) when an object is selected, text is written in the center of the object and remains within the object. Nearly any kind of object contains such an additional text element. These texts have slight differences to those in text frames concerning position and hyphenation.

For more about text, see Chapter 2 (Drawing Basic Shapes) and Chapter 10 (Advanced Draw Techniques) in the *Draw Guide*.

**Gluepoints and connectors**

All Draw objects have associated invisible gluepoints, which become visible when you choose any of the connectors under the Connector icon on the Drawing toolbar and then move the mouse pointer over the object.

Most objects have four gluepoints, as shown in Figure 146. You can add more gluepoints, and customize gluepoints, using the toolbar under the Gluepoint icon on the Drawing toolbar.

![Figure 146: Four gluepoints](image-url)
Gluepoints are different from handles (the small blue or green squares around an object). The handles are for moving or resizing an object. The gluepoints attach connectors to an object.

Connectors are lines or arrows whose ends automatically dock to gluepoints on an object. When you move the other object, the connector moves with it. Connectors are particularly useful for making organizational charts. You can reorganize the blocks of your chart and all the connected objects stay connected.

Figure 147 shows two Draw objects and a connector.

![Figure 147: A connector between two objects](image)

Draw offers a range of different connectors and connector functions. Open the floating Connector toolbar by clicking on the arrow next to the Connector icon. For more about connectors and gluepoints, see Chapter 9 (Organization Charts, Flow Diagrams, and More) in the Draw Guide.

### Drawing geometric shapes

Geometric shapes include basic shapes, symbol shapes, block arrows, flowcharts, callouts, and stars. You can add text to all these shapes. See Chapter 2 (Drawing Basic Shapes) and Chapter 10 (Advanced Draw Techniques) in the Draw Guide for details.

Figure 148 shows part of the Drawing toolbar with the icons referred to in the following sections. Clicking on the arrow next to the icon opens a floating toolbar with the relevant work tools.

**Tip**
The use of all these tools is similar to that of the Rectangle tool, even though they produce different geometric shapes.

![Figure 148: Part of the main Drawing toolbar](image)

### Basic shapes

The Basic Shapes icon makes available the range of tools for drawing basic shapes, including a rectangular tool identical to the one on the main toolbar.
Symbol shapes
The Symbol Shapes icon provides an array of tools for drawing the various symbols.

Block arrows
The Block Arrows icon opens the Block Arrows toolbar.

Flowcharts
The tools for drawing flowcharts are accessed by clicking on the Flowcharts icon.

The creation of flowcharts, organization charts, and similar planning tools are described in Chapter 9 (Organization Charts, Flow Diagrams, and More) in the Draw Guide.

Callouts
Use the Callouts icon to open the Callouts toolbar.

Stars and banners
These tools are associated with the Stars icon.

Selecting objects

Direct selection
To easiest way to select an object is to click directly on it. For objects that are not filled, click directly on the object's outline to select it.
Selection by framing
You can select several objects at once by using the mouse to drag a large rectangle around the objects, as shown. For this to work, the Select icon on the Drawing toolbar must be active. Only objects that lie entirely within the rectangle are selected.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. Hold down the Alt key and click where the object is located. If there are several overlapping objects, hold down the Alt key and click until you reach the object you want. To cycle through the objects in reverse order, hold down the Alt+Shift keys. The number and type of selected objects is shown at the left of the status bar to help you select the correct object.

Note
This method generally works in Windows, but on a Linux system it usually does not. If the Alt key on your system does not operate as described above, use the Tab key method described below.

To select an object that is covered by another object using the keyboard, press the Tab key to cycle through the objects, stopping at the object you wish to select. To cycle through the objects in reverse order, press Shift+Tab. This may not be practical if you have a large number of objects in your drawing.

When you click on the selected object, its outline will appear briefly through the objects covering it.

In the illustration to the right, the square located beneath the circle was selected in this way (the circle was made transparent in order to see the square).

Arranging objects
In a complex drawing, several objects may be stacked on top of one another. To rearrange the stacking order (move an object to the front or to the back of the stack), select the object, choose Modify > Arrange and choose Bring Forward or Send Backward. Or right-click the object, choose Arrange from the context menu, then choose Bring Forward or Send Backward.

These options are also available from the Arrange tear-off toolbar from the button on the Drawing toolbar. A keyboard shortcut is Shift+Ctrl+plus sign to bring an object to the top, and Shift+Ctrl+minus to send an object to the bottom.

Draw also provides tools for aligning multiple objects; details are given in the Draw Guide.

Selecting several objects
To select or deselect several objects one by one, press the Shift key and click on the various objects to be selected or deselected. One click on an object selects it; a second click on the same object deselects it.
Moving and dynamically adjusting an object’s size

There are several ways of moving or changing the size of an object. The *dynamic* method described here uses the mouse.

When you dynamically change an object, remember to check the left-hand area of the status bar at the bottom of the Draw window. This area shows detailed information about the ongoing manipulation. This information changes when the mouse is moved.

**Dynamic movement of objects**

To move an object, select it and then click within the object's border and hold down the left mouse button while dragging the mouse.

During movement, the shape of the object appears a faded version of the shape to help with repositioning.

To drop the object at its new location, release the mouse button. The new position appears immediately in the Status Bar.

**Dynamic size modification of objects**

To change the size of a selected object (or group of selected objects) with the mouse, move one of the handles located around the selection. As shown in the following illustration, a faded version of the new object shape is shown.

The results depend on which handle you use. To resize an object along one axis, use the appropriate side handle. To resize both axes, use a corner handle. The new size appears immediately in the status bar.

**Note**

If you press the *Shift* key while resizing an object, the change in size will be carried out symmetrically with respect to the two axes, so that the aspect (height/length) ratio of the object remains the same.

**Rotation**

Rotating an object lets you move the object around an axis. To do this dynamically (with the mouse), use the red handles, as you do when changing the size of the object.

**Note**

Rotation works in a slightly different way for 3D objects because the rotation occurs in 3D space and not in one plane. See Chapter 7 (Working with 3D Objects) in the *Draw Guide* regarding rotation when Edit Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle point of the selection with the mouse. The mouse cursor takes the shape of an arc of a circle with an arrow at each end. A faded version of the object being rotated appears and the current angle of rotation is dynamically shown in the status bar.

Rotations are made around an axis which is displayed as a small symbol, as shown in Figure 265. You can move the axis of rotation with the mouse.
If you hold down the Shift key during the rotation, the operation will be carried out in increments of 15°.

![Figure 149: Rotating an object](image)

**Inclination and perspective**

To slant or shear objects, use the red handles located at the midpoint of an edge of the selected objects. The mouse pointer changes to a \(\rightarrow\) when the pointer hovers over one of these midpoint handles. Not every object can be slanted; basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be used for shearing the object. This point stays fixed in location; the other sides and edges move in relation to it as the mouse is dragged (make sure that the \(\rightarrow\) handle icon is showing before dragging).

As with rotation, you can set the inclination (slanting) to occur in steps of 15° by pressing the Shift key while moving the handle.

**Editing objects**

To change an object's attributes (such as color and border width) you can use the Line and Filling toolbar or the context menu.

If the Line and Filling toolbar (Figure 150) is not visible, you can display it using View > Toolbars > Line and Filling. From here you can edit the most common object attributes. You can also open the Line dialog by clicking on the Line \(\mathbb{L}\) icon and the Area dialog by clicking on the Area \(\mathbb{A}\) icon to see more options.

![Figure 150: Line and Filling toolbar](image)
When you select text, this toolbar changes to show text formatting options.

**The context menu**

When an object is selected, you can right-click on the object to bring up a context menu, which provides additional access to the options shown above and another way to change an object’s attributes. The entries with a small arrow on the right-hand side contain a submenu.

**Editing lines and borders**

Lines, arrows, and the borders of an object are managed through the Line dialog. An object’s border is just another type of line.

You can change some properties from the Line and Filling toolbar. To see more options, select the object and click on the Line icon or right-click on the object and choose Line from the context menu. This opens the Line dialog.

**Common line properties**

In most cases the property you want to change is the line’s style (solid, dashed, invisible, and so on), its color, or its width. These options are all available from the Line and Filling toolbar (Figure 135).

You can also edit these properties from the Line dialog, where you can also change the line’s transparency. Figure 151 illustrates different degrees of transparency.

**Drawing arrows**

Arrowheads (and other line endings—usually referred to collectively as arrows) are a line property. Select a line and click on the Arrow Style icon from the Line and Filling toolbar. This opens the Arrowheads menu.

Several types of arrowheads are available. Each end of the line can have a different arrowhead (or no arrowhead).

Arrowheads are only applicable to lines. They have no effect on an object’s border.
Customizing line and arrow styles

You can modify the line and arrow styles and create your own. See Chapter 4 (Changing Object Attributes) in the Draw Guide for details.

Editing the inside (fill) of an object

The Apache OpenOffice term for the inside of an object is Area fill. The area fill of an object can be a uniform color, a gradient, a hatching, or an image. It can be made partly or fully transparent and can throw a shadow.

In most cases, you will choose one of the standard fill options, which are all available from the Line and Filling toolbar. You can also define your own area fills; see Chapter 4 in the Draw Guide for details.

Adding a shadow

In Draw, shadows are considered as an area property. Click on the Shadow icon on the Line and Filling toolbar.

You can customize the position, distance, color, and transparency of shadows by using Format > Area > Shadow or by right-clicking on the selected object and choosing Area > Shadow.

Adding transparency

You can make objects partly or fully transparent, or even with a varying degree of transparency (as a gradient).

Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a formatting template (a style) and then to apply that style to multiple objects. For more information about styles, see Chapter 2 (Using Styles and Templates) in this book.

Special effects

With Draw, you can apply many special effects to objects and groups of objects. This section describes a few of these effects. More effects include distorting, shadows, and transparency can be found in Chapter 4 (Changing Object Attributes) in the Draw Guide.
Flip an object

Select an object and click on the Flip icon. You will see a dashed line through the middle of the object.

This dashed line is the axis of symmetry. The object will be flipped around this line. Move one or both ends of the line with your mouse to set the orientation of the axis.

Then, grab any one of the eight green handles and move it across to the other side of the dashed line. The new position of the figure is shown dashed until the mouse is released.

Note

If you hold down the Shift key while moving the line, the line will rotate in 45-degree increments.

Mirror copies

Move the axis of symmetry to the desired location of the mirror axis. Copy the object to the clipboard. Flip the object, then click on an empty area of the Draw screen in order to deselect the object. Paste from the clipboard to put a copy of the object in its original location and now you have a mirror copy.

Distorting an image

There are three tools on the Effects menu that let you drag the corners and edges of an object to distort the image.

The Distort tool distorts an object in perspective, the Set to Circle (slant) and Set in Circle (perspective) tools both create a pseudo three-dimensional effect. See Chapter 4 in the Draw Guide for details.

Dynamic gradients

You can control transparency gradients in the same manner as color gradients. Both types of gradient can be used together. With a transparency gradient, the direction and degree of an object's fill color changes from opaque to transparent (in a regular gradient, the fill changes from one color to another, but the degree of transparency remains the same). See Chapter 4 in the Draw Guide for details.
**Duplication**

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates. The result of a duplication is a new group of objects.

To start duplication, click on an object or group and choose **Edit > Duplicate**. The dialog shown in Figure 152 appears. When the options chosen in that dialog are applied to a blue rectangle, they produce the result shown in Figure 153.

![Duplicate dialog box](image)

*Figure 152: Duplicating an object*

![Result of duplication](image)

*Figure 153: Result of duplication*

**Cross-fading**

Cross-fading transforms a shape from one form to another. The result is a new group of objects including the start and end points and the intermediate steps.

To carry out a cross-fade, first select two objects (hold the **Shift** key while selecting each object in turn) and then choose **Edit > Cross-fading**.
On the Cross-fading dialog, choose the number of increments (transition steps). You probably want to have *Cross-fade attributes* and *Same orientation* both checked. The end result is shown in Figure 155.

![Cross-fading settings](image)

*Figure 154: Choosing cross-fading settings*

![Cross-fading example](image)

*Figure 155: Cross-fading example*

## Combining multiple objects

Using Draw, you can combine drawing objects together in two distinct ways: *grouping* and *combining*. These two methods allow you to treat multiple objects as one unit, or to merge objects to form a new shape.

**Grouping** is like putting objects in a container. You can move them as a group and apply global changes to them. A group can always be undone and the objects that make up the group can always be manipulated separately.

A *combination* is a permanent fusion of objects leading to a new object. The original objects are no longer available as individual entities and the operation is not reversible.

### Grouping by common selection

When several objects are selected, any operations you carry out are applied to all of the objects. For example, you can rotate a group of objects in its entirety. Groups obtained through common selection of several objects are undone as soon as you click outside the group. However, you can group objects and keep those selected objects grouped together.

### Maintaining groups and undoing groups

To group objects, first select the objects, then right-click and choose *Group* from the pop-up menu. You can also use the keyboard shortcut *Ctrl+Shift+G* or choose *Modify > Group* from the menu bar.

When objects are grouped, any editing operations carried out on that group are applied to all members of the group. If you click on one member of the group, the whole group is selected.
The objects of a group retain their own individual properties. To undo a group, right-click and choose Unigroup from the pop-up menu, use the keyboard shortcut Ctrl+Alt+Shift+G or choose Modify > Ungroup from the menu bar.

You can edit a member of a group individually without breaking the group. To do this, right-click and choose Enter group or double-click on the group.

Combining objects

In contrast to grouping functions, combinations create a new object; subsequent “un-combining” in the same manner as ungrouping is not possible. Select a collection of objects, then right-click and choose Combine from the pop-up menu.

After you have selected more than one object, the Merge, Subtract, and Intersect functions can be reached in the Modify > Shapes menu or though the group’s right-click menu under the heading Shapes.

Aids for positioning objects

Draw has various tools to help you arrange the objects with respect to each other:

- Moving an object to the front or to the back
- Aligning objects with respect to each other
- Distributing the distance and space between objects

See Chapter 5 (Combining Multiple Objects) in the Draw Guide for more information.

Inserting and editing pictures

Draw contains a number of functions for editing raster graphics (bitmaps)—for example, photos and scanned images—including import and and export as well as conversion from one format to another. Draw can read in all the usual range of graphic file formats.

You can add pictures from several sources:

- The Gallery; see Chapter 10 (Graphics, the Gallery, and Fontwork) in this book
- Directly from a scanner (Insert > Picture > Scan)
- Images created by another program, including photographs from a digital camera (Insert > Picture > From File)

Draw provides tools for working with bitmap images: the Picture toolbar and the bitmap image management palette. However, it does not have the same capabilities as the specialized raster graphics programs like Adobe Photoshop or The Gimp. See Chapter 6 (Editing Pictures) in the Draw Guide for details and examples.

Working with 3D objects

Although Draw does not match the functionality of the leading drawing or picture editing programs, it is capable of producing and editing very good 3D drawings.

Draw offers two types of 3D objects: 3D bodies, and 3D shapes. Depending on which type you choose, there are different possibilities for further editing of the object (rotation, illumination, perspective). 3D shapes are simpler to set up and edit than 3D bodies, but 3D bodies currently allow for more customization.

See Chapter 7 (Working with 3D Objects) in the Draw Guide for details.
Exporting graphics

To save a Draw image in a format other than *.odg, use File > Export. Draw can save to many graphic file formats, as listed in Chapter 12 in this book. You can export the entire file or selected objects.

You can also export Draw files to HTML, PDF, or Flash. PDF export is the same as for any part of Apache OpenOffice, as described in Chapter 9 (Printing, Exporting, and E-mailing) in this book. Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web pages as there are pages in your Draw document. You can optionally choose to display the pages in frames with a navigator and set an index page. This process is similar to creating web pages from Impress presentations. For more information, see Chapter 10 (Printing, E-mailing, Exporting, and Saving Slide Shows) in the Impress Guide.

Adding comments to a drawing

Draw supports comments similar to those in Writer and Calc.

Choose Insert > Comment from the menu bar. A small box containing your initials appears in the upper left-hand corner of the Draw page, with a larger text box beside it. Draw has automatically added your name and the date at the bottom of this text box.

Type or paste your comment into the text box. You can optionally apply some basic formatting to parts of the text by selecting it, right-clicking, and choosing from the pop-up menu. From this menu, you can also delete the current comment, all the comments from the same author, or all the comments in the document.

You can move the small comment markers to anywhere you wish on the page. Typically you might place it on or near an object you refer to in the comment.

To show or hide the comment markers, choose View > Comments.

Choose Tools > Options > User Data to enter the name you want to appear in the Author field of the comment.

If more than one person edits the document, each author is automatically allocated a different background color.
Chapter 7
Getting Started with Base
Databases in Apache OpenOffice

Introduction

A data source, or database, is a collection of pieces of information that can be accessed or managed by Apache OpenOffice. For example, a list of names and addresses is a data source that could be used for producing a mail merge letter. A shop stock list could be a data source managed through AOO.

Note

Apache OpenOffice uses the terms “Data Source” and “Database” to refer to the same thing, which could be a database such as MySQL or dBase or a spreadsheet or text document holding data.

This chapter covers creating a database, showing what is contained in a database and how the different parts are used by AOO. It also covers using the Base component of AOO to register other data sources. A data source can be a database, spreadsheet, or text document.

Note

Base uses the HSQL database engine. All of the files created by this engine are kept in one zipped file. The database forms are included in this zipped file.

A database consists of a number of fields that contain the individual pieces of data. Each table of the database is a group of fields. When creating a table, you also determine the characteristics of each field in the table. Forms are for data entry into the fields of one or more tables associated with the form. They can also be used for viewing fields from one or more tables associated with the form. A query creates a new table from the existing tables based upon how you create the query. A report organizes the information of the fields of a query in a document according to your requirements.

Caution

The database in AOO requires Java Runtime Environment (JRE). If you do not have it on your computer, you can download it from www.java.com and install it following the instructions on the site. It should be Java 5.0 or higher. In AOO, use Tools > Options > OpenOffice.org > Java to register Java.

Windows’ version of JRE can not be used, but other versions can.

Base creates relational databases. This makes it fairly easy to create a database in which the fields of the database have relationships with each other.

For example: Consider a database for a library. It will contain a field for the names of the authors and another field for the names of the books. There is an obvious relationship between the authors
and the books they have written. The library may contain more than one book by the same author. This is what is known as a one-to-many relationship: one author and more than one book. Most if not all the relationships in such a database are one-to-many relationships.

Consider an employment database for the same library. One of the fields contains the names of the employees while others contain the social security numbers, and other personal data. The relationship between the names and social security numbers is one-to-one: only one social security number for each name.

If you are acquainted with mathematical sets, a relational database can easily be explained in terms of sets: elements, subsets, unions, and intersections. The fields of a database are the elements. The tables are subsets. Relationships are defined in terms of unions and intersections of the subsets (tables).

To explain how to use a database, we will create one for automobile expenses. In the process, we will be explaining how a database works.

**Planning a database**

The first step in creating a database is to ask yourself many questions. Write them down, and leave some space between the questions to later write the answers. At least some of the answers should seem obvious after you take some time to think.

You may have to go through this process a few times before everything becomes clear in your mind and on paper. Using a text document for these questions and answers makes it easier to move the questions around, add additional questions, or change the answers.

Here are some of the questions and answers I developed before I created a database for automobile expenses. I had an idea of what I wanted before I started, but as I began asking questions and listing the answers, I discovered that I needed additional tables and fields.

What are the fields going to be? My expenses divided into three broad areas: fuel purchases, maintenance, and vacations. The annual cost for the car’s license plate and driver’s license every four years did not fit into any of these. It will be a table of its own: license fees.

What fields fit the fuel purchases area? Date purchased, odometer reading, fuel cost, fuel quantity, and payment method fit. (Fuel economy can be calculated with a query.)

What fields fit the maintenance area? Date of service, odometer reading, type of service, cost of service, and next scheduled service of this type (for example, for oil changes list when the next oil change should be). But it would be nice if there was a way to write notes. So, a field for notes was added to the list.

What fields fit the vacations area? Date, odometer reading, fuel (including all the fields of the fuel table), food (including meals and snacks), motel, total tolls, and miscellaneous. Since these purchases are made by one of two bank cards or with cash, I want a field to state which payment type was used for each item.

What fields fit into the food category? Breakfast, lunch, supper, and snacks seem to fit. Do I list all the snacks individually or list the total cost for snacks for the day? I chose to divide snacks into two fields: number of snacks and total cost of snacks. I also need a payment type for each of these: breakfast, lunch, supper, and total cost of snacks.

What are the fields that are common to more than one area? Date appears in all of the areas as does odometer reading and payment type.

How will I use this information about these three fields? While on vacation, I want the expenses for each day to be listed together. The date fields suggest a relationship between the vacation table and the dates in each of these tables: fuel and food. This means that the date fields in these tables will be linked as we create the database.
The type of payment includes two bank cards and cash. So, we will create a table with a field for the type of payment and use it in list boxes in the forms.

Tip While we have listed fields we will create in the tables of the database, there is one more field that may be needed in a table: the field for the primary key. In some tables, the field for the primary key has already been listed. In other tables such as the payment type, an additional field for the primary key must be created.

Creating a new database

To create a new database, choose File > New > Database from the menu bar, or click the arrow next to the New icon on the Standard toolbar and select Database from the drop-down menu. Both methods open the Database Wizard.

On the first page of the Database Wizard, select Create a new database and then click Next.

The second page has two questions. Make sure the choice for the first question is Yes, register the database for me and the choice for the second question is Open the database for editing. Click Finish.

Note If the database is not registered, it will not be accessible to the other AOO components such as Writer and Calc. If the database is registered, other components can access it.

Save the new database with the name Automobile. This opens the Automobile – OpenOffice.org Base window. Figure 156 shows part of this window.

![Database](image)

**Figure 156: Creating database tables**

Tip Every time the Automobile database is opened, the Automobile – OpenOffice.org Base window opens. Changes can then be made to the database. The title for this window is always <database name> – OpenOffice.org Base.
Caution

As you create a database, you should save your work regularly. This means more than just saving what you have just created. You must save the whole database as well. For example, when you create your first table, you must save it before you can close it. When the table is first saved, it is also made part of the database.

Creating database tables

In a database, a table stores information for a group of things we call fields. For example, a table might hold an address book, a stock list, a phone book or a price list. A database can have from one to several tables.

To work with tables, click the Tables icon in the Database list, or press Alt+a. The three tasks that you can perform on a table are in the Tasks list (see Figure 156).

Using the Wizard to create a table

Wizards are designed to do the basic work. Sometimes this is not sufficient for what we want; in those cases we can use a wizard as a starting point and then build upon what it produces.

The Table Wizard in Base contains two categories of suggested tables: business and personal. Each category contains sample tables from which to choose. Each table has a list of available fields. We can delete some of these fields and add other fields.

A field in a table is one bit of information. For example, a price list table might have one field for item name, one for the description, and a third for the price.

Since none of the fields we need for our Automobile database are contained in any of the sample wizard tables, we will create a simple table using the wizard that has nothing to do with our database. This section is an exercise in explaining how the Wizard works.

The Wizard permits the fields of the table to come from more than one suggested table. We will create a table with fields from three different suggested tables in the Wizard.

Caution

Every table requires a Primary key field. (What this field does will be explained later.) We will use this field to number our entries and want that number to automatically increase as we add each entry.

Click Use Wizard to Create Table. This opens the Table Wizard (Figure 157).

Step 1: Select fields.

We will use the CD-Collection Sample table in the Personal category to select the fields we need.

1) **Category**: Select Personal. The Sample Tables drop down list changes to a list of personal sample tables.

2) **Sample tables**: Select CD-Collection. The Available fields box changes to a list of available fields for this table.

3) **Selected fields**: Using the > button, move the following fields from the Available fields window to the Selected fields window in this order: CollectionID, AlbumTitle, Artist, DatePurchased, Format, Notes, and NumberofTracks.

4) **Selected Fields from another sample table**. Click Business as the Category. Select Employees from the dropdown list of sample tables. Use the > button to move the Photo...
field from the *Available fields* window to the *Selected fields* window. It will be at the bottom of the list directly below the *NumberOfTracks* field.

5) If you make a mistake in selecting fields, click on the field name in the *Selected fields* list and use the < button to move it from the *Selected fields* list back to the *Available fields* list.

6) If you make a mistake in the order of the selected fields, click on the field name that is in the wrong order and use the **Up** or **Down** arrow on the right side of the *Selected fields* list to move the field name to the correct position.

7) Click **Next**.

![Figure 157: Selecting fields for the table](image)

**Step 2: Set field types and formats.**

In this step you give the fields their properties. When you click a field, the information on the right changes. (See Figure 158.) You can then make changes to meet your needs. Click each field, one at a time, and make the changes listed below.

**Note**

If any of these fields requires an entry, set *Entry required* to **Yes**. An entry with that field blank will then not be allowed. In general, only set *Entry required* to **Yes** if something must always be put in that field. By default, *Entry required* is set to **No**.

![Figure 158: Changing field types](image)
• **CollectionID:** Change **AutoValue** from **No** to **Yes**.

• **AlbumTitle:**
  - **Entry required:** Leave **Entry required** as **No**, unless all of your music is in albums.
  - **Length:** Unless you have an album title that exceeds 100 characters counting the spaces, do not change the length.
  - **Artist:** Use the Default setting. And since music has artists, set **Entry Required** to **Yes**.
  - **Date Purchased:** **Field type:** default date setting. **Entry required** should be **No**. (You may not know the date.)

Note

In Base the maximum length of each field must be specified on creation. It is not easy to change this later, so if in doubt specify a greater length. Base uses VCHAR as the field format for text fields. This format only uses the actual number of characters in a field up to the limit set. So, a field containing 20 characters will only use space for 20 characters even if the limit is set at 100. Two album titles containing 25 and 32 characters respectively will use space for 25 and 32 characters and not 100 characters.

• **Format:** Only change the **Entry Required** setting: from **No** to **Yes**.

• **Notes:** No changes are required.

• **NumberofTracks:** Change the **Field Type** to **Tiny Integer [TINYINT]**. Your allowable number of tracks will be 999. Small Integer [SMALLINT] would allow 99999 tracks if you needed more than 999 tracks.

• **Photo:** Use the default settings.

When you have finished, click **Next**.

Note

Each field has a **Field Type**, which must be specified. Types include text, integer, date, and decimal. If the field is going to have general information in it (for example, a name or a description), use text. If the field will always contain a number (for example, a price), the type should be decimal or another numerical field. The wizard picks the right field type, so to get an idea of how this works, see what the wizard has chosen for different fields.

**Step 3: Set primary key.**

1) **Create a primary key** should be checked.
2) Select option **Use an existing field as a primary key**.
3) In the **Fieldname** drop down list, select **CollectionID**.
4) Check **Auto value** if it is not already checked.
5) Click **Next**.

Note

A primary key uniquely identifies an item (or record) in the table. For example, you might know two people called “Randy Herring” or three people living at the same address and the database needs to distinguish between them.

The simplest method is to assign a unique number to each one: number the first person 1, the second 2, and so on. Each entry has one number and every number is different, so it is easy to say “record ID 172”. This is the option chosen here: **CollectionID** is just a number assigned automatically by Base to each record of this table.
Step 4: Create the table.

1) If desired, rename the table at this point. If you rename it, make the name meaningful to you. For this example, make no changes.
2) Leave the option Insert data immediately checked.
3) Click Finish to complete the table wizard. Close the window created by the table wizard. You are now back to the main window of the database with the listing of the tables, queries, forms, and reports. Notice that a table named “CD-Collection” is now listed in the Tables portion of the window.

Creating a table by copying an existing table

If you have a large collection of music, you might want to create a table for each type of music you have. Rather than creating each table from the wizard, you can make copies of the original table, naming each according to the type of music contained in it.

1) Click on the Tables icon in the Database pane to see the existing tables.
2) Right-click on the CD-Collection table icon. Choose Copy from the pop-up menu.
3) Move the mouse pointer below this table, right-click, and select Paste. The Copy table dialog opens.
4) Change the table name to Pop and click Next.
5) Click the >> button to move all the fields from the left box to the right box and click Next.
6) Since all the fields already have the proper Field type, no changes should be needed. However, this is the time and place to make any changes if they are needed. (See Caution below for the reason why.) Click Create. The new table is created.

Caution

Once tables have been created using the wizard and data has been entered, editing them should be very limited. Fields can be added or deleted, but adding a field requires taking the time to enter the data for that one field for every record having an entry for that field.

Deleting a field deletes all the data once contained in that field. Changing the field type of a field can lead to data being lost either partially or completely. When creating a new table, it pays to create the fields with the correct names, length, and format before you add any data. Deleting a table removes all of the data contained in every field of the table. Unless you are sure, do not delete a table.

Creating tables in Design View

Design View is a more advanced method for creating a new table, in which you directly enter information about each field in the table. We will use this method for the tables of our database.

Note

While the Field type and formatting are different in Design View, the concepts are the same as in the Wizard.

The first table to be created is Fuel. Its fields are FuelID, Date, FuelCost, FuelQuantity, Odometer, and PaymentType.

1) Click Create Table in Design View.
2) FuelID field:
   a) Type FuelID as the first Field Name. Press the Tab key to move to the Field Type column.
b) Select *Integer [INTEGER]* as the Field Type from the dropdown list. (The default setting is *Text [VARCHAR]*.)

**Tip**

A shortcut for selecting from the Field Type dropdown list: press the key for the first letter of the choice. You can cycle through the choices for a given letter by repeatedly pressing that key.

c) Change the Field Properties in the bottom section.

Change *AutoValue* from *No* to *Yes*.

d) Set *FuelID* as the *Primary key*.

Right-click on the green triangle to the left of *FuelID* (Figure 159) and choose *Primary Key* from the menu. This places a key icon in front of *FuelID*.

![Figure 159: Defining the primary key field](image)

3) All other fields (*Date, FuelCost, FuelQuantity, Odometer, and PaymentType*):

   a) Type the next field name in the Field Name column.

   b) Select the Field Type for each field.

      • For *Date* use Date[DATE]. (Press the *D* key to select it.)

      • *PaymentType* uses Text [VARCHAR], the default setting.

      • All other fields use Number [NUMERIC]. (Press the *N* key once to select it.)

   c) *FuelCost, FuelQuantity, and Odometer* need changes in the Field Properties section (Figure 160).

      • *FuelQuantity*: Change *Length* to 6 and *Decimal places* to 3. (Many fuel pumps measure fuel to thousands of a gallon in the USA where I live.)

      • *Odometer*: Change the *Length* to 10 and the *Decimal places* to 1.

      • *FuelCost*: Change the Length to 5 and Decimal places to 2. Click the *Format example* button. This opens the Field Format window (Figure 161). Use *Currency* as
the Category and your currency as the Format. My currency has two decimal places. Use what is appropriate for yours.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>FuelID</td>
<td>INTEGER</td>
</tr>
<tr>
<td>Date</td>
<td>DATE</td>
</tr>
<tr>
<td>FuelCost</td>
<td>NUMERIC</td>
</tr>
<tr>
<td>FuelQuantity</td>
<td>NUMERIC</td>
</tr>
<tr>
<td>Odometer</td>
<td>NUMERIC</td>
</tr>
<tr>
<td>PaymentTyp</td>
<td>VARCHAR</td>
</tr>
</tbody>
</table>

![Figure 160: Changing field properties](image)

4) To access additional formatting options, click the button to the right of the Format example field.

5) Description can be anything, or can be left blank.

6) To save and close the table, choose **File > Save**. Name the table *Fuel*. Close the Fuel table.

Follow the same steps to create the *Vacations* table. The fields and their field types are listed in Figure 162. Make sure you make the Date field the primary key before closing. (Right-click the gray
box to the left of Date and select **Primary key** from the menu.) Save the table and name it **Vacations**. Close the Vacations table.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>Date [ DATE ]</td>
<td></td>
</tr>
<tr>
<td>Odometer</td>
<td>Number [ NUMERIC ]</td>
<td>Odometer reading</td>
</tr>
<tr>
<td>Motel</td>
<td>Number [ NUMERIC ]</td>
<td></td>
</tr>
<tr>
<td>Tolls</td>
<td>Number [ NUMERIC ]</td>
<td>total tolls</td>
</tr>
<tr>
<td>Breakfast</td>
<td>Number [ NUMERIC ]</td>
<td></td>
</tr>
<tr>
<td>BPayment</td>
<td>Text [ VARCHAR ]</td>
<td>payment type</td>
</tr>
<tr>
<td>Lunch</td>
<td>Number [ NUMERIC ]</td>
<td></td>
</tr>
<tr>
<td>LPayment</td>
<td>Text [ VARCHAR ]</td>
<td>payment type</td>
</tr>
<tr>
<td>Supper</td>
<td>Number [ NUMERIC ]</td>
<td></td>
</tr>
<tr>
<td>SPayment</td>
<td>Text [ VARCHAR ]</td>
<td>payment type</td>
</tr>
<tr>
<td>SnackNo</td>
<td>Number [ NUMERIC ]</td>
<td></td>
</tr>
<tr>
<td>SnackCost</td>
<td>Number [ NUMERIC ]</td>
<td></td>
</tr>
<tr>
<td>SnPayment</td>
<td>Text [ VARCHAR ]</td>
<td>payment type for snacks</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>Number [ NUMERIC ]</td>
<td>misc. costs</td>
</tr>
<tr>
<td>MPayment</td>
<td>Text [ VARCHAR ]</td>
<td>payment type for motel</td>
</tr>
<tr>
<td>MiscNotes</td>
<td>Memo [ LONGVARCHAR]</td>
<td></td>
</tr>
<tr>
<td>MiscPayment</td>
<td>Text [ VARCHAR ]</td>
<td>payment type for miscellaneous</td>
</tr>
</tbody>
</table>

*Figure 162: Fields in Vacations table*

**Creating tables for the list box**

When the same information can be used in several fields, design a table for each type of information. Each table will contain two fields: the information field and **ID**, in that order.

---

**Caution**

You **must create** these tables with the information field listed **first** and the ID field listed **last**. Failure to do so will produce the wrong results. For my Payment table, I use Name and ID as my fields, with *Dan, Kevin,* and *Cash* being the Name entries. The corresponding ID entries are 0, 1, 2. When the Name field is listed first in the table, one of the three names will appear in the payment field of the Fuel table. If the ID field is listed first, 0, 1, or 2 appear in the payment field instead.

1) Follow the directions in “Creating tables in Design View” on page 179. In the table, the two fields can be **Type** and **PaymentID**. In the Field Properties, set **AutoValue** to **Yes** for the **PaymentID** field. Set the **PaymentID** field as the primary key. (See Figure 163.)

2) Save the table using the name **Payment Type**.

*Figure 163: Table in Design View*

**Note**

If you have several tables to create with the same fields, design one table and produce the other tables by cutting and pasting. (See “Creating a table by copying an existing table” on page 179.)
**Adding data to the list table**

List tables do not require a form. Instead, add their data directly to the table. In this example, use the names of the two people with a bank card and Cash for cash purchases.

1) In the main database window, click on the *Tables* icon (Figure 156). In the list of tables, right-click on *Payment Type* and select *Open* from the pop-up menu.
   
a) Enter *Dan* in the Type column in the first row. Press the *Tab* key to move to the second row. Notice that the PaymentID value for this row changes from `<AutoField>` to 0.
   
b) Enter *Kevin* in the second row. The PaymentID changes to 1.
   
c) Enter *Cash* in the third row. The PaymentID changes to 2.

2) Save and close the table window.

---

**Defining relationships**

Now that the tables have been created, what are the relationships between our tables? This is the time to define them based upon the questions we asked and answered in the beginning.

When on vacation, we want to enter all of our expenses all at one time each day. Most of these expenses are in the *Vacations* table, but the fuel we buy is not. So, we will relate these two tables using the Date fields. Since the *Fuel* table may have more than one entry per date, this relationship between the *Vacations* and *Fuel* tables is one to many. (It is designated 1:n.)

The *Vacations* table also contains several fields for the type of payment used. For each field listing the payment type, there is only one entry from the *Payment Type* table. This is a one to one relationship: one field in one table to one entry from the other table. (It is designated 1:1.) Other tables also contain fields for the type of payment. The relationship between the fields of those tables and the *Payment Type* table are also 1:1.

Since the *Payment Type* table only provides a static list, we will not be defining a relationship between the *Payment Type* table and the fields of the other tables which use the entries of the *Payment Type* table. That will be done when the forms are created.

The *Fuel* and *Maintenance* tables do not really have a relationship even though they share similar fields: Date and Odometer.

---

**Tip**  
You can also use the *Enter* key to move from entry field to entry field, or use the *down arrow* key to move from row to row.

---

**Tip**  
As you create your own databases, you need to also determine where tables are related and how.

1) To begin defining relationships, choose *Tools > Relationships*. The Automobile – OpenOffice.org Base: Relation Design window opens and the Add Tables dialog pops up. (You can also open it by clicking the Add Tables icon on the Relation Design window.)

2) On the Add Tables dialog, use either of these ways to add a table to the Relation Design window:
   
   • Double-click the name of the table. In our case, do this for both *Vacations* and *Fuel*.
   
   • Or, click the name of the table and then click *Add* for each table.

3) Click *Close* to close the Add Tables dialog when you have added the tables you want.
4) You can define the relationship between the Vacations and Fuel tables in two ways:
   • Click and drag the Date field in the Fuel table to the Date field in the Vacations table. When you release the mouse button, a connecting line forms between the two date fields.
   ![Figure 164: Designation for a 1:n relationship](image)

   • Or, click the New Relation icon. This opens the Relations window (Figure 165). Our two tables are listed in the Tables involved section.
     - In the Fields involved section, click the dropdown list under the Fuel label.
     - Select Date from the Fuel table list.
     - Click in the cell to the right of this dropdown list. This opens a dropdown list for the Vacations table.
     - Select Date from the Vacations table list. It should now look like Figure 165.
     - Click OK.

   ![Figure 165: Selected fields in a relationship](image)

5) Modifying the Update options and Delete options section of the Relation window.
   a) Right-click the line connecting the Date fields in the two table lists to open a menu.
   b) Select Edit to open the Relations dialog (Figure 166).

   ![Figure 166: Update options and Delete options section](image)

   c) Select Update cascade.
   d) Select Delete cascade.
e) Click **OK** to close the Relations dialog and choose **File > Save** to save the Relation Design window.

While these options are not strictly necessary, they do help. Having them selected permits you to update a table that has a relationship defined with another table. It also permits you to delete a field from the table.

## Creating a database form

Databases are used to store data. But, how is the data put into the database? Forms are used to do this. In the language of databases, a form is a front end for data entry and editing.

A simple form consists of the fields from a table (Figure 167). More complex forms can contain much more, including additional text, graphics, selection boxes, and many other elements. Figure 168 is made from the same table with a text label (Fuel Purchases), a list box placed in **PaymentType**, and a graphic background.

### Using the Wizard to create a form

We will use the Form Wizard to create a Vacations form, which will contain a form and a subform.

In the main database window (Figure 163), click the **Forms** icon in the left column. In the Tasks list, double-click **Use Wizard to Create Form** to open the Form Wizard (Figure 169). Simple forms require only some of these steps, while more complex forms may use all of them.
Step 1: Select fields.
1) Under Tables or queries, select Table: Vacations. Available fields lists the fields for the Vacations table.
2) Click the right double arrow to move all of these fields to the Fields in the form list. Click Next.

Step 2: Set up a subform.
Since we have already created a relationship between the Fuel and Vacations tables, we will use that relationship. If no relationship had been defined, this would be done in step 4.
1) Click the box labeled Add Subform.
2) Click Subform based upon existing relation.
3) Fuel is listed as a relation we want to add. So, click Fuel to highlight it, as in Figure 170. Click Next.

Step 3: Add subform fields.
This step is exactly the same as step 1. The only difference is that not all of the fields will be used in the subform.
1) Fuel is preselected under Tables or queries.
2) Use the >> button to move all the fields to the right.
3) Click the FuelID field to highlight it.
4) Use the < button to move the FuelID to the left (Figure 171). Click Next.
Step 4: Get joined fields.

This step is for tables or queries for which no relationship has been defined. Because we have already defined the relationship, the wizard skips this step.

Note

It is possible to create a relationship between two tables that is based upon more than one pair of fields. How to do that and why is discussed in the *Base Guide*.

Caution

When selecting a pair of fields from two tables to use as a relationship, they have to have the same field type. That is why we used the Date field from both tables: both their field types are Date[DATE]. Whether a single pair of fields from two tables are chosen as the relationship or two or more pairs are chosen, certain requirements must be met for the form to work.

- No field from the subform can be the Primary key for its table. (FuelID cannot be used.)
- Each pair of joined fields must have the same file type.
- One of the fields from the main form must be the Primary key for its table. (Date would have to be used.)

Step 5: Arrange controls.

Each control in a form consists of two parts: label and field. This step in creating the form determines where a control's label and field are placed in relationship with each other. The four choices from left to right are *Columnar left*, *Columnar - Labels on top*, *As Data Sheet*, and *In Blocks - Labels Above*.

1) Arrangement of the main form: Click the second icon (*Columnar - Labels on top*). The labels will be placed above their field.

2) Arrangement of the subform: Click the third icon (*As Data Sheet*). (The labels are column headings and the field entries are in spreadsheet format.) Click *Next*.

Arrange the controls on your form

<table>
<thead>
<tr>
<th>Label placement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align left</td>
</tr>
<tr>
<td>Align right</td>
</tr>
</tbody>
</table>

Arrangement of the main form

- Columnar - Labels on Top

Arrangement of the subform

- As Data Sheet
Step 6: Set data entry.
Unless you have a need for any of these entries to be checked, accept the default settings. Click Next.

Step 7: Apply styles.
1) Select the color you want in the Apply Styles list. (I chose the beige which is Orange 4 in the Color table.)
2) Select the Field border you want. (I prefer the 3-D look. You might want to experiment with the different possible settings.)
3) Click Next.

Step 8: Set name.
1) Enter the name for the form. In this case, it is Fuel.
2) Click Modify the form.
3) Click Finish. The form opens in Edit mode.

Modifying a form
We will be moving the controls to different places in the form and changing the background to a picture. We will also modify the label for the PaymentType field as well as change the field to a list box.

First, we must decide what we want to change. The discussion will follow this ten step outline of our planned changes.

1) Provide a dropdown capability for the Date field in the main form, and lengthen the field to show the day of the week, month, day, and year.
2) Shorten the length of the payment fields (all fields containing the word Payment).
3) Move the controls into groups: food, fuel subform, and miscellaneous.
4) Change the wording of some of the labels. Some single words should be two words. Some abbreviations should be used if possible (Misc. for miscellaneous).
5) Change the lengths of several fields and labels. Only Lunch, Supper, Motel, and Tolls have acceptable lengths. But for a better appearance, changes will be made to these as well.
6) Replace all the fields whose label ends in Payment with a list box containing the entries from the Payment Type table.
7) Lengthen the Note field vertically, add a scroll bar, and move it.
8) Make changes in the Date and PaymentType columns of the subform that are similar to the changes in the main form.
9) Add headings for each group in the main form.
10) Change the background to a picture, then modify some of the labels so that they can be read clearly. Change the font color of the headings.

Here are some methods that we will be using in these steps. The controls in the main form consists of a label and its field. Sometimes we want to work with the entire control, other times we want to work with only the label or the field, and there are times when we want to work with a group of controls.

• Clicking a label or field selects the entire control. A border appears around the control with eight green handles. You can then drag and drop it where you want.
Control+click a label or field selects only the label or the field. You can press the Tab key to change the selection from the field to the label or the label to the field.

Moving a group of controls is almost as easy as moving one of them.
1) Click the field of the top left control to be moved, to select it.
2) Move the cursor to just above and to the left of the selected control.
3) Drag the cursor to the bottom right of the group of controls and release the mouse button.
   As you drag the cursor, a dashed box appears showing what is contained in your selection. Make sure it is big enough to include the entire length of all the controls. When you release the mouse button, a border with its green handles appears around the controls you selected.

Move the cursor over one of the fields. It changes to a drag icon. Drag the group of controls to where you want them.

Tip
When either changing size or moving a control, two properties of the Form Design toolbar should be selected: Snap to Grid, and Guides when Moving. Your controls will line up better, and an outline of what you are moving moves as the cursor moves.
You should also have both rulers active (View > Ruler).

Step 1: Change the Date field.
1) Control+click the Date field to select it.
2) Move the cursor over the middle green handle on the right side. It should change to a double-headed arrow.
3) Hold the left mouse button down as you drag the cursor to the right until the length is 6 cm. The vertical dashed line is lined up with the 6. Release the mouse button.
4) Click the Control icon in the Form Controls toolbar. The Properties: Date Field window opens. Each line contains a property of the field.
• Scroll down to the Date format property. This is a dropdown list with Standard (short) as the default setting. Click it to open the list. Select the Standard (long) entry.
• Scroll down to the Dropdown property. Its default setting is No. It is also a dropdown list. Click to open the list. Select Yes.

**Tip**
To see what the Date field will look like, click the Form Mode On/Off icon (the second icon from the left in Figure 175). You can do this any time you want to see the form with the changes you have made.

---

**Step 2: Shorten the width of some fields.**

All of the fields with a label containing the word payment are too wide. They need shortening before the controls are moved.

1) Control+click the BPayment field.

![Figure 176: Selecting a field](image)

2) Move the cursor over the middle green handle on the right. The cursor becomes a double-headed arrow.

3) Drag the cursor to the left until the field is 2.5 cm wide (1 inch).

**Tip**
If you have the Snap to Grid and Guides when moving icons selected in the Design Format toolbar, you will see how wide the field is as you shorten it.

4) Repeat these steps to shorten these fields: Lpayment, SPayment, SnPayment, Mpayment, and MiscPayment.

---

**Step 3: Move the controls to group them by category.**

We want to move the controls so that they look like Figure 177.

![Figure 177: Positioning of controls](image)

1) Click the first control you want to move. A border appears around the control with eight green handles.
2) Move the cursor over the label or field of the control. It change shape to a drag icon.
3) Drag and drop the control to where you want it.

**Caution**

Do not use *Control+click* when moving a field. It moves either the field or the label but not both. To move both, use a *mouse click* and drag to the desired spot.

4) Use the same steps to move the rest of the controls to where they belong.

**Step 4: Change the label wording.**

*Field names* need to be single words. However, the labels for the fields in a form can be more than one word. So, we will change them by editing the text in the label.

**Note**

The table wizard in Base contains suggested fields which are single words, often consisting of two separate words. Table names in the wizard have been that way also. However, you can use multiple words as the name of a field, label, or table. We will do so when we create a list box for each of the *payment type* controls.

1) *Control+click* the SnackNo label. Do one of the following:
   - Right-click the SnackNo label and select *Control* from the pop-up menu.
   - Or, click the Control icon in the Form Control toolbar (Figure 175).
2) The dialog that opens is labeled Properties: Label Field. It contains all of the properties of the selected label.
   - In the Label selection, edit the label to Snack No.
   - Close the Properties dialog.
3) Use the same procedure to change these labels as well: BPayment to Payment, LPayment to Payment, SPayment to Payment, Miscellaneous to Misc., SnackCost to Snack Cost, MPayment to Payment, MiscPayment to Misc. Payment, and MiscNotes to Misc. Notes.

**Tip**

You can modify all of the listings in the Properties window. For example, if you change the Alignment from Left to Center, the word or words in the label are centered within the label. When you have some time, you might want to experiment with different settings just to see the results you get.

**Step 5: Change the widths of the labels and fields.**

We want the following controls to be 2 cm wide (0.8 inches): Breakfast, Lunch, Supper, Odometer, Snack No., Tolls, Snack Cost, Motel, and Misc. All of the payment fields were changed in step 2, but Misc. Payment needs to be changed to 3 cm (1.2 inches).

1) Right-click Breakfast and choose **Position and Size**. On the Position and Size dialog, change Width to 2 cm.
2) Repeat for the other listed controls, using 3 cm for Misc.Payment.
Caution

When changing the position or size of an entire control, use the Position and Size dialog or the drag and drop method.

When working with either the label or the field (but not both at the same time), you can use the Properties dialog to make these changes when you want to be exact. However, you need to be careful not to accidentally select the entire control for use with the Properties dialog or you will apply the exact same values to both the label and field. For example, if you enter the values for a new position, both the field and the label moves to the same position and the field is positioned on top of the label. Then you have to move each of them to where you want them.

Note

To open the Properties window, right-click a control and select Control from the pop-up menu. Or, you can click the Control icon in the Form Controls toolbar. Just be careful, and use Control+Z to undo any mistakes you may make. Detailed instructions on how to use the Properties window will be in the Base Guide.

Step 6: Replace fields with other fields.

We want to replace the PaymentType field with a List Box. Then we can choose the type of payment from the Payment Type table rather than having to manually enter the type. In my case, each of my payment types begins with a different letter. If I enter the first letter of the payment type, the rest of the word automatically appears. I can then go to the next field.

1) Control+click the Payment field for Breakfast. The green handles appear around the field but not around the Label.

2) Right-click within the green handles and select Replace with > List Box.

3) Click the Control icon in the Form Controls toolbar to open the Properties: List Box dialog.

4) On the General tab, scroll down to the Dropdown selection. Change the No to Yes.

---

Figure 178: Selecting a field of a control

Figure 179: Dropdown list open to reveal choices
5) Click the **Data** tab.

- **Type of list contents** is a dropdown list. Change it to **Sql**.

![Type of list contents dropdown list](image1.png)

*Figure 180: Type of list contents dropdown list*

- Type the following **exactly** as it is in the **List contents** box:
  
  ![List content for payment type fields](image2.png)

  *Figure 181: List content for payment type fields*

  ```sql
  SELECT "Type", "Type" FROM "Payment Type"
  ```

**Note**

What you wrote is called an SQL command. The words **SELECT** and **FROM** are written in capital letters because they are commands. When the command **SELECT** is used, it requires a field name within quotation marks and then the field's alias, also within quotation marks. In this case, the field and its alias are the same. The **FROM** command requires the name of the table which contains the field. Single-word table names do not require quotation marks, but multiple-word table names do.

- Repeat these steps for the payment fields for Lunch, Supper, Motel, Snacks, and Misc. The main form should look like Figure 182 as far as where the controls are located. It also shows what the Note control should look like. Those changes are explained in the next step.
- Close the Properties window.
Step 7: Change the Misc. Notes field.

We want the Misc. Notes control, which has a field type of Memo, to have a vertical scrollbar for additional text space if desired.

1) Control+click the Misc. Notes field. The green handles should surround the field but not its label.
2) Click the Control icon to open the Properties window (Figure 183).
3) Scroll down to the Scrollbars setting. Change the selection from None to Vertical in this dropdown list.
4) Close the Properties window.
5) Lengthen the Misc. Notes field by moving the cursor over the middle green handle at the bottom of the field and dragging down until the length is 6 cm (2.4 inches).

Figure 183: Scrollbar selections in the Properties window
Step 8: Change labels and fields in the subform.

The subform is located at the bottom of the form. We want to widen the Date column, change the field in the PaymentType column to a list box, and change the label for the PaymentType column to two words.

To widen the Date column, move the mouse pointer over the dividing line between the Date and FuelCost columns. When the pointer changes shape, click and drag to move the divider to the right.

To change the PaymentType column:

1) Right-click the label PaymentType and choose Replace with > List box from the menu.
2) Again right-click the label PaymentType to open the menu. Select Column to open the Properties dialog (Figure 184).
3) In the Label box, change PaymentType to Payment Type.
4) Click the Data tab.
5) From the Type of list contents dropdown list, select Sql.
6) Type the following exactly as it is written:
   
   SELECT "Type", "Type" FROM "Payment Type"

7) Close the Properties dialog.

Step 9: Add headings to groups.

This step is easier to do if you have end-of-paragraph markers visible. Choose View > Nonprinting Characters to turn them on.

1) Make sure the cursor in in the upper left corner. If it is not, click in that corner to move it there.
2) Press the Enter key to move the cursor down to the space between the Date field and the Breakfast field.
3) Change the Apply Styles dropdown list from Default to Heading 2.
4) Use the spacebar to move the cursor to where you want the heading to start.
5) Type the heading Meals.
6) Use the spacebar to move the cursor to the center of snack area.
7) Type the heading Snacks.
8) Use the Enter key to move the cursor between the Supper control and the subform.
9) Use the spacebar to move the cursor to the center of the subform.
10) Type the heading Fuel Data.

**Note** If you know how to use styles, you can open the Styles and Formatting window using F11. Right-clicking the Heading 2 paragraph style allows you to modify the appearance of all three headings. See Chapter 6 of the *Writer Guide* for details.

**Step 10: Change the background of a form.**

The background for a form can be a color, or a graphic (picture). You can use any of the colors in the Color Table at **Tools > Options > OpenOffice.org > Colors**. If you know how to create custom colors, you can use them. You can also use a picture (graphic file) as the background.

If you choose a dark background, you may need to change many of the labels and headings so they can be seen.

1) Select the labels of the top row of controls.
   a) **Control+click** the Date label.
   b) **Control+shift+click** the rest of the labels of the top row. The border will gradually grow to the right as you do this until all the labels are enclosed in it.
   c) Click the **Control** icon in the Design Form toolbar to open the Properties dialog.
   d) Change the **Background color selection from Default to Light cyan**. (This is a dropdown list.) Close the Properties dialog.

2) Select the other labels in the same way and then change their background color.

3) To change the font color for the headings:
   a) Open Styles and Formatting using the F11 key. Make sure the Paragraph icon is selected at the left end of the icons in Figure 187.
   b) Right-click the Heading 2 style to open a pop-up window and select **Modify** from this menu.
   c) In the **Paragraph Style Heading 2** dialog, click the **Font Effects** tab. Change **Font color from Automatic to Light Cyan**.
d) Click **OK** to close the dialog.

### Tip

Learning how to use styles can be very helpful at times. By using styles, we changed the font color for all three headings at one time. There are other methods of changing the font color, but they require repeating the same steps for each heading.

4) To add a graphic to the background:
   a) Right-click on the background and select **Page** from the pop-up menu.
   b) On the Page Style dialog, click the Background tab, change the As dropdown list from **Color** to **Graphic**.
   c) Click Browse to find and select the graphic file you want to use, and click **Open**. In the Type section of the Background tab, select **Area**.
   d) Click **OK** to close the dialog. The form should look like Figure 188.

---

**Figure 187: Styles and Formatting window**

**Figure 188: Finished form**
Step 11: Change the tab order.

The Tab key moves the cursor from field to field. This is much easier to do than to click each field to enter data into it. It also permits us to group our expenses into areas before we begin entering data. For example, all of our meal receipts can be grouped together as can our snacks and also our fuel purchases.

1) Control+click the Date field.
2) Click the Form Design icon in the Form Controls toolbar to open the Form Design toolbar (Figure 189), or choose View > Toolbars > Form Design to open this toolbar.
3) Click the Activation Order icon (circled).

Figure 189: Form Design toolbar with Activation Order icon circled

4) Rearrange the order of the fields in the Tab Order window.
   a) Find the txtMPayment listing near the bottom of the list and click it.
   b) Click the Move Up button until txtPayment is just below fmtMotel.
   c) Use the same two steps to put the fields in the same order as in Figure 190. Click OK.

Figure 190: Tab order for the main form

5) Save and close the form.
6) Save the database.

Creating forms and subforms in Design View

This method requires using the Form Controls and Form Design toolbars extensively. These techniques are beyond the scope of this document. Instructions for creating forms using Design view will be described in the Database Guide.
Accessing other data sources

OpenOffice.org allows data sources to be accessed and then linked into AOO documents. For example, a mail merge links an external document containing a list of names and addresses into a letter, with one copy of the letter being generated for each entry.

To access a data source that is not a *.odb file:

1) **File > New > Database** opens the Database Wizard window.
2) Select **Connect to an existing database**. Click the arrow next to the Database type field and select the database type from the drop-down list. Click Next.
3) Click **Browse** and select the database. Click Next.
4) Accept the default settings: Register the database for me, and Open the database for editing. Click Finish. Name and save the database in the location of your choice.

Accessing a spreadsheet as a data source

Accessing a spreadsheet is similar to accessing other databases:

1) Choose **File > New > Database**.
2) Select **Connect to an existing database**. Select Spreadsheet as the Database type.
3) Click **Browse** to locate the spreadsheet you want to access. If the spreadsheet is password protected, check the Password required box. Click Next.
4) If the spreadsheet requires a user’s name, enter it. If a password is also required, check its box. Click Next.

**Note**

Using this method of accessing a spreadsheet, you cannot change anything in the spreadsheet. You can only view the contents of the spreadsheet, run queries, and create reports based upon the data already entered into the spreadsheet.

All changes in a spreadsheet must be made in the spreadsheet itself, using Calc. After modifying the spreadsheet and saving it, you will see the changes in the database. If you create and save an additional sheet in your spreadsheet, the database will have a new table the next time you access it.

Registering *.odb databases

Databases created by OOo2.x or later are in the *.odb (OpenDocument Base) format. Other programs can also produce databases in this format. Registered a *.odb database is simple:

1) Choose **Tools > Options > OpenOffice.org Base > Databases**.
2) Under Registered databases, click New.
3) Browse to where the database is located.
4) Make sure the registered name is correct.
5) Click OK.

Using data sources in Apache OpenOffice

Having registered the data source, whether a spreadsheet, text document, external database or other accepted data source, you can use it in other AOO components including Writer and Calc.
Viewing data sources

Open a document in Writer or Calc. To view the data sources available, press F4 or select View > Data Sources from the pull-down menu. This brings up a list of registered databases, which will include Bibliography and any other database registered, such as the Automobile database created earlier in this chapter.

To view each database, click on the + to the left of the database’s name (see Figure 191). This brings up Tables and Queries. Click on the + next to Tables to view the individual tables created. Now click on a table to see all the records held in it.

![Figure 191: Databases](image)

Editing data sources

Some data sources can be edited in the View Data Sources dialog. A spreadsheet can not. A record can be edited, added, or deleted.

The data is displayed on the right side of the screen. Click in a field to edit the value.

Beneath the records are five tiny buttons. The first four move backwards or forwards through the records, or to the beginning or end. The fifth button, with a small star, inserts a new record.

![Figure 192: View Data Sources navigation buttons](image)

To delete a record, right-click on the gray box to the left of a row to highlight the entire row, and select Delete Rows to remove the selected row.

![Figure 193: Deleting a row in the Data View window](image)

Launching Base to work on data sources

You can launch Base at any time from the View Data Source pane. Just right-click on a database or the Tables or Queries icons and select Edit Database File. Once in Base, you can edit, add, and delete tables, queries, forms, and reports.

Using data sources in Writer and Calc

Data can be placed into Writer and Calc documents from the tables in the data source window. In Writer, values from individual fields can be inserted. Or, a complete table can be created in the Writer document. One common way to use a data source is to perform a mail merge.
Tip
Choosing Tools > Mail Merge Wizard or clicking on the Mail Merge icon on the View Data Source pane launches the Mail Merge wizard which steps you through creating a mail merge document. See Chapter 11 in the Writer Guide.

Writer documents
To insert a field from a table opened in the data source window into a Writer document, click on the field name (the gray square at the top of the field list) and, with the left mouse button held down, drag the field onto the document. In a Writer document, it will appear as <FIELD> (where FIELD is the name of the field you dragged).

For example, to enter the cost of meals and who paid for them on a certain date of a vacation:

1) Open the list of data sources (F4) and select the Vacations table in the Automobile database.

2) Use this sentence: “On (date), our breakfast cost (amount) paid by (name), our lunch cost (amount) paid by (name), and our supper cost (amount) paid by (name).” But only type “On , our breakfast cost paid by , our lunch cost paid by , and our supper cost paid by .”

3) To replace (date), click the field name Date in the data source window and drag it to the right of the word On. The result: On <Date>. If you have Field shadings turned on (View > Field shading), <Date> has a gray background. Otherwise it does not.

4) To replace first (amount), click the Breakfast field name and drag it to the right of our breakfast cost. Make sure you have the proper spacing between the field names and the words before and after them. Result: breakfast cost <Breakfast>.

5) To replace the first (name), click the BPayment field name and drag it to the right of paid by. Result: paid by <BPayment>.

6) In the same way, fill in the rest of the fields in the sentence.
   • Use <Lunch> and <LPayment> for the second set of (amount) and (name) in the sentence.
   • Use <Supper> and <SPayment> for the third set of (amount) and (name) in the sentence.

7) Final result: On <Date>, our breakfast cost <Breakfast> paid by <BPayment>, our lunch cost <Lunch> paid by <LPayment>, and our supper cost <Supper> paid by <SPayment>.

8) Add data to the fields of the sentence:
   • Click the gray box to the left of the row of data you want to add. That row should be highlighted like the second row of Figure 194.
   • Click the Data to Fields icon (circled). This should fill the fields with the data from the row you chose.
   • Click another row and then click this icon again. The data in the sentence changes to this selected row of data.
   • Save the document if you want to use it as an example later.
Adding data in table format is a little easier and takes perhaps fewer steps. Some of the steps will be quite similar.

1) Navigate to the place you want to place the table and click the location.

2) Control+Click the gray box to the left of each row of the data source that you want to be a row in your table when the rows are not consecutive. To select consecutive rows, click the gray box to the left of the top desired row and Shift+click the bottom desired row.

3) Click the Data to text icon to open the Insert Database Columns dialog (Figure 195). (The Data to text icon is to the left of the Data to Fields icon in Figure 194.)

4) Move the fields you want in your table from the Database Columns list to the Table column(s) list.
   - To place the fields in the order you select, click the field and use the single arrow to move the fields in the order you desire. You can also limit the fields you use to less than all of the fields available.
   - If you want to use all of the fields, use the double arrow pointing to the right to move all of them at one time. The order of the fields in the table you create will be the same as in the data source table.
   - To remove a single field from the Table Column(s) list, click the field and use the single arrow pointing to the left.

5) To start over, click the double arrow pointing to the left.

6) Select the settings for your table. Use the default settings as in Figure 195.

7) Click OK. Save the document.

**Calc spreadsheets**

There are two ways to enter data in a Calc spreadsheet. One enters the data into the spreadsheet cells. The other creates records in the spreadsheet just like they are done in creating a form in a database. While you can directly access the data in the spreadsheet cells, you can only see the data in the records created in the spreadsheet.

Entering data directly to the spreadsheet cells uses the Data to Text icon as we did to make a table in a Writer document. But differences exist in these two situations.

The steps are straightforward.
1) Click the cell of the spreadsheet which you want to be the top left of your data including the column names.
2) Use F4 to open the database source window and select the table whose data you want to use.
3) Select the rows of data you want to add to the spreadsheet:
   • Click the gray box to the left of the row you want to select if only selecting one row. That row is highlighted.
   • To select multiple rows, hold down the Control key while clicking the gray box of the rows you need. Those rows are highlighted.
   • To select all the rows, click the gray box in the upper left corner. All rows are highlighted.
4) Click the Data to text icon to insert the data into the spreadsheet cells.
5) Save the spreadsheet.

Adding records to a spreadsheet is fairly easy. You need to have the Data Source window open, your spreadsheet open, and the table you want to use selected.

1) Click the gray box above the field name for the table's ID field.
2) Drop and drag the gray box for the table's ID field to where you want the record to appear in the spreadsheet.
3) Repeat until you have moved all of the fields you need to where you want them.
4) Name and save the spreadsheet.
5) Click a row of the table in the Data Source window.
6) Drag the data in the ID field in the selected row onto the ID field in the spreadsheet. The Save icon should activate.
7) Click the Edit File button to make the spreadsheet read only. Click Save when asked if you want to save the file.
8) The Data Source window goes blank, the fields in the spreadsheet are populated with data from the row you selected, and the Form Navigation toolbar appears at the bottom of the spreadsheet.

![Figure 196: Navigation arrows of a form](image)

9) Click the arrows on the Form Navigation toolbar to view the different records of the table. (The arrows are circled in red.) The number in the box changes when you change the record number by clicking an arrow. The data in the fields changes correspondingly to the data for that particular record number.

## Entering data in a form

*Records* are used to organize the data we enter into a form. They also organize the data we enter into a subform.

Each type of field allows a different method to enter the data. In many if not all cases, more than one method can be used.

The first step to entering data in a form is to open it from the main database window (Figure 163).

1) Click the Forms icon in the Database list.
2) Find the form's name in the Forms list (Vacations).
3) Double-click the form’s name.
The quickest way to enter a date in the Date field is to click the arrow that opens the dropdown calendar. Then click the day you want. Then press the Tab key to go to the Odometer field.

![Calendar dropdown](image)

**Figure 197: Calendar dropdown**

The Odometer, Tolls, and Motel fields are numerical fields. Enter values directly into them, or use the up and down arrows. When the value is entered, use the Tab key to go to the next field.

- Clicking the up arrow increases the value, and the down arrow decreases the value one unit.
- These two arrows only change the numerals to the left of the decimal place.
- Numerals to the right of the decimal place must be changed by deleting them and typing the desired ones.

The Motel's Payment field is a dropdown list. If as in my case, all of the elements of the list start with different letters, typing the first letter selects the desired entry.

- If two or more elements of the list have the same first letter, repeated typing of the first letter will cycle through the elements with this same first letter.
- When the selection is correct, use the Tab key to go to the Misc. field.

The rest of the fields of the main form are either numerical fields or dropdown lists until we reach the Misc. Notes field. It is a text field. Type anything you desire in this field just as you would any simple text editor.

Since the Tab key is used to move between fields, it can not be used in a text field. All spacing must be done by the spacebar. Finally, the Enter key only acts as a line break to move the cursor to the next line. While the Enter key will move from non-text fields to non-text fields, it will not do so from a text field. Use the Tab key instead.

If we did not have a subform for fuel data, pressing the Tab key in the last field would save all of the fields, clear them, and make the form ready to accept data on the second record.

Since we have a subform form, using the Tab key places the cursor in the first Date field of the subform with the date automatically entered to match the Date field of the main form.

The FuelCost, FuelQuantity, and Odometer fields are numerical fields. The Payment field is a dropdown list. Enter the data just as you did in the main form, and use the Tab key to go to the next field.

When you use the Tab key to leave the Payment field, it goes to the Date field of the next line and automatically enters the date. Now you can enter your second set of fuel data for this day.
To move to another record when the form has a subform, click any of the fields of the main form. In this case, click the Date field of the main form. Then use the directional arrows at the bottom. There are four of them from left to right: First Record, Previous Record, Next Record, and Last Record (Figure 196). To the right of these arrows is the New Record icon.

To create a new record while in another record in the main form, click either the Next Record icon or the New Record icon.

**Tip**

The number in the Record box is the number of the record whose data is shown in the form. If you know the number of the record you want, you can enter it into the record box and then press Enter to take you to that record.

Error: Reference source not found is a record with data inserted in its fields.

Creating queries

Queries are used to get specific information from a database. Query results are special tables within the database.

To demonstrate the use of queries, we will use two different methods:

- Using our CD-Collection table, we will create a list of albums by a particular artist. We will do this using the Wizard.
- The information we might want from the Fuel table includes what our fuel economy is. We will do this using the Design View. (Queries that require calculations are best created with the Design view.)
Using the Wizard to create a query

Queries created by the wizard provide a list or lists of information based upon what one wants to know. It is possible to obtain a single answer or multiple answers, depending upon the circumstances.

In the main database window (Figure 163), click the Queries icon in the Databases section, then in the Tasks section, click Use Wizard to Create Query. The Query Wizard window opens (Figure 199). The information we want is what albums are by a certain musical group or individual (the album's author). We can include when each album was bought.

---

**Note**

When working with a query, more than one table can be used. Since different tables may contain the same field names, the format for naming fields in a query is `Table name.field name`, with a period (.) between the table name and the field name. For example, The Lunch field of the Vacation table used in a query has the name `Vacation.Lunch`.

---

**Step 1: Select the fields.**

1) Select the CD-Collection table from the dropdown list of tables.
2) Select fields from the CD-Collection table in the Available fields list.
   a) Click Artist, and use the > button to move it to the Fields in the Query list.
   b) Move the AlbumTitle and DatePurchased fields in the same manner.
   c) Click Next.

**Tip**

To change the order of the fields, select the field you want to move and click the up or down arrow.

![Select the fields (columns) for your query](image)

**Figure 199: First page of the Query Wizard**

---

**Step 2: Select the sorting order.**

Up to four fields can be used to sort the information of our query. A little simple logic helps at this point. Which field is most important?
In our query, the artist is most important. The album title is less important, and the date purchased is of least importance. Of course, if we were interested in what music we bought on a given day, the date purchased would be the most important.

Figure 200: Sorting order page

1) Click the first Sort by dropdown list.
   • Click CD-Collection.Artist to select it.
   • To list the artists in alphabetical order (a-z), select Ascending on the right.

2) Click the second Sort by dropdown list.
   • Click CD-Collection.ArtistTitle and select Ascending.

3) Repeat this process for CD-Collection.DatePurchased.

4) Click Next.

Step 3: Select the search conditions.

The search conditions allow us to compare the name we entered with the names of the artist in our database and decide whether to include a particular artist in our query or not.

• is equal to: the same as
• is not equal to: not the same as
• is smaller than: comes before
• is greater than: comes after
• is equal or less than: the same as or comes before
• is equal or greater than: the same as or comes after
• like: similar to in some way

Note These conditions apply to numbers, letters (using the alphabetical order), and dates.

1) Since we are only searching for one thing, we will use the default setting of Match all of the following.

2) We are looking for a particular artist, so select CD-Collection.Artist in the Fields list and is equal to as the Condition.

3) Type the name of the artist in the Value box. Click Next.

Step 4: Select type of query.

We want simple information, so the default setting: Detailed query is what we want. Click Next at the bottom of the window.
Step 7: Assign aliases if desired.  
We want the default settings. Click Next.

Step 8: Overview.  
Name the query (suggestion: Query_Artists). To the right of this are two choices. Select Display Query. Click Finish.

Using the Design View to create a query  
Creating a query using Design View is not as difficult as it may first seem. It may take multiple steps, but each step is fairly simple.

What fuel economy is our vehicle getting (miles per gallon in the USA)? This question requires creating two queries, with the first query used as part of the second query.

Step 1: Open the first query in Design View.  
Click Create Query in Design View.

Step 2: Add tables.

![Add Table or Query window](image)

1) Click Fuel to highlight it.  
2) Click Add. Click Close.

**Tip**  
Move the cursor over the bottom edge of the fuel table (Figure 202) and drag the to make it longer and easier to see all of the fields in the table.
Step 3: Add fields to the table at the bottom.

1) Double-click the FuelID field in the Fuel table.
2) Double-click the Odometer field.
3) Double-click the FuelQuantity field.

The table at the bottom of the query window should now have three columns.

![Figure 203: Query table](image)

Step 4: Set the criterion for the query.

We want the query’s FuelID to begin with the numeral 1.

1) Type >0 in the Criterion cell under FuelID in the query table.
2) Click the Run Query icon in the Query Design toolbar.

![Figure 204: Query Design toolbar](image)

Figure 205 contains the Fuel table with my entries and the query results based upon the Fuel table: the query results are in the right table.

![Figure 205: Fuel table and query of the fuel table](image)

Step 5: Save and close the query.

Since this query contains the ending odometer reading for our calculations, name it End-Reading when saving it. Then close the query.

Step 6: Create the query to calculate the fuel economy.

1) Click Create Query in Design View to open a new query.
2) Add the Fuel table to the query just as you did in step 2 (Figure 206). But, do not close the Add Tables window.
3) Add the End-Reading query to this query.
   a) Click Queries to get the list of queries in the database.
b) Click End-Reading.

c) Click Add, and then click Close.

**Step 7: Add fields to the table at the bottom of the query.**

We are going to calculate the fuel economy. To do this we need the FuelQuantity and distance traveled. Since the FuelQuantity we want to use is at the ending odometer reading, we will use the End-Reading query to get it. We will also use the Odometer field from the Fuel table and End-Reading query.

**Figure 207: Tables in this query**

1) Double-click FuelQuantity in the End-Reading query.
2) Double-click Odometer in the End-Reading query.
3) Double-click Odometer in the Fuel table.

**Figure 208: Added fields to the query**

**Step 8: Enter the FuelID difference field.**

We want the difference between the FuelID value of the Fuel table and FuelID value of the End-Reading query to equal one (1).

1) Type "End-Reading"."FuelID" - "Fuel"."FuelID" in the field to the right of the Odometer field of the Fuel Table.
   Type the numeral 1 (one) in the Criterion cell of this column.
2) Calculate the distance traveled:
   - Type "End-Reading"."Odometer" - "Fuel"."Odometer" in the Field cell.
   - Type >0 in the Criterion cell.

3) Calculate fuel economy:
   Type ("End-Reading"."Odometer" - "Fuel"."Odometer")/"End-Reading"."FuelQuantity" in the next column to the right of the word Field.

Note
When entering fields for these calculations, you must follow this format: table or query name followed by a period followed by the field name. For hyphenated or multiple-word names (table or query), use double quotes around the table or query name. The query will then add the rest of the double quotes as in Figure 211.

Use the arithmetical symbol between the two. More than one calculation can be done by using parentheses to group the arithmetical operations.

Step 9: Run the query and make some modification.
After we run the query to make sure it works correctly, we will hide all of the fields that we do not need.

   1) Click the Run Query icon in the Design Query toolbar (Figure 204). The results are in Figure 212.
Figure 212: Result of running the fuel economy query

Notice that not all of the last column label is visible because some of the labels are long. We can fix this problem by using an alias for many of the fields. The labels are replaced by their aliases.

2) Add Aliases:
Type in the aliases as they are listed in Figure 213.

<table>
<thead>
<tr>
<th>FuelQuantity</th>
<th>Odometer</th>
<th>Odometer</th>
<th>&quot;End-Reading&quot;</th>
<th>&quot;FuelID&quot; - &quot;Fuel&quot;</th>
<th>Fuel Economy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quantity</td>
<td>Begin</td>
<td>End</td>
<td>&quot;End-Reading&quot;</td>
<td>&quot;FuelID&quot; - &quot;Fuel&quot;</td>
<td>Fuel Economy</td>
</tr>
<tr>
<td>End-Reading</td>
<td>End-Reading</td>
<td>Fuel</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 213: Query table with aliases added

3) Run the query again. The results are in Figure 214.

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Begin</th>
<th>End</th>
<th>&quot;End-Reading&quot;</th>
<th>&quot;FuelID&quot; - &quot;Fuel&quot;</th>
<th>Distance</th>
<th>Fuel Economy</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.430</td>
<td>778.7</td>
<td>704.2</td>
<td>1</td>
<td>74.5</td>
<td>11.59</td>
<td></td>
</tr>
<tr>
<td>19.570</td>
<td>1032.3</td>
<td>778.7</td>
<td>1</td>
<td>253.6</td>
<td>12.96</td>
<td></td>
</tr>
<tr>
<td>15.150</td>
<td>1239.4</td>
<td>1032.3</td>
<td>1</td>
<td>207.1</td>
<td>13.67</td>
<td></td>
</tr>
</tbody>
</table>

Figure 214: Query run with aliases

We really do not need the column showing the difference between the FuelID fields from the table and query, so we will hide it. While it will not be visible, it will still be used in the calculations.

4) Hide a field that does not need to be seen.
Remove the check in the box of the Visible cell as in Figure 215.

<table>
<thead>
<tr>
<th>Field</th>
<th>FuelQuantity</th>
<th>Odometer</th>
<th>Odometer</th>
<th>&quot;End-Reading&quot;</th>
<th>&quot;FuelID&quot; - &quot;Fuel&quot;</th>
<th>Alias</th>
<th>Quantity</th>
<th>Begin</th>
<th>End</th>
<th>&quot;End-Reading&quot;</th>
<th>&quot;FuelID&quot; - &quot;Fuel&quot;</th>
<th>Visible</th>
<th>Table</th>
<th>End-Reading</th>
<th>End-Reading</th>
<th>Fuel</th>
<th>Sort</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>&quot;End-Reading&quot;</td>
<td>&quot;FuelID&quot; - &quot;Fuel&quot;</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 215: Making a field invisible in a query run

5) Rerun the query (Figure 216).

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Begin</th>
<th>End</th>
<th>Distance</th>
<th>Fuel Economy</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.430</td>
<td>778.7</td>
<td>704.2</td>
<td>74.5</td>
<td>11.59</td>
</tr>
<tr>
<td>19.570</td>
<td>1032.3</td>
<td>778.7</td>
<td>253.6</td>
<td>12.96</td>
</tr>
<tr>
<td>15.150</td>
<td>1239.4</td>
<td>1032.3</td>
<td>207.1</td>
<td>13.67</td>
</tr>
</tbody>
</table>

Figure 216: Query run with aliases

Step 10: Close, save, and name the query.
My suggestion for a name is Fuel Economy.

There are obviously other calculations that can be made in this query such as cost per distance traveled and how much of the cost belongs to each of the payments types.
Creating reports

Reports provide information found in the database in a useful way. In this they are similar to queries. Reports are generated from the database’s tables or queries. They can contain all of the fields of the table or query or just a selected group of fields. Reports can be static or dynamic. Static reports contain the data in the selected fields at the time the report was created. Dynamic reports can be updated to show the latest data.

For example, a report on expenses for a vacation in the past should probably be a static report because it is based upon specific data that does not change. However, a report on the fuel data should probably be a dynamic report, because this report depends upon data that does change.

Caution

Dynamic reports update only the data that is changed or added to a table or query. They do not show any modifications made to the table or query itself. For example, after creating the report below, open the fuel economy query created in the previous section. For the "End-Reading"."Odometer – Fuel"."Odometer" column, change the number 1 to the number 3. The report will be identical before and after you make the change.

All reports are based upon a single table or query. So you need first to decide what fields you want to use in the report. If you want to use fields from different tables, you must first combine these fields in a single query. Then you can create a report on this query.

For example, a report on vacation expenses includes both fuel costs and meal costs. These values are contained in fields of two different tables: Vacations and Fuel. So this report requires creating a query.

Creating a static report

We will create a report on vacation expenses. Certain questions need to be asked before creating the report.

- What information do we want in the report?
- How do we want the information arranged?
- What fields are required to provide this information?
- Will a query have to be created because these fields are in different tables?
- Are there any calculations required in the data before being added to the report?

The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper, snacks, and fuel. One possible report would simply list the totals of each of these expense groups. Another possible report would list the expense totals for each day of the vacation. A third possible report would list the totals for each expense group for each type of payment. (This would let us know where the money came from to pay the expenses.) The best way to create reports like these is to create the queries needed to gather the needed data, insert the query data into a spreadsheet, and use the necessary Calc functions on this data.

We will create two reports, one listing the expenses each day other than fuel and the second listing the fuel costs each day.
The fields we need for the first report from the Vacations table are: Date, Motel, Toll, Breakfast, Lunch, Supper, SnackCost, and Miscellaneous. This report will not require an additional query.

The second report involves the Fuel table. Since this table includes fuel purchases at times other than during the vacation, we need to create a query that contains only the fuel purchased during the vacation.

**Vacations table report**

To create a new report.

1) Click the *Reports* icon in the Database list in the Automobile – OpenOffice.org Base window (Figure 163).
2) In the Tasks list, click **Use Wizard to Create Report**. The Report Wizard opens.

**Step 1: Field selection**

1) Select *Table: Vacations* in the Tables or Queries dropdown list.
2) Use the > to move these fields from the *Available fields* list to the *Fields in report* list: Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnackCost. Click **Next**.

![Figure 217: Adding fields to a report](image)

**Step 2: Labeling fields**

Change any field labels you wish. We will shorten Miscellaneous to Misc. Click **Next**.

**Step 3: Grouping**

Since we are grouping by the date, use the > button to move the *Date* field to the Grouping list. Click **Next**.

![Figure 218: Selecting fields for grouping data](image)

**Step 4: Sort options**

We do not want to do any additional sorting. Click **Next**.
Step 5: Choose layout
We will be using the default settings for the layout. Click Next.

Step 6: Create report
- Label the report: Vacation Expenses.
- Select Static report.
- Click Finish.

Note
If you feel adventurous, try selecting some of the other layout choices. After selecting a choice, drag the Report Wizard window out of the way so that you can see what you have selected. (Move the cursor over the Title Bar of the window, and then drag and drop.)

Vacation fuel report
1) Create a query containing only fuel bought on the days of the vacation.
   a) Open a query in Design View.
   b) Follow the steps for adding tables in “Add tables” on page 208 to add the Fuel table.
   c) In the Fuel table, double-click Date and FuelCost to enter them in the table at the bottom of the query.
   d) In the Criterion cell of the Date field, type the following:

   ![Figure 219: Setting the criterion for a query](image)

2) Save, name, and close the query. (Suggestion: Vacation Fuel Purchases.)

Tip
When using dates in a query, enter them in numerical form MM/DD/YYYY or DD/MM/YYYY depending upon your language's default setting for dates (my default setting is MM/DD/YYYY).
Each date must have a # before and after it. Hence, May 25, 2007 is written #05/25/2007# or #25/5/2007# depending upon your language's default setting for dates.

3) Open a new report.
   • Right-click the Vacation Fuel Purchases query.
   • Select Report Wizard from the pop-up menu.

Note
When a new report is opened in this way, the query used to open it is automatically selected in the Tables or queries dropdown list in the Report Wizard.
4) Create the report.
   Use >> to move both fields from the Available fields list to the Fields in report list. Click Next.
5) Label fields.
   Add a space to FuelCost to make it Fuel Cost (two words). Click Next.
6) Group fields.
   Click Date to highlight it. Use > to move the Date field to the Groupings list. Click Next.
7) Choose layout.
   We will be making no changes in the layout. Click Next.
8) Create report (final settings).
   - Use the suggested name, which is the same as the query.
   - Select Static report. Click Finish.

Creating a dynamic report

Now we will create a report with some statistics on our fuel consumption. To do this, we have to modify two queries: End-Reading and Fuel Economy. We will be adding the FuelCost field to the End-Reading query. Then we will add the FuelCost field from the End-Reading query to the Fuel Economy query.

Tip

When opening a query to edit it, it might appear as in Figure 220. If you move your cursor over the black line (circled), it becomes a double headed arrow. Drag it to a lower position.

---

1) Add the FuelCost field to the End-Reading query:
   a) Right-click the End-Reading query and select Edit from the pop-up menu.
   b) In the Fuel table list, double-click to add FuelCost to the bottom table (Figure 221).
   c) Save and close the query.
2) Add the FuelCost field from the End-Reading query to the Fuel Economy query:
   • Right-click the Fuel Economy query and select **Edit** from the pop-up menu.
   • Double-click the FuelCost field in the End-Reading query list to add it to the query table at the bottom.

3) Add a calculation field to the right of the FuelCost field.
   • Type the following in a Field cell in the table at the bottom:
     "End-Reading"."FuelCost"/("End-Reading"."Odometer" - "Fuel"."Odometer")
   • Type the following in its Alias cell: *cost per mile*.

   **Note** If you use the metric system, *cost per km* is the appropriate alias.

4) Save and close the query.
5) Open a new report.
   Right-click the Fuel Economy query and select **Report Wizard**.
6) Select fields.
   Move all the fields from the Available fields to the Fields in report list. Use the >> to do so.
   Click **Next**.
7) Label fields.
   Change FuelCost to Fuel Cost by placing a space between the words. Click **Next**.
8) Group fields.
   Use > to move the Date field to the Groupings list. Click **Next**.
9) Sort options: the wizard skipped this one.
10) Choose layout: accept the default. Click **Next**.
11) Create the report.
   • Change the report name to Fuel Statistics.
   • The default setting is Dynamic report, so no change is necessary.
   • Select Modify report layout.
   • Click **Finish**.
Modifying a report

At the end of the last section, we left the Fuel Statistics report open in the edit mode (Figure 222). We will be working on that report. These same steps can be used with any report that you open for editing.

The Author is the name you listed in Tools > Options > OpenOffice.org > User Data. The date is not correct. The columns need to be moved to the left to give a better appearance. None of the numbers are correct, but their only purpose is to show the number of decimal places.

**Step 1: Change the date.**

1) Click to the right of the date (4/26/20) so that the cursor is next to the field. Use the Backspace key to erase the date.
2) **Insert > Fields > Date.** This places today’s date where the original date was.
3) Change the date formatting:
   a) Double-click the date field you just inserted. The Edit Fields: Document window opens.
   b) Since this is a dynamic report, change the Select field from Date (fixed) to Date.
   c) Change the Format to what you desire. (I use the Friday, December 31, 1999 choice.) Click OK.

**Step 2: Change the column widths.**

The column widths can be changed by moving the cursor over the right border of each column so that it becomes a double-headed arrow. Then drag and drop it to where you want it. This has to be done for each column in each table in the report. This can also be done with the last column on the right even though there is no black border. It should now look something like Figure 224.

![Figure 222: A report in edit mode](image)

![Figure 223: Modifying a date field](image)

![Figure 224](image)
Step 3: Change the number formatting in the cells.

The fuel quantity should have three decimal places. The Begin, End, and Distance should have one decimal place. Fuel Cost should be currency and have two decimal places, and Cost per mile should have three decimal places.

1) Right-click the cell below Quantity and select **Number format**. (The cell is circled in Figure 224.)

2) In the **Options** section (Figure 225),
   a) Change the number of Decimal places to 3.
   b) Click the green checkmark. Click **OK**.

3) Change the Cost per mile field.
   a) Right-click in the cell below Fuel Cost.
   b) Select **Number Format**.
   c) In the Category list, select **Currency**. Click **OK**.

4) Change the Fuel Cost field.
   a) Right-click in the cell below Cost per mile.
   b) Select **Number Format**.
   c) In the Category list, select **Currency**.
   d) In the Option section:
      • Set the number of decimal places to 3.
      • Click the green checkmark.
   e) Click **OK**.

Step 4: Save and close the report.

Double-click the report. It should now look like Figure 226.
<table>
<thead>
<tr>
<th>Date</th>
<th>Motel</th>
<th>Tolls</th>
<th>Misc.</th>
<th>Breakfast</th>
<th>Lunch</th>
<th>Supper</th>
<th>SnackCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Friday, May 25, 2007</td>
<td>$50.00</td>
<td>$2.00</td>
<td></td>
<td>$11.00</td>
<td>$15.00</td>
<td>$13.00</td>
<td>$5.00</td>
</tr>
<tr>
<td>Saturday, May 26, 2007</td>
<td>$48.00</td>
<td>$4.00</td>
<td></td>
<td>$13.00</td>
<td>$10.00</td>
<td>$15.00</td>
<td>$7.00</td>
</tr>
<tr>
<td>Sunday, May 27, 2007</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 226: Final report*
Chapter 8
Getting Started with Math
Apache OpenOffice’s Equation Editor

What is Math?
Math is Apache OpenOffice’s component for writing mathematical equations. It is most commonly used as an equation editor for text documents, but it can also be used with other types of documents or stand-alone. When used inside Writer, the equation is treated as an object inside the text document.

Note: The equation editor is for writing equations in symbolic form, as in equation 1. If you want to evaluate a numeric value, see the Calc Guide.

\[
\frac{df(x)}{dx} = \ln(x) + \tan^{-1}(x^2)
\]

Getting started
To insert an equation, choose Insert > Object > Formula.
The equation editor opens at the bottom of the screen, and the floating Elements window may appear. You will also see a small box with a gray border in your document, where the formula will be displayed. (See Figure 227.)

Entering a formula
The equation editor uses a markup language to represent formulas. For example, %beta creates the Greek character beta ( β ). This markup is designed to read similar to English whenever possible. For example, \textit{a over b} produces a fraction: \( \frac{a}{b} \).
You can enter a formula in three ways:
- Select a symbol from the Elements window.
- Right-click on the equation editor and select the symbol from the context menu.
- Type markup in the equation editor.
The context menu and the Elements window insert the markup corresponding to a symbol. This provides a convenient way to learn the Math markup.

**Note**

Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

### The Elements window

The simplest method for entering a formula is to use the Elements window.
The Elements window is divided into two main parts.

• The **top** shows the symbol categories. Click on these to change the list of symbols.
• The **bottom** shows the symbols available in the current category.

**Tip** You can hide or show the Elements window with View > Elements.

**Example 1:** $5 \times 4$

For this example we will enter a simple formula: $5 \times 4$. On the Elements window:

1) Select the top-left button of the categories (top) section.
2) Click on the multiplication symbol.

When you select the multiplication symbol on the Elements window, two things happen:

• The equation editor shows the markup: `<?>` *times* `<?>`
• The body of the document shows a gray box like this: $\text{□} \times \text{□}$

The `<?>` symbols shown in Figure 230 are placeholders that you can replace by other text, for example 5 and 4. The equation will update automatically, and the result should resemble Figure 231.
To keep the equation from updating automatically, choose **View > AutoUpdate display** from the menu bar. To update a formula manually, press **F9** or choose **View > Update**.

![Figure 231. Result of entering 5 and 4 next to the times operator](image)

**Right-click (context) menu**

Another way to access mathematical symbols is to right-click on the equation editor. This pops up the menu shown in Figure 232. The items in this menu correspond exactly to those in the Elements window.

![Figure 232. Right-click (context) menu](image)

**Markup**

You can type the markup directly in the equation editor. For example, you can type `5 times 4` to obtain $5 \times 4$. If you know the markup, this can be the fastest way to enter a formula.

**Tip**

The formula markup resembles the way the formula reads in English.
Below is a short list of common equations and their corresponding markup.

<table>
<thead>
<tr>
<th>Display</th>
<th>Command</th>
<th>Display</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>(a = b)</td>
<td>(a = b)</td>
<td>(\sqrt{a})</td>
<td>sqrt {a}</td>
</tr>
<tr>
<td>(a^2)</td>
<td>(a^\text{^2})</td>
<td>(a_n)</td>
<td>(a_n)</td>
</tr>
<tr>
<td>(\int f(x) ,dx)</td>
<td>(\text{int} f(x) ,dx)</td>
<td>(\sum a_n)</td>
<td>(\text{sum} \ a_n)</td>
</tr>
<tr>
<td>(a \leq b)</td>
<td>(a \leq b)</td>
<td>(\infty)</td>
<td>(\text{infinity})</td>
</tr>
<tr>
<td>(a \times b)</td>
<td>(a \times b)</td>
<td>(x \cdot y)</td>
<td>(x \text{ cdot} \ y)</td>
</tr>
</tbody>
</table>

**Greek characters**

Greek characters (\(\alpha\), \(\beta\), \(\gamma\), \(\theta\), and so on) are common in mathematical formulas. *These characters are not available in the Elements window or on the right-click menu.* Fortunately, the markup for Greek characters is simple: Type a % sign followed the name of the character, in English. (In localized versions of OpenOffice.org, these names are localized.)

- To write a lowercase character, type the name of the character in lowercase.
- To write an uppercase character, type the name of the character in uppercase.

A complete table of Greek characters is provided in the *Math Guide*. See the table below for some examples.

<table>
<thead>
<tr>
<th>Lowercase</th>
<th>Uppercase</th>
</tr>
</thead>
<tbody>
<tr>
<td>%alpha (\rightarrow) (\alpha)</td>
<td>%ALPHA (\rightarrow) (A)</td>
</tr>
<tr>
<td>%beta (\rightarrow) (\beta)</td>
<td>%BETA (\rightarrow) (B)</td>
</tr>
<tr>
<td>%gamma (\rightarrow) (\gamma)</td>
<td>%GAMMA (\rightarrow) (\Gamma)</td>
</tr>
<tr>
<td>%psi (\rightarrow) (\psi)</td>
<td>%PSI (\rightarrow) (\Psi)</td>
</tr>
<tr>
<td>%phi (\rightarrow) (\phi)</td>
<td>%PHI (\rightarrow) (\Phi)</td>
</tr>
<tr>
<td>%theta (\rightarrow) (\theta)</td>
<td>%THETA (\rightarrow) (\Theta)</td>
</tr>
</tbody>
</table>

Another way to enter Greek characters is by using the Symbols catalog window. Choose **Tools > Catalog**. Under Symbol set, select **Greek** and double-click on a Greek letter from the list. The markup name of the character is shown below the list window.
Example 2:  \( \pi \approx 3.14159 \)

For this example we will suppose that:

- We want to enter the above formula (the value of pi rounded to 5 decimal places).
- We know the name of the Greek character (\( \pi \)).
- But we do not know the markup associated with the \( \approx \) symbol.

**Step 1:** Type `%` followed by the text `pi`. This displays the Greek character \( \pi \).

**Step 2:** Open the Elements window (View > Elements).

**Step 3:** The \( \approx \) symbol is a relation, so we click on the Relations button. If you hover the mouse over this button you see the tooltip Relations (Figure 234).

Figure 235 shows the Elements window after clicking the Relations button. The symbol we want is circled.

**Step 4:** Click on the a \( \approx \) b symbol. The equation editor now shows the markup `%pi<=>` simeq `<=>`.
Step 5: Delete the <?> text and add 3.14159 at the end of the equation. We end up with the markup \( \pi \simeq 3.14159 \). The result is shown in Figure 236.

![Figure 236. Final result](image)

## Customizations

### Formula editor as a floating window

The formula editor can cover a large part of the Writer window. To turn the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 237.
2) Hold down the Control key and double-click.

![Figure 237. Hold down the Control key and double-click on the border of the formula editor to turn it into a floating window.](image)

Figure 238 shows the result. You can dock the floating window again by using the same steps. Hold down the Control key and double-click the window frame.

![Figure 238. Formula editor as a floating window](image)
How can I make a formula bigger?

This is one of the most common questions people ask about Math. The answer is simple, but not intuitive:

1) Start the formula editor and choose **Format > Font size**.

![Figure 239. Changing the font size for a formula](image)

2) Select a larger font size under **Base size** (top-most entry).

![Figure 240. Edit Base size (top) to make a formula bigger](image)

The result of this change is illustrated in Figure 241.

![Figure 241. Result of changing the base font size](image)
Formula layout

The most difficult part of using Math comes when writing complicated formulas. This section provides some advice.

Brackets are your friends

Math knows nothing about order of operation. You must use brackets to state the order of operations explicitly. Consider the following example.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{2}{x+1} )</td>
<td>( \frac{2}{x+1} )</td>
</tr>
<tr>
<td>( \frac{2}{x+1} )</td>
<td>( \frac{2}{x+1} )</td>
</tr>
</tbody>
</table>

Equations over more than one line

Suppose you want to type an equation covering more than one line. For example:

\( \begin{align*} x &= 3 \\ y &= 1 \end{align*} \)

Your first reaction would be to simply press the Enter key. However, if you press the Enter key, though the markup goes to a new line, the resulting equation does not. You must type the newline command explicitly. This is illustrated in the table below.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>( x = 3 ) newline ( y = 1 )</td>
<td>( x = 3 ) newline ( y = 1 )</td>
</tr>
</tbody>
</table>

How do I add limits to my sum/integral?

The sum and int commands can (optionally) take the parameters from and to. These are used for lower and upper limits respectively. These parameters can be used singly or together. Limits for integrals are usually treated as subscripts and superscripts.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sum_{k=1}^{n} a_k )</td>
<td>( \sum_{k=1}^{n} a_k )</td>
</tr>
<tr>
<td>( \int_{0}^{x} f(t) , dt ) or ( \int_{0}^{x} f(t) , dt )</td>
<td>( \int_{0}^{x} f(t) , dt ) or ( \int_{0}^{x} f(t) , dt )</td>
</tr>
</tbody>
</table>
\[ \int_{\mathbb{R}} f \]

\[ \sum_{n=0}^{\infty} 2^{-n} \]

**Note**  
For more details on integrals and sums, see the *Math Guide*.

**Brackets with matrices look ugly!**  
For background, we start with an overview of the matrix command.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
</table>
| matrix \{ a \# b \## c \# d \} | \[
\begin{pmatrix}
a & b \\
c & d
\end{pmatrix}
\] |

**Note**  
Rows are separated by two \#’s and entries within each row are separated by one \#.

The first problem people have with matrices is that brackets do not scale with the matrix.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
</table>
| ( matrix \{ a \# b \## c \# d \} ) | \[
\begin{pmatrix}
a & b \\
\end{pmatrix}
\] |

Math provides scalable brackets. That is, the brackets grow in size to match the size of their contents. Use the commands *left* ( and *right* ) to make scalable brackets.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
</table>
| left( matrix \{ a \# b \## c \# d \} right) | \[
\begin{pmatrix}
a & b \\
c & d
\end{pmatrix}
\] |

**Tip**  
Use *left* [ and *right* ] to obtain square brackets.

**How do I make a derivative?**  
Making derivatives essentially comes down to one trick: *Tell Math it’s a fraction*.  
In other words, you have to use the *over* command. Combine this with either the letter \( d \) (for a total derivative) or the *partial* command (for a partial derivative) to achieve the effect of a derivative.

**Note**  
Notice that we have to use braces (squiggly brackets) to make the derivative.
### How do I align my equations at the equals sign?

Math does not have a command for aligning equations on a particular character, but you can use a matrix to do this, as shown below.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>{df} over {dx}</td>
<td>(\frac{df}{dx})</td>
</tr>
<tr>
<td>{\text{partial } f} over {\text{partial } y}</td>
<td>(\frac{\partial f}{\partial y})</td>
</tr>
<tr>
<td>{\text{partial}^2 f} over {\text{partial } t^2}</td>
<td>(\frac{\partial^2 f}{\partial t^2})</td>
</tr>
</tbody>
</table>

The empty braces around = are necessary because = is a binary operator and thus needs an expression on each side.

You can reduce the spacing around = if you change the inter-column spacing of the matrix:

1) With the equation editor open, choose **Format > Spacing** from the menu bar.
2) In the Spacing dialog (Figure 242), click the **Category** button and select **Matrices** in the drop-down menu.
3) Enter 0% for Column spacing and click **OK**.

![Figure 242: Changing spacing in a matrix formula](image)

### Numbering equations

Equation numbering is one of Math’s best hidden features. The steps are simple, but obscure:

1) Start a new line.
2) Type \( fn \) and then press F3.
The \( fn \) is replaced by a numbered formula:

\[ E = mc^2 \]  

(1)

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta function:

\[ \zeta (z) = \sum_{n=1}^{\infty} \frac{1}{n^z} \]  

(2)

You can reference an equation (“as shown in Equation (1)”) with these steps:

1) Choose **Insert > Cross-reference** from the menu bar.
2) On the **Cross-references** tab (Figure 243), under **Type**, select **Text**.
3) Under **Selection**, select the equation number.
4) Under **Format**, select **Reference**.
5) Click **Insert**.

Done! If you later add more equations to the paper before the referenced equation, all the equations will automatically renumber and the cross-references will update.

**Tip** To insert the equation number without parenthesis around it, choose **Numbering** instead of **Reference** under **Format**.

*Figure 243. Inserting a cross-reference to an equation number*
Introduction

This chapter provides general information about printing, exporting, and e-mailing documents from Apache OpenOffice.

Quick printing

Click the Print File Directly icon to send the entire document to the default printer defined for your computer.

Note

You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P). (See Figure 244.)

The Print dialog has four tabs, from which you can choose a range of options, as described in the following sections.

Note

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for Apache OpenOffice, go to Tools > Options > OpenOffice.org > Print and Tools > Options > OpenOffice.org Writer > Print. See Chapter 11 (Setting Up and Customizing Apache OpenOffice) for more details.

The different components of Apache OpenOffice have different available print settings, as summarized in Table 2.
Table 2: Print options in Apache OpenOffice components

<table>
<thead>
<tr>
<th>Feature</th>
<th>Writer</th>
<th>Calc</th>
<th>Impress</th>
<th>Draw</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select pages/sheets/slides to print</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Print multiple pages/sheets/slides on one page</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Print a brochure</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Print envelopes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Print labels or business cards</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Preview pages/sheets before printing</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

Selecting general printing options

On the General tab of the Print dialog, you can choose:

- The **printer** (from the printers available)
- Which **pages** to print, the number of copies to print, and whether to collate multiple copies (**Range and copies** section)
- Whether to print a multiple-page document in reverse page order, to accommodate the output feed of the printer
- Whether to print any **comments** that are in the document, and where to print the comments.
Select the Properties button to display a dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog (Figure 246), the last item, Use only paper tray from printer preference, is not available in Calc.

Printing multiple pages on a single sheet of paper

You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog, select the Page Layout tab (Figure 247).

2) In the Layout section, select from the drop-down list the number of pages to print per sheet. The preview panel on the left of the Print dialog shows how the printed document will look. When printing more than 2 pages per sheet, you can choose the order in which they are printing across and down the paper. The two pictures below show the difference.
3) In the Page sides section, select whether to print all pages or only some pages.
4) Click the **Print** button.

**Tip**

In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from Print Preview instead. See page 241.

---

**Selecting pages/sheets/slides to print**

In addition to printing a full document, you can choose to print individual pages/ sheets/slides, ranges of pages/sheets/slides, or a selection of a document. The details vary slightly in Writer, Calc, Draw and Impress, as described in this section.

**Writer**

**Printing an individual page:**

1) Choose **File > Print** from the menu bar.
2) On the Print dialog, select the page to print.
   a) In the **Ranges and copies** section of the General page, select the **Pages** option.
   b) Enter the **sequence number** of the page you want to print. The preview box changes to show the selected page.
       If you have restarted page numbering within the document, the sequence number is not the same as the page number.
3) Click the **Print** button.

**Printing a range of pages:**

1) Choose **File > Print** from the menu bar.
2) On the Print dialog, select the range of pages to print.
   a) In the **Ranges and copies** section of the General page, select the **Pages** option.
   b) Enter the sequence numbers of the pages to print (for example, 1–4 or 1,3,7,11).
3) Click the **Print** button.

**Printing a selection of text:**

1) In the document, select the material (text and graphics) to print.
2) Choose **File > Print** from the menu bar.
3) The *Ranges and copies* section of the Print dialog now includes a *Selection* option and the preview box shows the selected material. See Figure 248.

4) Click the **Print** button.

![Figure 248: Printing a selection of text](image)

**Calc**

You can choose single sheets, multiple sheets, and selections of cells for printing.

![Figure 249: Choosing what to print in Calc](image)
Printing an individual sheet:
1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.
2) Choose File > Print from the menu bar.
3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.
4) Click the Print button.

Printing a range of sheets:
1) In the spreadsheet, select the sheets to print.
   a) Select the first sheet.
   b) Hold down the Control key.
   c) Click on the additional sheet tabs.
   d) Release the Control key when all required sheets are selected.
2) Choose File > Print from the menu bar.
3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.
4) Click the Print button.

Printing a selection of cells:
1) In the document, select the section of cells to print.
2) Choose File > Print from the menu.
3) In the Ranges and copies section of the Print dialog, select the Selected cells option.
4) Click the Print button.

Caution
After printing, be sure to deselect the extra sheets. If you keep them selected, the next time you enter data on one sheet, you enter data on all the selected sheets. This might not be what you want.

Impress and Draw
You can choose individual slides, ranges of slides, or selections of slides for printing.

Printing an individual slide:
1) Choose File > Print from the menu bar.
2) Select the slide to print.
   a) In the Ranges and copies section of the Print dialog, select the Slides option.
   b) Enter the number of the slide to print.
3) Click the Print button.
Printing a range of pages:
1) Choose **File > Print** from the menu bar.
2) Select the slides to print.
   a) In the *Ranges and copies* section of the Print dialog, select the *Slides* option.
   b) Enter the number of the slides to print (for example 1-4 or 1,3,7,11).
3) Click the **Print** button.

Printing a selection of a slide, or a selection from multiple slides:
1) In the document, select the section of the slide to print.
2) Choose **File > Print** from the menu bar.
3) Select the *Selection* option in the *Ranges and copies* section of the Print dialog.
4) Click the **Print** button.

**Printing handouts, notes, or outlines in Impress**

*Handouts* prints the slides in reduced size on the page, from one to nine slides per page. The slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the page.

*Notes* prints a single slide per page with any notes entered for that slide in Notes View.

*Outline* prints the title and headings of each slide in outline format.

To print handouts, notes, or outlines:
1) Choose **File > Print** from the menu bar.
2) In the *Print* section of the Print dialog, select the required option.
3) For Handouts, you can then choose how many slides to print per page, and the order in which they are printed.
4) Click the **Print** button.

![Print dialog](image)

**Printing a brochure**

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

**Tip**
Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:
1) Choose **File > Print**.
2) In the Print dialog, click **Properties**.

---

Chapter 9 Printing, Exporting, and E-mailing
3) Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog.

5) Select the Brochure option.

6) In the Page sides section, select Back sides / left pages option from the Include drop-down list.

7) Click the Print button.

8) Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.

9) On the Print dialog, in the Page sides section, select Front sides / right pages option from the Include drop-down box.

10) Click the Print button.

**Tip** If your printer can print double-sided automatically, choose All pages.

---

**Printing envelopes, labels, business cards**

Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing. For details of how to set these up, see Chapter 11 (Using Mail Merge) in the Writer Guide. To print:

1) Choose File > Print from the menu bar.

2) On the Print dialog, under Ranges and copies, choose Pages and type 1 in the box. Click the Print button.

---

**Printing in black and white (on a color printer)**

You may wish to print documents in black and white on a color printer. Several choices are available. Please note that some color printers may print in color regardless of the settings you choose.

Change the printer settings to print in black and white or grayscale:

1) Choose File > Print to open the Print dialog.
2) Click **Properties** to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the Color settings. See your printer’s help or user manual for more information.

3) The choices for color might include *black and white* or *grayscale*. Choose the required setting.

4) Click **OK** to confirm your choice and return to the Print dialog.

5) Click the **Print** button to print the document.

---

**Tip**

Grayscale is best if you have any graphics in the document.

---

Change the Apache OpenOffice settings to print all color text and graphics as grayscale:

1) Choose **Tools > Options > OpenOffice.org > Print**.
2) Select the **Convert colors to grayscale** option. Click **OK** to save the change.
3) Open the Print dialog (*File > Print*).
4) Click the **Print** button to print the document.

Change the Writer (or Calc, Impress, Draw) settings to print all color text as black, and all graphics as grayscale:

1) Choose **Tools > Options > OpenOffice.org Writer > Print**.
2) Under **Contents**, select the **Print text in black** option. Click **OK** to save the change.
3) Open the Print dialog (*File > Print*).
4) Click the **Print** button to print the document.

---

**Previewing pages/sheets before printing**

You can use the previewing options in Writer and Calc to view the document as it will be printed. Different viewing options are available.

**Writer**

The normal page view in Writer shows you what each page will look like when printed and you can edit the pages in that view. If you are designing a document to be printed double-sided, you may want to see what facing pages look like. Writer provides two ways to do this:

- **View Layout (editable view):** use the Facing Pages (Book Preview) button on the status bar.

![Figure 250. Page Preview toolbar (Writer)](image)

- **Page Preview (read-only view).**

To use Page Preview:

1) Choose **File > Page Preview** (or click the **Page Preview** button on the Standard toolbar).

   Writer now displays the **Page Preview** toolbar instead of the Formatting toolbar.

   ![Figure 250. Page Preview toolbar (Writer)](image)

2) Select the required preview icon: **Two Pages**, **Multiple Pages** or **Book Preview**.
3) To print the document from this view, click the Print document icon to open the Print dialog.
4) Choose the print options and click the Print button.

Calc
To preview the sheets in Calc before printing:
1) Choose File > Page Preview.
   The Calc window now displays the Page Preview toolbar instead of the Formatting toolbar.

   ![Figure 251. Page Preview toolbar (Calc)]

   2) To print the document from this view, click the Print document icon to open the Print dialog.
   3) Choose the print options and click the Print button.

Exporting to PDF
OpenOffice.org can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.

Quick export to PDF
Click the Export Directly as PDF icon to export the entire document using your default PDF settings. You are asked to enter the file name and location for the PDF file, but you do not get a chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links, and Security). Select the appropriate settings, and then click Export. Then you are asked to enter the location and file name of the PDF to be created, and click Save to export the file.

General page of PDF Options dialog
On the General page, you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.

Range section
- All: Exports the entire document to PDF.
- Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of page ranges and single pages, by using a format like 3-6;8;10;12.
- Selection: Exports all the selected material.
Images section

- **Lossless compression:** Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.

- **JPEG compression:** Allows for varying degrees of quality. A setting of 90% works well with photographs (small file size, little perceptible loss of quality).

- **Reduce image resolution:** Lower-DPI (dots per inch) images have lower quality. For viewing on a computer screen generally a resolution of 72dpi (for Windows) or 96dpi (GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or 600 dpi, depending on the capability of the printer. Higher dpi settings greatly increase the size of the exported file.

**Note**

EPS (Encapsulated PostScript) images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.
General section

- **PDF/A-1a**: PDF/A is an ISO standard for long-term preservation of documents, by embedding all the information necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, and encryption). PDF tags are written. If you select PDF/A-1a, the forbidden elements are greyed-out (not available).

- **Tagged PDF**: Tagged PDF contains information about the structure of the document's contents. This can help to display the document on devices with different screens, and when using screen reader software. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.

- **Create PDF form - Submit format**: Choose the format of submitting forms from within the PDF file. This setting overrides the control's URL property that you set in the document. There is only one common setting valid for the whole PDF document: PDF (sends the whole document), FDF (sends the control contents), HTML, and XML. Most often you will choose the PDF format.

- **Export bookmarks**: Exports headings in Writer documents, and page names in Impress and Draw documents, as “bookmarks” (a table of contents list displayed by most PDF viewers).

- **Export comments**: Exports comments as PDF notes. You may not want this!

- **Export automatically inserted blank pages**: If selected, automatically inserted blank pages are exported to the PDF. This is best if you are printing the PDF double-sided. For example, books usually have chapters set to always start on an odd-numbered (right-hand) page. When the previous chapter ends on an odd page, Apache OpenOffice inserts a blank page between the two odd pages. This option controls whether to export that blank page.

- **Embed standard fonts**: In previous versions of OpenOffice.org, the standard fonts (Times, Helvetica, Courier, Symbol, and ZapfDingbats) were only embedded into the PDF when the resulting file was of the PDF/A type, since the PDF/A standards requires this. From OpenOffice.org version 3.3, you can choose to embed these fonts in all PDF documents created by Apache OpenOffice to enhance display accuracy in PDF viewers.

Initial View page of PDF Options dialog

On the *Initial View* page (Figure 253), you can choose how the PDF opens by default in a PDF viewer. The selections should be self-explanatory.

User Interface page of PDF Options dialog

On the *User Interface* page (Figure 254), you can choose more settings to control how a PDF viewer displays the file. Some of these choices are particularly useful when you are creating a PDF to be used as a presentation or a kiosk-type display.

Window options section

- **Resize window to initial page**. Causes the PDF viewer window to resize to fit the first page of the PDF.

- **Center window on screen**. Causes the PDF viewer window to be centered on the computer screen.

- **Open in full screen mode**. Causes the PDF viewer to open full-screen instead of in a smaller window.

- **Display document title**. Causes the PDF viewer to display the document's title in the title bar.
Figure 253: Initial View page of PDF Options dialog

Figure 254: User Interface page of PDF Options dialog
User interface options section

- **Hide menubar.** Causes the PDF viewer to hide the menu bar.
- **Hide toolbar.** Causes the PDF viewer to hide the toolbar.
- **Hide window controls.** Causes the PDF viewer to hide other window controls.

Transitions

In Impress, displays slide transition effects as their respective PDF effects.

Bookmarks

Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected on the General page.

**Links page of PDF Options dialog**

On the Links page, you can choose how links are exported to PDF.

![Figure 255: Links page of PDF Options dialog](image)

**Export bookmarks as named destinations**

If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.

**Convert document references to PDF targets**

If you have defined links to other documents with OpenDocument extensions (such as .ODT, .ODS, and .ODP), this option converts the files names to .PDF in the exported PDF document.

**Export URLs relative to file system**

If you have defined relative links in a document, this option exports those links to the PDF.

**Cross-document links**

Defines the behavior of links clicked in PDF files.

**Security page of PDF Options dialog**

PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and apply some digital rights management (DRM) features.

- With an open password set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
• With a permissions password set, the PDF can be opened by anyone, but its permissions can be restricted. See Figure 256. After you set a password for permissions, the other choices on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened with the correct password, and its permissions can be restricted.

**Note** Permissions settings are effective only if the user’s PDF viewer respects the settings.

Figure 257 shows the pop-up dialog displayed when you click the **Set open password** button on the Security page of the PDF Options dialog.

![Figure 256: Security page of PDF Options dialog](image-url)
Exporting to other formats

Apache OpenOffice uses the term “export” for some file operations involving a change of file type. If you cannot find what you want under File > Save As, look under File > Export as well.

Apache OpenOffice can export files to XHTML. In addition, Draw and Impress can export to Adobe Flash (.swf) and a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file name for the exported document, then select the required format in the File format list and click the Export button.

E-mailing documents

Apache OpenOffice provides several ways to quickly and easily send documents as an e-mail attachment in one of three formats: OpenDocument (Apache OpenOffice’s default format), Microsoft Office formats, or PDF.

Note

Documents can only be sent from the Apache OpenOffice menu if you have an e-mail program such as Thunderbird installed on your computer.
To send the current document in OpenDocument format:

1) Choose **File > Send > Document as E-mail**. OpenOffice.org opens your default e-mail program. The document is attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.

**File > Send > E-mail as OpenDocument Text** (or Spreadsheet or Presentation) has the same effect.

If you choose **E-mail as Microsoft [Word, Excel, or Powerpoint]**, Apache OpenOffice first creates a file in one of those formats and then opens your e-mail program with the file attached.

Similarly, if you choose **E-mail as PDF**, Apache OpenOffice first creates a PDF using your default PDF settings (as when using the **Export Directly as PDF** toolbar button) and then opens your email program with the .PDF file attached.

**E-mailing a document to several recipients**

To e-mail a document to several recipients, you can use the features in your e-mail program or you can use Apache OpenOffice’s mail merge facilities to extract email addresses from an address book.

You can use Apache OpenOffice’s mail merge to send e-mail in two ways:

- Use the Mail Merge Wizard to create the document and send it. See Chapter 11 (Using Mail Merge) of the **Writer Guide** for details.
- Create the document in Writer without using the Wizard, then use the Wizard to send it. This method is described here.

To use the Mail Merge Wizard to send a previously-created Writer document:

1) Click **Tools > Mail Merge Wizard**. On the first page of the wizard, select **Use the current document** and click **Next**.

2) On the second page, select **E-mail message** and click **Next**.
3) On the third page, click the **Select Address List** button. Select the required address list (even if only one is shown) and then click **OK**. (If the address list you need is not shown here, you can click **Add** to find it and add it to the list.)

4) Back on the Select address list page, click **Next**. On the Create salutation page, deselect **This document should contain a salutation.**
5) In the left-hand list, click **8. Save, print or send**. Apache OpenOffice displays a “Creating documents” message and then displays the **Save, print or send** page of the Wizard.

6) Select **Send merged document as E-Mail**. The lower part of the page changes to show e-mail settings choices. (See Figure 262.)

7) Type a subject for your email and click **Send documents**. Apache OpenOffice sends the e-mails.
Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the document's content plus your personal key. The checksum and your public key are stored together with the document.

When someone later opens the document on any computer with a recent version of OpenOffice.org, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document. In addition, the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority. Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For a more detailed description of how to get and manage a certificate, and signature validation, see “About Digital Signatures” in the Apache OpenOffice Help.

To sign a document:

1) Choose File > Digital Signatures.
2) If you have not saved the document since the last change, a message box appears. Click Yes to save the file.
3) After saving, you see the Digital Signatures dialog. Click Add to add a public key to the document.
4) In the Select Certificate dialog, select your certificate and click OK.
5) You see again the Digital Signatures dialog, where you can add more certificates if you want. Click OK to add the public key to the saved file.

A signed document shows an icon in the status bar. You can double-click the icon to view the certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > OpenOffice.org > Security > Options, you can set Apache OpenOffice to remind (warn) you when files contain certain information and remove personal information automatically on saving.

To remove personal and some other data from a file, go to File > Properties. On the General tab, uncheck Apply user data and then click the Reset button. This removes any names in the created and modified fields, deletes the modification and printing dates, and resets the editing time to zero, the creation date to the current date and time, and the version number to 1.

To remove version information, either go to File > Versions, select the versions from the list and click Delete, or use Save As and save the file with a different name.
Introduction

You can add graphic and image files, including photos, drawings, scanned images, and others, to Apache OpenOffice (AOO) documents. AOO can import various vector (line drawing) and raster (bitmap) file formats. The most commonly used graphic formats are GIF, JPG, PNG, and BMP.

Graphics in Apache OpenOffice are of three basic types:

- Image files, such as photos, drawings, and scanned images
- Diagrams created using AOO's drawing tools
- Charts created using AOO's Chart facility

This chapter covers images and diagrams.

More detailed descriptions on working with drawing tools can be found in the Draw Guide and Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file, directly from a graphics program or a scanner, or from the Apache OpenOffice Gallery.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into an AOO document using either of the following methods.

Drag and drop

1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the AOO document and drop it where you want it to appear. A faint vertical line marks where the image will be dropped.

This method embeds (saves a copy of) the image file in the Writer document. To link the file instead of embedding it, hold down the Control+Shift keys while dragging the image.

Insert Picture dialog

1) Click in the AOO document where you want the image to appear.
2) Choose Insert > Picture > From File from the menu bar.
3) On the Insert Picture dialog (Figure 263), notice the two options at the bottom left: Preview and Link. Choose Preview to view a thumbnail of the selected image on the right, so you can verify that you have the correct file. See page 254 for the use of Link.
4) Navigate to the file to be inserted, select it, and click Open.
If you choose the **Link** option, a message box appears when you click **Open**. The message states that the picture will not be stored with the document, but only referenced as a link, and asks if you want to embed the graphic instead. Choose **Keep Link** if you want the link, or **Embed Graphic** if you do not. To prevent this message from appearing again, deselect the box by **Ask when linking a graphic** at the bottom of the message.

**Figure 263. Insert picture dialog**

**Linking an image file**

If the **Link** option in the Insert picture dialog is selected, Apache OpenOffice creates a link to the file containing the image instead of saving a copy of the image in the document. The result is that the image is displayed in the document, but when the document is saved, it contains only a reference to the image file—not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

- **Advantage** – Linking can reduce the size of the document when it is saved, because the image file itself is not included. File size is usually not a problem on a modern computer with a reasonable amount of memory, unless the document includes many large graphics files; Apache OpenOffice can handle quite large files.

- **Advantage** – You can modify the image file separately without changing the document because the link to the file remains valid, and the modified image will appear when you next open the document. This can be a big advantage if you (or someone else, perhaps a graphic artist) is updating images.

- **Disadvantage** – If you send the document to someone else, or move it to a different computer, you must also send the image files, or the receiver will not be able to see the linked images. You need to keep track of the location of the images and make sure the recipient knows where to put them on another machine, so that the document can find them. For example, you might keep images in a subfolder named Images (under the folder containing the document); the recipient of the file needs to put the images in a subfolder with the same name and in the same place relative to the document.
Note When inserting the same image several times in the document it would appear beneficial to link rather than embed; however, this is not so because Apache OpenOffice embeds only one copy of the image file in the document.

**Embedding linked images**

If you originally linked the images, you can easily embed one or more of them later if you wish. To do so:

1) Open the document in Apache OpenOffice and choose Edit > Links.
2) The Edit Links dialog (Figure 264) shows all the linked files. In the Source file list, select the files you want to change from linked to embedded.
3) Click the Break Link button.
4) Save the document.

**Note** Going the other way, from embedded to linked, is not so easy—you must delete and reinsert the images, one at a time, selecting the Link option when you do so.

![Figure 264: The Edit Links dialog](image)

**Inserting an image from the clipboard**

Using the clipboard, you can copy images into an AOO document from another AOO document and from other programs. To do this:

1) Open both the source document and the target document.
2) In the source document, select the image to be copied.
3) Move the mouse pointer over the selected image and press Control+C to copy the image to the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the graphic is to be inserted.
6) Press Control+V to insert the image.

**Caution** If the application from which the graphic was copied is closed before the graphic is pasted into the target, the image stored on the clipboard could be lost.
Inserting an image using a scanner

If a scanner is connected to your computer, AOO can call the scanning application and inserted the scanned item into the AOO document as an image. To start this procedure, place the cursor where you want the graphic to be inserted and choose **Insert > Picture > Scan > Select Source**.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by scanned material into a graphics program and cleaning it up there before inserting the resulting image into AOO.

Inserting an image from the Gallery

The Gallery provides a convenient way to group reusable objects such as graphics and sounds that you can insert into your documents. The Gallery is available in all components of AOO. See "Managing the Gallery" on page 257. You can copy or link an object from the Gallery into a document.

To insert an object:

1) Choose **Tools > Gallery** or click the Gallery icon on the Standard toolbar (in Writer and Calc) or the Drawing toolbar (in Impress and Draw).
2) Select a theme.
3) Select an object with a single click.
4) Drag and drop the image into the document. (See Figure 265.)

You can also right-click on the object and choose **Insert > Copy**.

---

**Figure 265.** Copying a graphic object from the Gallery into a document (oval marks the Hide/Show button for the Gallery)

To insert an object as a link:

1) Choose **Tools > Gallery** and select a theme.
2) Select an object with a single click, then while pressing the **Shift** and **Control** keys, drag and drop the object into the document.
Inserting an image as a background

To insert an image as the background to a page or paragraph:

1) Choose Tools > Gallery and select a theme.
2) Select an object with a single click, right-click on the object, and choose Insert > Background > Page or > Paragraph.

Modifying and positioning graphics

Apache OpenOffice provides many tools for resizing, modifying, filtering, and positioning graphics; wrapping text around graphics; and using graphics as backgrounds and watermarks. These tools are described in relevant chapters of the other guides. Some sophisticated adjustments of the graphics are best done in an image manipulation program and the results brought into AOO, rather than using AOO’s inbuilt tools.

Managing the Gallery

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and Backgrounds. You can create other groups or themes and add your own pictures or find extensions containing more graphics.

The box on the left of the gallery window lists the available themes. Click on a theme to see its contents displayed in the Gallery window.

You can display the Gallery in Icon View (Figure 266) or Detailed View, and you can hide or show the Gallery by clicking on the Hide button (similar to the Hide button for the Navigator and the Styles and Formatting window when they are docked).

![Figure 266. Icon view of one theme in the Gallery](image)

By default, the Gallery is docked above the workspace. To expand the Gallery, position the pointer over the line that divides it from the top of the workspace. When the pointer changes to parallel lines with arrows, click and drag downward. The workspace resizes in response.

As with other docked windows, you can “float” the Gallery by moving the mouse pointer over an edge of the Gallery window, holding down the Control key, and double-clicking. Repeat this procedure to dock the Gallery again.
The default themes are locked; no items can be added to or deleted from these themes. The locked themes are easily recognizable by right-clicking on them; the only available option in the pop-up menu is Properties.

In a default installation, only the My themes theme is customizable, although new themes can be added as explained in “Adding a new theme to the Gallery” on page 259.

**Adding objects to the Gallery**

You may wish to add to the Gallery any images that you use frequently, for example, a company logo. You can then very easily insert these graphics into a document later.

You can add images only to “My Theme” or to any other theme that you have created; these are indicated by a green icon in the list of themes. You cannot add images to the built-in themes, indicated by an icon of another color.

**Method 1** (selecting a file):

1) Right-click on the desired theme and select Properties from the context menu.
2) In the theme's Properties dialog, go to the Files page and click the Find Files button.

![Figure 267. Gallery Properties dialog](image)

3) The Select path dialog (not shown) opens. You can enter the path for the file's directory in the Path text box, or you can navigate to locate the file's directory.
4) Click the Select button to start the search. A list of graphic files is then displayed in the Properties dialog. You can use the File type drop-down list to limit the files displayed.
5) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and then click Add. (Hold down either the Shift key or the Control key while you click on the files.)
Method 2 (drag and drop)
You can drag and drop an image into the Gallery from a document.

1) Open the document containing an image you want to add to the Gallery, and display the Gallery theme to which you want to add it.
2) Position the mouse pointer above the image, without clicking.
3) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this case, press the Alt key while you click the image, to select it without activating the link. If the mouse pointer does not change to a hand symbol, you can simply click the image to select it.
4) Once the image is selected, evident from the green selection handles around it, release the mouse button. Click again on the image, keeping the mouse button pressed for more than two seconds. Without releasing the mouse button, drag the image into the document.
5) Release the mouse button.

Deleting images from the Gallery
To delete an image from a theme that you created:

1) Right-click on the name of the image file or its thumbnail in the Gallery.
2) Click Delete on the pop-up menu. A message appears, asking if you want to delete this object. Click Yes.

Note Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location.

Adding a new theme to the Gallery
To add a new theme to the Gallery:

1) Click the New Theme button above the list of themes (Figure 266).
2) In the Properties of New Theme dialog, click the General tab and type a name for the new theme.
3) Click the Files tab and add images to the theme, as described earlier.

Deleting a theme from the Gallery
You can delete only theme that you have added to the Gallery; you cannot delete any of the inbuilt themes. To delete a theme from the Gallery:

1) Go to Tools > Gallery.
2) In the left part of the Gallery, select in the list the theme you wish to delete.
3) Right-click on the theme, then click Delete on the pop-up menu.

Location of the Gallery and the objects in it
Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard disk, on a network drive, or on a CD-ROM. Listings in the Gallery refer to the location of each object. When you add graphics to the Gallery, the files are not moved or copied; only the location of each new object is added as a reference.

In a work group, you may have access to a shared Gallery (where you cannot change the contents unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > OpenOffice.org > Paths. You can change this location, and you can copy your gallery files (*.sdv) to other computers.
Creating an image map

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text hyperlinks. Clicking on a hotspot causes Apache OpenOffice to open the linked page in the appropriate program (for example, the default browser for an HTML page; AOO Calc for a *.ods file; a PDF viewer for a *.pdf file). You can create hotspots of various shapes and include several hotspots in the same image.

To use the image map editor:

1) In your AOO document, select the picture where you want to define the hotspots.
2) Choose Edit > ImageMap from the menu bar. The ImageMap Editor (Figure 268) opens.
3) Use the tools and fields in the dialog (described on the next page) to define the hotspots and links necessary.
4) Click the Apply icon to apply the settings.
5) When done, click the Save icon to save the image map to a file, then click the X in the upper right corner to close the dialog.

![ImageMap Editor](image-map-editor.png)

Figure 268: The dialog to create or edit an image map

The main part of the dialog shows the image on which the hotspots are defined. A hotspot is identified by a line indicating its shape.
The toolbar at the top of the dialog contains the following tools:

- **Apply** button: click this button to apply the changes.
- **Load, Save, and Select** icons.
- Tools for drawing a hotspot shape: these tools work in exactly the same way as the corresponding tools in the Drawing toolbar.
- **Edit, Move, Insert, Delete Points**: advanced editing tools to manipulate the shape of a polygon hotspot. Choose the Edit Points tool to activate the other tools.
- **Active** icon: toggles the status of a selected hotspot between active and inactive.
- **Macro**: associates a macro with the hotspot instead of just associating an hyperlink.
- **Properties**: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:

- **Address**: the address pointed to by the hyperlink. You can also point to an anchor in a document; to do this, write the address in this format: `file:///<path>/document_name#anchor_name`
- **Text**: type the text that you want to be displayed when the mouse pointer is moved over the hotspot.
- **Frame**: where the target of the hyperlink will open: pick among _blank (opens in a new browser window), _self (opens in the active browser window), _top or _parent.

**Tip**

The value _self for the target frame usually will work just fine. It is therefore not recommended to use the other choices unless absolutely necessary.

---

**Using Apache OpenOffice’s drawing tools**

You can use Apache OpenOffice’s drawing tools to create graphics such as simple diagrams using rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing objects to make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in your document, or you can insert them into a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because:

- You cannot include images in a group with drawing objects, so they may get out of alignment in your document.
- If you convert a document to another format, such as HTML, the drawing objects and the graphics will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended to use Apache OpenOffice Draw, which includes many more features such as layers, styles, and so on.

**Creating drawing objects**

To begin using the drawing tools, display the Drawing toolbar (Figure 269) by clicking **View > Toolbars > Drawing**.

If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to a convenient place on the window.
To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change the anchor later, if necessary.
2) Choose the tool from the Drawing toolbar (Figure 269). The mouse pointer changes to a drawing-functions pointer.
3) Move the cross-hair pointer to the place in the document where you want the graphic to appear and then click and drag to create the drawing object. Release the mouse button. The selected drawing function remains active, so you can draw another object of the same type.
4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the arrow) on the Drawing toolbar.
5) You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using either the Drawing Object Properties toolbar (Figure 270) or the choices and dialogs reached by right-clicking on the drawing object.

Set or change properties for drawing objects

To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 269), click the Select tool.
2) On the Drawing Object Properties toolbar (Figure 270), click on the icon for each property and select the value you want for that property.
3) For more control, or to define new attributes, you can click on the Area or Line icons on the toolbar to display detailed dialogs.

Figure 269. The Drawing toolbar

Figure 270. Drawing Object Properties toolbar
The default you set applies to the current document and session. It is not retained when you close the document or close Writer, and it does not apply to any other document you open. The defaults apply to all the drawing objects except text objects.

To change the properties for an existing drawing object:

1) Select the object.
2) Continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of the drawing object:

1) Right-click on the drawing object and then choose Position and Size from the pop-up menu. The Position and Size dialog is displayed.
2) Choose any properties, as required.

**Resizing a drawing object**

An object is resized in a similar way to an image. Select the object, click on one of the eight handles around it and drag it to its new position. For a scaled resizing, select one of the corner handles and keep the *Shift* key pressed while dragging the handle to its new position.

For more sophisticated control of the size of the object, choose Format > Object > Position and Size from the menu bar. Use the Position and Size dialog to set the width and height independently. If the Keep ratio option is selected, then the two dimensions change so that the proportion is maintained, allowing for a scaled resizing.

**Grouping drawing objects**

To group drawing objects:

1) Select one object, then hold down the *Shift* key and select the others you want to include in the group. The bounding box expands to include all the selected objects.
2) With the objects selected, hover the mouse pointer over one of the objects and choose Format > Group > Group from the menu bar or right-click and choose Group > Group from the pop-up menu.

| Note | You cannot include an embedded or linked graphic in a group with drawing objects. |

**Using Fontwork**

With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice. You will surely find one that fits your document.

Fontwork is available with each component of AOO, but you will notice small differences in the way that each component displays it.

**The Fontwork toolbars**

You can use two different toolbars for creating and editing a Fontwork object.

- Go to View > Toolbars > Fontwork.

*Figure 271. The floating Fontwork toolbar*
• If you click on an existing Fontwork object, the Formatting toolbar changes to display the Fontwork options as shown in Figure 267. The contents of this toolbar vary depending on the AOO component with which it is being used.

Creating a Fontwork object

1) On the Drawing or Fontwork toolbar, click the Fontwork Gallery icon. If the Drawing toolbar is not visible, go to View > Toolbars > Drawing to display it.

2) In the Fontwork Gallery, select a Fontwork style, then click OK. The Fontwork object will appear in your document. Notice the colored squares around the edge (indicating that the object is selected) and the yellow dot; these are discussed in “Moving and resizing Fontwork objects” on page 268.

3) Double-click the object to edit the Fontwork text. Type your own text in place of the black Fontwork text that appears over the object.

4) Click anywhere in a free space or press Esc to apply your changes.
Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the selected Fontwork object is a 3D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar

Make sure that the Fontwork toolbar, shown in Figure 271, is visible. If you do not see it, go to View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects.

Fontwork Shape: Edits the shape of the selected object. You can choose from a palette of shapes.

Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles between normal height (some characters taller than others, for example capital letters, d, h, l and others) and all letters the same height.

Fontwork Alignment: Changes the alignment of characters. Choices are left align, center, right align, word justify, and stretch justify. The effects of the text alignment can only be seen if the text spans over two or more lines. In the stretch justify mode, all the lines are filled completely.
Fontwork Character Spacing: Changes the character spacing and kerning in the object. For custom spacing, input a percentage value: 100% is normal spacing; less than 100% is tight spacing; more than 100% is expanded spacing.

Using the Formatting toolbar

Now let us go further and customize the Fontwork object with several more attributes.

Click on the Fontwork object. The Formatting toolbar changes to show the options for editing the object. (The toolbar shown in Figure 276 appears when you use Fontwork in Writer.)

![Formatting toolbar for a Fontwork object in Writer](image)

This figure shows the toolbar floating. In its default, docked position it is one of the toolbars located below the menu bar. The example toolbar has also been customized to show all of the available options; by default only a subset of these options is shown.

On the Formatting toolbar you have a large choice of options for customizing your object. These choices are the same as the ones for other drawing objects. For more information, see the Draw Guide.

**Line options**

**Line** icon: Opens a dialog with three tabs: Line, Line Styles, Arrow Styles. Use the Line tab to edit the most common properties of the line around the selected Fontwork object, by choosing from previously-defined attributes including line style, line color, and arrow styles. Use the Lines Styles and Arrow Styles tabs to edit the properties of line and arrow styles, and define new styles.
Arrow Style icon: Choose from the different arrow styles.
Line Style box: Choose from the available line styles.
Line Width box: Set the width of the line.
Line Color box: Select the color of the line.

Area options
Area icon: Opens a dialog with seven tabs: Area, Shadow, Transparency, Colors, Gradients, Hatching, Bitmaps.
- **Area** tab: Choose from the predefined list a color, bitmap, gradient or hatching pattern to fill the selected object.
- **Shadow** tab: Set the shadow properties of the selected object.
- **Transparency** tab: Set the transparency properties of the selected object.
- **Colors** tab: Modify the available colors or add new ones to appear on the Area tab.
- **Gradients** tab: Modify the available gradients or add new ones to appear on the Area tab.
- **Hatching** tab: Modify the available hatching patterns or add new ones to appear on the Area tab.
- **Bitmaps** tab: Create simple bitmap patterns and import bitmaps, to make them available on the Area tab.

Area Style / Filling boxes: Select the type of the fill of the selected object. For more detailed settings, use the Area icon.

Positioning options
Rotate icon: Rotate the selected object manually using the mouse to drag the object.
To Foreground icon: Move the selected object in front of the text.
To Background icon: Move the selected object behind the text.
Alignment icon: Modify the alignment of the selected objects.
Bring to front icon: Move the selected object in front of the others.
Send to back icon: Move the selected object behind the others.
Change Anchor icon: Choose between anchoring options:
- To Page - The object keeps the same position in relation to the page margins. It does not move as you add or delete text.
- To Paragraph - The object is associated with a paragraph and moves with the paragraph. It may be placed in the margin or another location.
- To Character - The object is associated with a character but is not in the text sequence. It moves with the paragraph but may be placed in the margin or another location. This method is similar to anchoring to a paragraph.
- As Character - The object is placed in the document like any character and moves with the paragraph as you add or delete text before the object.

Ungroup icon: Ungroup the selected objects, so you can manage them individually.
Group icon: Group the selected objects, so you can manage them as a single object.
**Using menu options**

You can use some of the choices on the Format menu to anchor, align, arrange and group selected Fontwork objects, wrap text around them, and flip them horizontally and vertically.

You can also right-click on a Fontwork object and choose many of the same options from the pop-up menu. The pop-up menu also provides quick access to the Line, Area, Text, and Position and Size dialogs. The Text dialog offers only a few options for Fontwork objects and is not discussed here. On the Position and Size dialog, you can enter precise values concerning size and position. For more information on all of these menu options, see the *Draw Guide*.

**Using the 3D-Settings toolbar**

If the selected Fontwork object is a 3D object, you can also use the options on the 3D-Settings toolbar. You can also change a 2D Fontwork object into a 3D object (or change a 3D object into a 2D object) by clicking the Extrusion On/Off icon on the 3D-Settings toolbar. For more information, see the *Draw Guide*.

![3D-Settings toolbar](image)

*Figure 277: 3D-Settings toolbar*

**Moving and resizing Fontwork objects**

When you select a Fontwork object, eight colored squares (known as handles) appear around the edge of the object, as shown below. You can drag these handles to resize the object.

A yellow dot also appears on the object. This dot may be along an edge of the object, or it may be somewhere else; see figure to right for an example. If you hover the pointer over this yellow dot, the pointer turns into a hand symbol. You can drag the dot in different directions to distort the object.

Hovering the pointer over other parts of the object turns the pointer into the usual symbol for dragging the object to another part of the page.

For precise control of the location and size of the object, use the Position and Size dialog.
Chapter 11
Setting Up and Customizing Apache OpenOffice

Choosing Options to Suit the Way You Work

Choosing options for all of Apache OpenOffice

This section covers some of the settings that apply to all the components of Apache OpenOffice. For information on settings not discussed here, see the online help.

Click **Tools > Options**. The list in the left-hand box of the Options – OpenOffice.org dialog varies depending on which component is open. The illustrations in this chapter show the list as it appears when a Writer document is open.

Click the marker (+ or triangle) by OpenOffice.org on the left-hand side. A list of pages drops down. Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

![Options - OpenOffice.org](image)

*Figure 278: OpenOffice.org options*

**Note**
The **Back** button has the same effect on all pages of the Options dialog. It resets the options to the values that were in place when you opened OpenOffice.org.
User Data options

Because the name or initials stored in the OpenOffice.org – User Data page are used for several things, including document properties (created by and last edited by information) and the name of the author of notes and changes, you should ensure that the correct information appears here. Fill in the form (shown in Figure 279), or amend or delete any existing incorrect information.

![Figure 279: Filling in user data](image)

General options

The options on the OpenOffice.org – General page are described below.

![Figure 280: Setting general options for OpenOffice.org](image)
Help - Tips
When Tips is active, one or two words will appear when you hold the mouse pointer over an icon or field, without clicking.

Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu command or a field on a dialog appears when you hold the mouse pointer over that item.

Help Agent
To turn off the Help Agent (similar to Microsoft's Office Assistant), deselect this option. To restore the default behavior, click Reset Help Agent.

Help formatting
High contrast is an operating system setting that changes the system color scheme to improve readability. To display Help in high contrast (if your computer's operating system supports this), choose one of the high-contrast style sheets from the pull-down list.

<table>
<thead>
<tr>
<th>High-contrast style</th>
<th>Visual effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Black text on white background</td>
</tr>
<tr>
<td>High Contrast #1</td>
<td>Yellow text on black background</td>
</tr>
<tr>
<td>High Contrast #2</td>
<td>Green text on black background</td>
</tr>
<tr>
<td>High Contrast Black</td>
<td>White text on black background</td>
</tr>
<tr>
<td>High Contrast White</td>
<td>Black text on white background</td>
</tr>
</tbody>
</table>

Open/Save dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use OpenOffice.org dialogs option. When this option is selected, the Open and Save dialogs supplied with OpenOffice.org will be used. See Chapter 1 (Introducing Apache OpenOffice) for more about the AOO Open and Save dialogs. This book uses the AOO Open and Save dialogs in illustrations.

Print dialogs - Use OpenOffice.org dialogs
(Mac OS X only) To use the standard Print dialogs for your operating system, deselect the Use OpenOffice.org dialogs option. When this option is selected, the Print dialogs supplied with OpenOffice.org will be used. This book uses the AOO Print dialogs in illustrations.

Document status
If this option is selected, then the next time you close the document after printing, the print date is recorded in the document properties as a change and you will be prompted to save the document again, even if you did not make any other changes.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is interpreted as 1/1/2020.
Memory options

In the Options dialog, click **OpenOffice.org > Memory**.

![Memory options dialog](image)

**Figure 281: Choosing Memory options for the OpenOffice.org applications**

These options control how the program uses your computer’s memory and how much memory it requires. Before changing them, you may wish to consider the following points:

- More memory can make **AOO** faster and more convenient (for example, more undo steps require more memory); but the trade-off is less memory available for other applications and you could run out of memory altogether.

- If your documents contain a lot of objects such as images, or the objects are large, **AOO**’s performance may improve if you increase the memory for **AOO** or the memory per object. If you find that objects seem to disappear from a document that contains a lot of them, increase the number of objects in the cache. (The objects are still in the file even if you cannot see them on screen.)

- To load the **Quickstarter** (an icon on the desktop or in the system tray) when you start your computer, select the option near the bottom of the dialog. This makes **AOO** start faster; the trade-off is **AOO** uses some memory even when not being used. This option (sometimes called **Enable systray quickstarter**) is not available on all operating systems.
View options

The options on the OpenOffice.org – View page affect the way the document window looks and behaves. Some of these options are described below. Set them to suit your personal preferences.

![User Interface - Scaling](image)

**User Interface - Scaling**

If the text in the help files or on the menus of the AOO user interface is too small or too large, you can change it by specifying a scaling factor. Sometimes a change here can have unexpected results, depending on the screen fonts available on your system. However, it does not affect the actual font size of the text in your documents.

**User Interface - Icon size and style**

The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The Automatic icon size option uses the setting for your operating system. The second box specifies the icon style (theme); here the Automatic option uses an icon set compatible with your operating system and choice of desktop: for example, KDE or Gnome on Linux.

**User Interface - Use system font for user interface**

If you prefer to use the system font (the default font for your computer and operating system) instead of the font provided by AOO for the user interface, select this option.

**User interface - Screen font anti-aliasing**

(Not available in Windows; not shown in Figure 282.) Select this option to smooth the screen appearance of text. Enter the smallest font size to apply anti-aliasing.

**Menu - icons in menus**

Causes icons as well as words to be visible in menus.

**Font Lists - Show preview of fonts**

Causes the font list to look like Figure 283, Left, with the font names shown as an example of the font; with the option deselected, the font list shows only the font names, not their formatting (Figure 283, Right). The fonts you will see listed are those that are installed on your system.

---

Chapter 11 Setting Up and Customizing Apache OpenOffice 273
Font Lists - Show font history
Causes the last five fonts you have assigned to the current document are displayed at the top of the font list. Otherwise fonts are shown in alphabetical order.

Graphics output – Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen display. Not supported on all operating systems and AOO distributions.

Graphics output – Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look smoother and with fewer artifacts. Not supported on all operating systems and AOO distributions.

Tip
Press Shift+Control+R to restore or refresh the view of the current document.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

- Automatic scrolling – dragging while pressing the middle mouse button shifts the view.
- Paste clipboard – pressing the middle mouse button inserts the contents of the “Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit > Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard” can contain different contents at the same time.

<table>
<thead>
<tr>
<th>Function</th>
<th>Clipboard</th>
<th>Selection clipboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy content</td>
<td>Edit &gt; Copy Control+C</td>
<td>Select text, table, or object.</td>
</tr>
<tr>
<td>Paste content</td>
<td>Edit &gt; Paste Control+V</td>
<td>Clicking the middle mouse button pastes at the cursor position.</td>
</tr>
<tr>
<td>Pasting into another document</td>
<td>No effect on the clipboard contents.</td>
<td>The last marked selection is the content of the selection clipboard.</td>
</tr>
</tbody>
</table>

Selection – Transparency
Determines the appearance of selected text or graphics, which appear on a shaded background. To make the shaded background more or less dark, increase or decrease the Transparency setting.
If you prefer selected material to appear in reversed color (typically white text on a black background), deselect this option.

**Print options**

On the OpenOffice.org – Print page, set the print options to suit your default printer and your most common printing method.

In the *Printer warnings* section near the bottom of the page, you can choose whether to be warned if the paper size or orientation specified in your document does not match the paper size or orientation available for your printer. Having these warnings turned on can be quite helpful, particularly if you work with documents produced by people in other countries where the standard paper size is different from yours.

**Tip**

If your printouts are incorrectly placed on the page or chopped off at the top, bottom, or sides, or the printer is refusing to print, the most likely cause is page size incompatibility.

![Figure 284: Choosing general printing options to apply to all AOO components](image)

**Path options**

On the OpenOffice.org – Paths page, you can change the location of files associated with, or used by, OpenOffice.org to suit your working situation. In a Windows system, for example, you might want to store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 285 and click *Edit*. On the Select Path dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click *OK* to return to the Options dialog. Note that some items can have at least two paths listed: one to a shared folder (which might be on a network) and one to a user-specific folder (normally on the user’s personal computer).
Tip
You can use the entries in the OpenOffice.org – Paths dialog to compile a list of files, such as those containing AutoText, that you need to back up or copy to another computer.

Figure 285: Viewing the paths of files used by OpenOffice.org

Color options
On the OpenOffice.org – Colors page, you can specify colors to use in AOO documents. You can select a color from a color table, edit an existing color, and define new colors. These colors are stored in your color palette and are then available in all components of AOO.

Figure 286: Defining colors to use in color palettes in AOO
To modify a color:

1) Select the color to modify from the list or the color table.
2) Enter the new values that define the color. If necessary, change the settings from RGB (Red, Green, Blue) to CMYK (Cyan, Magenta, Yellow, Black) or vice versa. The changed color appears in the lower of the two color preview boxes at the top.
3) Modify the Name as required.
4) Click the Modify button. The newly defined color is now listed in the Color table.

Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 287. Here you can select a color from the color window on the left; or you can enter values in the boxes on the right, using your choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.

The color window is linked directly with the color input fields on the right; as you choose a color in the window, the numbers change accordingly. The lower color field on the left shows the value of the selected color on the left and the currently set value from the color value fields on the right.

Modify the color components as required and click **OK** to exit the dialog. The newly defined color now appears in the lower of the color preview boxes shown in Figure 286. Type a name for this color in the Name box, then click the **Add** button. A small box showing the new color is added to the Color table.

Another way to define or alter colors is through the Colors page of the Area dialog, where you can also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw object and use the context menu of this object to open the Area dialog. If you load a palette in one component of AOO, it is only active in that component; the other components keep their own palettes.
Font options

You can define replacements for any fonts that might appear in your documents. If you receive from someone else a document containing fonts that you do not have on your system, OpenOffice.org will substitute fonts for those it does not find. You might prefer to specify a different font from the one the program chooses.

On the OpenOffice.org – Fonts page:

1) Select the **Apply Replacement Table** option.
2) Select or type the name of the font to be replaced in the **Font** box. (If you do not have this font on your system, it will not appear in the drop-down list in this box, so you need to type it in.)
3) In the **Replace with** box, select a suitable font from the drop-down list of fonts installed on your computer.
4) The checkmark to the right of the **Replace with** box turns green. Click on this checkmark. A row of information now appears in the larger box below the input boxes. Select the options under **Always** and **Screen**.
5) In the bottom section of the page, you can change the typeface and size of the font used to display source code such as HTML and Basic (in macros).

Security options

Use the OpenOffice.org – Security page (Figure 289) to choose security options for saving documents and for opening documents that contain macros.

Security options and warnings

If you record changes, save multiple versions, or include hidden information or notes in your documents, and you do not want some of the recipients to see that information, you can set warnings to remind you to remove it, or you can have AOO remove some of it automatically. Note that (unless removed) much of this information is retained in a file whether the file is in AOO’s default OpenDocument format, or has been saved to other formats, including PDF.
Click the **Options** button to open a separate dialog with specific choices (Figure 290).

**Macro security**
Click the **Macro Security** button to open the Macro Security dialog (not shown here), where you can adjust the security level for executing macros and specify trusted sources.

**Security options and warnings**
The following options are on the Security options and warnings dialog (Figure 290).

**Remove personal information on saving**
Select this option to always remove user data from the file properties when saving the file. To manually remove personal information from specific documents, deselect this option and then use the **Delete** button under **File > Properties > General**.
**Ctrl-click required to follow hyperlinks**

In older versions of OpenOffice.org, clicking on a hyperlink in a document opened the linked document. Now you can choose whether to keep this behavior (by unchecking this box). Many people find creation and editing of documents easier when accidental clicks on links do not activate the links.

The other options on this dialog should be self-explanatory.

**Appearance options**

Writing, editing, and (especially) page layout are often easier when you can see the page margins (text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that are different from AOO's defaults for such items as note indicators or field shadings.

On the OpenOffice.org – Appearance page, you can specify which items are visible and the colors used to display various items.

**Figure 291: Showing or hiding text, object, and table boundaries**

- To show or hide items such as text boundaries, select or deselect the options next to the names of the items.
- To change the default colors for items, click the down-arrow in the *Color Setting* column by the name of the item and select a color from the pop-up box.
- To save your color changes as a color scheme, click *Save*, type a name in the *Scheme* box; then click *OK*.

**Accessibility options**

Accessibility options include whether to allow animated graphics or text, how long help tips remain showing, some options for high contrast display, and a way to change the font for the user interface of the OpenOffice.org program.

Accessibility support relies on Sun Microsystems Java technology for communications with assistive technology tools. See "Java options" below. The *Support assistive technology tools* option
is not shown on all AOO installations. See Assistive Tools in OpenOffice.org in the Help for other requirements and information.

Select or deselect the options as required.

![Miscellaneous options](image)

**Figure 292: Choosing accessibility options**

**Java options**

If you install or update a Java Runtime Environment (JRE) after you install OpenOffice.org, or if you have more than one JRE installed on your computer, you can use the OpenOffice.org – Java options page to choose the JRE for AOO to use.

If you are a system administrator, programmer, or other person who customizes JRE installations, you can use the Parameters and Class Path pages (reached from the Java page) to specify this information.

If you do not see anything listed in the middle of the page, wait a few minutes while AOO searches for JREs on the hard disk.

If AOO finds one or more JREs, it will display them there. You can then select the **Use a Java runtime environment** option and (if necessary) choose one of the JREs listed.

![Java options](image)

**Figure 293: Choosing a Java runtime environment**
**Online Update options**

On the OpenOffice.org – Online Update page, you can choose whether and how often to have AOO check the AOO website for program updates. If the **Check for updates automatically** option is selected, an icon appears at the right-hand end of the menu bar when an update is available. Click this icon to open a dialog where you can choose to download the update.

If the **Download updates automatically** option is selected, the download starts when you click the icon. To change the download destination, click the **Change** button and select the required folder in the file browser window.

**Choosing options for loading and saving documents**

You can set the Load/Save options to suit the way you work.

If the Options dialog is not already open, click **Tools > Options**. Click the expansion symbol (+ or triangle) to the left of **Load/Save**.

**General Load/Save options**

Most of the choices on the Load/Save – General page are familiar to users of other office suites. Some items of interest are described below.
Figure 296: Choosing Load and Save options

**Load user-specific settings with the document**
When you save a document, certain settings are saved with it. Some settings (printer name, data source linked to the document) are always loaded with a document, whether or not this option is selected. If you select this option, these document settings are overruled by the user-specific settings of the person who opens it. If you deselect this option, the user’s personal settings do not overrule the settings in the document. For example, your choice (in the options for Writer) of how to update links is affected by the Load user-specific settings option.

**Load printer settings with the document**
If this option is not selected, the printer settings that are stored with the document are ignored when you print it using the Print File Directly icon. The default printer in your system will be used instead.

**Edit document properties before saving**
If you select this option, the Document Properties dialog pops up to prompt you to enter relevant information the first time you save a new document (or whenever you use Save As).

**Save AutoRecovery information every**
Choose whether to enable AutoRecovery and how often to save the information used by the AutoRecovery process.

AutoRecovery in AOO overwrites the original file. If you also choose Always create backup copy, the original file then overwrites the backup copy. If you have this set, recovering your document after a system crash will be easier; but recovering an earlier version of the document may be harder.

**Save URLs relative to file system / internet**
Relative addressing to a file system is only possible if the source document and the referenced document are both on the same drive. A relative address always starts from the directory in which the current document is located. It is recommended to save relatively if you want to create a directory structure on an Internet server.
Default file format and ODF settings

**ODF format version.** AOO by default saves documents in OpenDocument Format (ODF) version 1.2 Extended. While this allows for improved functionality, there may be backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an earlier version of OpenOffice.org (using ODF 1.0/1.1), some of the advanced features may be lost. Two notable examples are cross-references to headings and the formatting of numbered lists. If you plan to share documents with people who are still using older versions of OpenOffice.org, save the document using ODF version 1.0/1.1.

**Size optimization for ODF format.** OpenOffice.org documents are XML files. When you select this option, AOO writes the XML data without indents and line breaks. If you want to be able to read the XML files in a text editor in a structured form, deselect this option.

**Document type.** If you routinely share documents with users of Microsoft Office, you might want to change the *Always save as* attribute for documents to one of the Microsoft Office formats.

---

**Note**

Although AOO can open files in the .docx, .xlsx, and .pptx formats produced by Microsoft Office 2007, it cannot save in those formats. This capability is planned for a future release.

---

VBA Properties Load/Save options

On the Load/Save – VBA Properties page, you can choose whether to keep any macros in Microsoft Office documents that are opened in OpenOffice.org.

![VBA Properties Load/Save options](image)

*Figure 297: Choosing Load/Save VBA Properties*

- If you choose **Save original Basic code**, the macros will not work in AOO but are retained if you save the file into Microsoft Office format.
- If you choose **Load Basic code to edit**, the changed code is saved in an AOO document but is not retained if you save into a Microsoft Office format.
- If you are importing a Microsoft Excel file containing VBA code, you can select the option **Executable code**. Whereas normally the code is preserved but rendered inactive (if you inspect it with the StarBasic IDE you will notice that it is all commented), with this option the code is ready to be executed.
Microsoft Office Load/Save options

On the Load/Save – Microsoft Office page, you can choose what to do when importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents such as spreadsheets or equations).

Select the [L] options to convert Microsoft OLE objects into the corresponding OpenOffice.org OLE objects when a Microsoft document is loaded into AOO (mnemonic: “L” for “load”).

Select the [S] options to convert OpenOffice.org OLE objects into the corresponding Microsoft OLE objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

![Figure 298: Choosing Load/Save Microsoft Office options](image)

HTML compatibility Load/Save options

Choices made on the Load/Save – HTML Compatibility page affect HTML pages imported into OpenOffice.org and those exported from AOO. See HTML documents; importing/exporting in the Help for more information.

![Figure 299. Choosing HTML compatibility options](image)
Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to <font size=7> tags, if they are used in the HTML pages. (Many pages no longer use these tags.)

Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator characters differ according to the locale of the HTML page. The clipboard, however, contains no information about the locale. If this option is not selected, numbers will be interpreted according to the Language - Locale setting in Tools > Options > Language Settings > Languages (see page 287). If this option is selected, numbers will be interpreted as for the English (USA) locale.

Import - Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by AOO to be imported as fields. For an opening tag, an HTML_ON field will be created with the value of the tag name. For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the HTML export.

Import - Ignore font settings
Select this option to have AOO ignore all font settings when importing. The fonts that were defined in the HTML Page Style will be used.

Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If OpenOffice.org Writer is selected, specific OpenOffice.org Writer instructions are exported.

Export - OpenOffice.org Basic
Select this option to include OOo Basic macros (scripts) when exporting to HTML format. You must activate this option before you create the OpenOffice.org Basic macro; otherwise the script will not be inserted. OpenOffice.org Basic macros must be located in the header of the HTML document. Once you have created the macro in the OpenOffice.org Basic IDE, it appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose Tools > Customize > Events. See Chapter 13 (Getting Started with Macros) for more information.

Export - Display warning
When the OpenOffice.org Basic option (see above) is not selected, the Display warning option becomes available. If the Display warning option is selected, then when exporting to HTML a warning is shown that OpenOffice.org Basic macros will be lost.

Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities are only effective if print layout export is activated.

Export - Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when uploading using FTP.

Export - Character set
Select the appropriate character set for the export.
Choosing language settings

You may need to do several things to set the language settings to what you want:

- Install the required dictionaries
- Change some locale and language settings
- Choose spelling options

Install the required dictionaries

AOO automatically installs several dictionaries with the program. To add other dictionaries, be sure you are connected to the Internet, and then use Tools > Language > More Dictionaries Online. AOO will open your default web browser to a page containing links to additional dictionaries that you can install. Follow the prompts to select and install the ones you want.

Change locale and language settings

You can change some details of the locale and language settings that AOO uses for all documents, or for specific documents.

In the Options dialog, click Language Settings > Languages.

![Language Setting Options](Figure 300: Language Setting Options)

On the right-hand side of the Language Settings – Languages page (Figure 296), change the User interface, Locale setting, Default currency, and Default languages for documents as required. In the example, English (UK) has been chosen for all the appropriate settings.

If you want the language (dictionary) setting to apply to the current document only, instead of being the default for all new documents, select the option labelled For the current document only.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese, Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew, and Arabic. If you choose either of these options, the next time you open this dialog, you will see some extra choices under Language Settings, as shown in Figure 295. These choices (Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

![Extra pages available when enhanced language support options are selected](Figure 301: Extra pages available when enhanced language support options are selected)
Choose spelling options

To choose the options for checking spelling, click Language Settings > Writing Aids. In the Options section of the page (Figure 303), choose the settings that are useful for you.

Some considerations:
• If you do not want spelling checked while you type, deselect **Check spelling as you type** and select **Do not mark errors**. (To find the second item, scroll down in the Options list.)

• If you use a custom dictionary that includes words in all upper case and words with numbers (for example, AS/400), select **Check uppercase words** and **Check words with numbers**.

• **Check special regions** includes headers, footers, frames, and tables when checking spelling.

Here you can also check which user-defined (custom) dictionaries are active by default, and add or remove dictionaries, by clicking the **New** or **Delete** buttons.

---

**Note**

OpenOffice.org does not have a grammar checker, but you can install a grammar checker extension such as Language Tool and access that tool from **Tools > Spelling and Grammar**. See “Adding functionality with extensions” on page 299 for more information.

---

### Choosing Internet options

Use the Internet Options pages to define search engines and save proxy settings for use with OpenOffice.org.

If you are using a Netscape or Mozilla browser (such as Firefox), you can enable the Browser Plug-in so you can open AOO files in your browser, print them, save them, and work with them in other ways.

If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page of E-mail options is available, where you can specify the e-mail program to use when you send the current document as e-mail. Under Windows the operating system’s default e-mail program is always used.

![Figure 304: Internet options, showing E-mail page available to Linux and Mac OS X users.](image)

### Controlling AOO’s AutoCorrect functions

Some people find some or all of the items in AOO’s AutoCorrect function annoying because they change what you type when you do not want it changed. Many people find some of the AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click **Tools > AutoCorrect Options**. (You need to have a document open for this menu item to appear.)

In Writer, this dialog has five tabs, as shown in Figure 305. In other components of AOO, the dialog has only four tabs.
Customizing Apache OpenOffice

You can customize menus, toolbars, and keyboard shortcuts in OpenOffice.org, add new menus and toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.

Other customizations are made easy by extensions that you can install from the OpenOffice.org website or from other providers.

Note

Customizations to menus and toolbars can be saved in a template. To do so, first save them in a document and then save the document as a template as described in Chapter 2 (Styles and Templates).

Customizing menus

You can add and rearrange items on the menu bar, add items to menus, and make other changes.

To customize menus:

1) Choose Tools > Customize.
2) On the Customize dialog, go to the Menus page.
3) In the Save In drop-down list, choose whether to save this changed menu for the application (for example, OpenOffice.org Writer) or for a selected document (for example, MyDoc.odt).
4) In the section **OpenOffice.org [name of the program (example: Writer)] Menus**, select from the **Menu** drop-down list the menu that you want to customize. The list includes all the main menus as well as submenus (menus that are contained under another menu). For example, in addition to **File**, **Edit**, **View**, and so on, there is **File | Send** and **File | Templates**. The commands available for the selected menu are shown in the central part of the dialog.

5) To customize the selected menu, click on the **Menu** or **Modify** buttons. You can also add commands to a menu by clicking on the **Add** button. These actions are described in the following sections. Use the up and down arrows next to the **Entries** list to move the selected menu item to a different position.

6) When you have finished making all your changes, click **OK** (not shown in illustration) to save them.

**Creating a new menu**

In the Customize dialog, click **New** to display the dialog shown in Figure 307.

1) Type a name for your new menu in the **Menu name** box.

2) Use the up and down arrow buttons to move the new menu into the required position on the menu bar.

3) Click **OK** to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a command to a menu” on page 293.
Modifying existing menus

To modify an existing menu, select it in the Menu list and click the Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the entries in the Menu list. For example, Rename and Delete are not available for the menus supplied by AOO.

To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure 307 (but without the Menu name box) opens. Use the up and down arrow buttons to move the menu into the required position.

To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the arrow keys to move it up or down in the sequence.

In addition to renaming, you can specify a keyboard shortcut that allows you to select a menu command when you press Alt+ an underlined letter in a menu command.

1) Select a menu entry.
2) Click the Modify button and select Rename.
3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to select the Save All command by pressing Alt+V (after opening the File menu using Alt+F), enter Sa~ve All.

Caution

Be careful when using these shortcuts. In the example above, if the File menu is not already open, then pressing Alt+V opens the View menu; if some other menu is open, Alt+V might activate some other command.
Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of
the dialog.

On the Add Commands dialog (Figure 308), select a category and then the command, and click
Add. The dialog remains open, so you can select several commands. When you have finished
adding commands, click Close. Back on the Customize dialog, you can use the up and down
arrow buttons to arrange the commands in your preferred sequence.

![Figure 308: Adding a command to a menu](image)

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.

To begin, select the menu or submenu in the Menu list near the top of the Customize page, then
select the entry in the Entries list under Menu Content. Click the Modify button and choose the
required action from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a separator line after the
highlighted entry.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar, as described in Chapter 1 (Introducing OpenOffice.org). This
section describes how to create new toolbars and add other icons (commands) to the list of those
available on a toolbar.
To get to the toolbar customization dialog, do any of the following:

- On the toolbar, click the arrow at the end of the toolbar and choose **Customize Toolbar**.
- Choose **View > Toolbars > Customize** from the menu bar.
- Choose **Tools > Customize** from the menu bar and pick the **Toolbars** page (Figure 309).

To customize toolbars:

1. In the Save In drop-down list, choose whether to save this changed toolbar for the application (for example, Writer) or for a selected document.
2. In the section **OpenOffice.org <name of the program (example: Writer)> Toolbars**, select from the **Toolbar** drop-down list the toolbar that you want to customize.
3. You can create a new toolbar by clicking on the **New** button, or customize existing toolbars by clicking on the **Toolbar** or **Modify** buttons, and add commands to a toolbar by clicking on the **Add** button. These actions are described below.
4. When you have finished making all your changes, click **OK** to save them.

![Screenshot of the Customize dialog](image)

**Figure 309. The Toolbars page of the Customize dialog**

**Creating a new toolbar**

To create a new toolbar:

1. Choose **Tools > Customize > Toolbars** from the menu bar.
2. Click **New**. On the Name dialog, type the new toolbar's name and choose from the Save In drop-down list where to save this changed menu: for the application (for example, Writer) or for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new toolbar, you need to add some commands to it, as described below.
Adding a command to a toolbar

If the list of available buttons for a toolbar does not include all the commands you want on that toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.

1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click the Add button in the Toolbar Content section of the dialog.
2) The Add Commands dialog is the same as for adding commands to menus (Figure 308). Select a category and then the command, and click Add. The dialog remains open, so you can select several commands. When you have finished adding commands, click Close. If you insert an item which does not have an associated icon, the toolbar will display the full name of the item: the next section describes how to choose an icon for a toolbar command.
3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the commands in your preferred sequence.
4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign it to the command.

![Change Icon dialog](image)

Figure 310: Change Icon dialog
To use a custom icon, create it in a graphics program and import it into AOO by clicking the Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in size and cannot contain more than 256 colors.

**Example: Adding a Fax icon to a toolbar**

You can customize OpenOffice.org so that a single click on an icon automatically sends the current document as a fax.

1) Be sure the fax driver is installed. Consult the documentation for your fax modem for more information.

2) Choose **Tools > Options > OpenOffice.org Writer > Print**. The dialog shown in Figure 311 opens.

3) Select the fax driver from the **Fax** list and click **OK**.

4) Click the arrow icon at the end of the Standard toolbar. In the drop-down menu, choose **Customize Toolbar**. The Toolbars page of the Customize dialog appears (Figure 309). Click **Add**.

5) On the Add Commands dialog (Figure 312), select **Documents** in the Category list, then select **Send Default Fax** in the Commands list. Click **Add**. Now you can see the new icon in the Commands list.

6) In the Commands list, click the up or down arrow button to position the new icon where you want it. Click **OK** and then click **Close**.

Your toolbar now has a new icon to send the current document as a fax.
Assigning shortcut keys

In addition to using the built-in keyboard shortcuts (listed in the included Help), you can define your own. You can assign shortcuts to standard AOO functions or your own macros and save them for use with the entire Apache OpenOffice suite.

Caution

Be careful when reassigning your operating system’s or AOO’s predefined shortcut keys. Many key assignments are universally understood shortcuts, such as F1 for Help, and are always expected to provide certain results. Although you can easily reset the shortcut key assignments to the AOO defaults, changing some common shortcut keys can cause confusion, frustration and possible data loss or corruption, especially if other users share your computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.

1) Select Tools > Customize > Keyboard. The Customize dialog opens.
2) To have the shortcut key assignment available in all components of OpenOffice.org select the OpenOffice.org button.
3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at the upper right.
5) Click OK to accept the change. Now the chosen shortcut keys will execute the function chosen in step 3 above whenever they are pressed.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys selection box. If the Keys list is empty, it indicates that the chosen key combination is free for use. If it were not, and you wanted to reassign a shortcut key combination that is already in use, you must first delete the existing key.

Shortcut keys that are greyed-out in the listing on the Customize dialog, such as F1 and F10, are not available for reassignment.
**Example: Assigning styles to shortcut keys**

You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.

1) Click **Tools > Customize > Keyboard**. The Keyboard page of the Customize dialog (Figure 313) opens.

![Figure 313. Defining keyboard shortcuts for applying styles](image)

2) To have the shortcut key assignment available only with one component (for example, Writer), select that component's name in the upper right corner of the page; otherwise select **OpenOffice.org** button to make it available to every component.

3) Choose the shortcut keys you want to assign a style to. In this example, we have chosen Ctrl+9.

4) In the **Functions** section at the bottom of the dialog, scroll down in the Category list to **Styles**. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.

5) Choose the category of style. (This example uses a paragraph style, but you can also choose character styles and others.) The **Function** list will display the names of the available styles for the selected category. The example shows some of AOO's predefined styles.
6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.

7) Make any other required changes, and then click OK to save these settings and close the dialog.

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a later time, thus permitting you to create and apply different configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the right of the Customize dialog (Figure 313).

2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an existing file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, otherwise the file will be saved immediately.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load button at the right of the Customize dialog, and then select the configuration file from the Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed; the defaults will be set without any further notice or user input.

Adding functionality with extensions
An extension is a package that can be installed into OpenOffice.org to add new functionality.

Although individual extensions can be found in different places, the official extension repository is at http://extensions.services.openoffice.org/. Some extensions are free of charge; others are available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In AOO, select Tools > Extension Manager from the menu bar. In the Extension Manager dialog (Figure 314), click Add.

3) A file browser window opens. Find and select the extension you want to install and click Open. The extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip
To get extensions that are listed in the repository, you can open the Extension Manager and click the Get more extensions here link.
To install a shared extension, you need write access to the Apache OpenOffice installation directory.

Some popular extensions

This section describes a few of the more important and popular extensions to Apache OpenOffice. In each case, you need to first install the extension as described in the previous section. All tools listed here are open source and free of charge.

PDF Import

Enables you to make minor modifications to the text of existing PDF files when the original source files do not exist or you are unable to open the source files. (Whenever possible, modify the source and regenerate the PDF to obtain the best results.)

When the extension is installed, PDF is listed as a choice in the File Type drop-down list in the File > Open dialog.

Best results can be achieved with the PDF/ODF hybrid file format, which this extension also enables. A hybrid PDF/ODF file is a PDF file that contains an embedded ODF source file. Hybrid PDF/ODF files will be opened in AOO as an ODF file without any layout changes.

Non-hybrid PDF documents open in Draw. Depending on the complexity of the layout, changes may be easy or difficult to make, and the saved result may or may not preserve the original layout. Font substitution may occur.

Documents with more sophisticated layouts, such as those created with professional desktop publishing applications that use special fonts and complex vector graphics, are not suitable for the PDF Import Extension. Similarly, longer documents (> 20 pages) may cause some performance and stability problems.
Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several languages. After you have installed this extension, you will find the templates under File > New > Templates and Documents.

Template Changer (for Writer)
Adds two new items to the File > Templates menu in Writer that allow you to assign a new template to the current document or to a folder of documents. All styles and formatting will be loaded from that template and the document will behave as it was created using that template.

DataPilot Tools for Calc
Adds some utility functions that make using the Calc DataPilot easier:

- Display the current source range for a DataPilot
- Change the source range for a DataPilot
- Refresh all DataPilots on the current sheet
Chapter 12
Open Source, Open Standards, OpenDocument

Introduction

Apache OpenOffice is both a product and an open-source project. If you are new to Apache OpenOffice, its open source development, and the community that produces and supports it, you should read this appendix.

A short history of Apache OpenOffice

The OpenOffice.org project began when Sun Microsystems released the source code for its StarOffice® software to the open source community on October 13, 2000. OpenOffice.org 1.0, the product, was released on April 30, 2002. Major updates to OpenOffice.org included version 2.0 in October 2005 and version 3.0 in October 2008. Since version 2.0, OpenOffice.org has supported the open standard OASIS OpenDocument as its default file format.

On January 26, 2010, Oracle Corporation acquired Sun Microsystems. In June, 2011, Oracle contributed the OpenOffice.org source code to the Apache Software Foundation using the Apache Software Grant Agreement (SGA). This SGA permits the Apache OpenOffice Project Management Committee to re-license the OpenOffice source code under the Apache 2.0 license.

Oracle also transferred to Apache the trademarks and domain names owned by them and associated with the project. After extensive community discussion and comment, the OpenOffice project voted to change the name from "OpenOffice.org" to "Apache OpenOffice".

The new license, the Apache License 2.0, is compatible with the GNU GPLv3 and with the GNU LGPLv3 (the previous license), as well as MPLv2, the new Mozilla license.

The Apache OpenOffice community

Work on Apache OpenOffice is performed by a diverse group of volunteers from over a dozen countries. These volunteers work on coding, testing, documentation, websites, translations, marketing as well as other functions. The Apache OpenOffice community invites contributors. Whatever you do best, you can do it for Apache OpenOffice.
What is “open source”?

The four essential rights of open-source software are embodied within the Free Software Foundation’s General Public License (GPL):

- The right to use the software for any purpose.
- Freedom to redistribute the software for free or for a fee.
- Access to the complete source code of the program (that is, the “blueprints”).
- The right to modify any part of the source, or use portions of it in other programs.

The basic idea behind open source is very simple: When programmers can read, redistribute, and modify the source code for a piece of software, the software evolves. People improve it, people adapt it, people fix bugs.

For more information on Free and Open Source software, visit these websites:

Open Source Initiative (OSI): http://www.opensource.org
Free Software Foundation (FSF): http://www.gnu.org

What are “open standards”?

An open standard provides a means of doing something that is independent of manufacturer or vendor, thus enabling competing software programs to freely use the same file formats. HTML, XML, and ODF are examples of open standards for documents.

An open standard meets the following requirements:

- It is well documented with the complete specification publicly available, either free or at a nominal charge.
- It can be freely copied, distributed and used. The intellectual property of the standard is made irrevocably available on a royalty-free basis.
- It is standardized and maintained in an independent, open forum (also called "standards organization") using an open process.

What is OpenDocument?

OpenDocument (ODF) is an XML-based file format for office documents (text documents, spreadsheets, drawings, presentations and more), developed at OASIS (http://www.oasis-open.org/who/), an independent, international standards group.

Unlike other file formats, ODF is an open standard. It is publicly available, royalty-free, and without legal or other restrictions; therefore ODF files are not tied to a specific office suite and anybody can build a program that interprets these files. For this reason ODF is quickly becoming the preferred file format for government agencies, schools and other companies who prefer not to be too dependent on a particular software supplier.

Apache OpenOffice by default saves documents in Open Document Format. Apache OpenOffice has adopted version 1.2 of the OpenDocument standard. Apache OpenOffice can also open and save many other file formats; see “Error: Reference source not found” on page Error: Reference source not found, “Error: Reference source not found” on page Error: Reference source not found, and “Error: Reference source not found” on page Error: Reference source not found.
OpenDocument filename extensions

The most common filename extensions used for OpenDocument documents are:

- *.odt for word processing (text) documents
- *.ods for spreadsheets
- *.odp for presentations
- *.odb for databases
- *.odg for graphics (vector drawings)
- *.odf for formulas (mathematical equations)

File formats Apache OpenOffice can open

Apache OpenOffice can open a wide variety of file formats in addition to the OpenDocument formats.

Opening text documents

In addition to OpenDocument formats (.odt, .ott, .oth, and .odm), Writer 3 can open the formats used by OpenOffice.org 1.x (.sxw, .stw, and .sxg) and the following text document formats:

- Microsoft Word 6.0/95/97/2000/XP (.doc and .dot)
- Microsoft Word 2003 XML (.xml)
- Microsoft Word 2007 XML (.docx, .docm, .dotx, .dotm)
- Microsoft WinWord 5 (.doc)
- WordPerfect Document (.wpd)
- WPS 2000/Office 1.0 (.wps)
- Rich Text Format (.rtf)
- Text CSV (.csv and .txt)
- StarWriter formats (.sdw, .sgl, .vor)
- DocBook (.xml)
- Unified Office Format text (.uot, .uof)
- Ichitaro 8/9/10/11 (.jtd and .jtt)
- Hangul WP 97 (.hwp)
- T602 Document (.602, .txt)
- AportisDoc (Palm) (.pdb)
- Pocket Word (.psw)
- HTML Document (.htm, .html)

Most of these file types are automatically detected by Apache OpenOffice, so they can be opened without explicitly selecting the document type in the file picker.

When opening .htm or .html files (used for web pages), Apache OpenOffice customizes Writer for working with these files.

 Opening spreadsheets

In addition to OpenDocument formats (.ods and .ots), Calc 3 can open the formats used by OpenOffice.org 1.x (.sxc and .stc) and the following spreadsheet formats:

- Microsoft Excel 97/2000/XP (.xls, .xlsx, and .xltx)
- Microsoft Excel 4.x–5.0/95 (.xls, .xlsx, and .xltx)
- Microsoft Excel 2003 XML (.xml)
- Microsoft Excel 2007 XML (.xlsx, .xlsm, .xlts, .xltm)
- Microsoft Excel 2007 binary (.xlsxb)
Lotus 1-2-3 (.wk1, .wks, and .123)
Data Interchange Format (.dif)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarCalc formats (.sdc and .vor)
dBASE (.dbf)
SYLK (.slk)
Unified Office Format spreadsheet (.uos, .uof)
HTML Document (.htm and .html files, including Web page queries)
Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)

**Opening presentations**
In addition to OpenDocument formats (.odp, .odg, and .otp), Impress 3 can open the formats used by OpenOffice.org 1.x (.sxi and .sti) and the following presentation formats:

- Microsoft PowerPoint 97/2000/XP (.ppt and .pot)
- Microsoft PowerPoint 2007 (.pptx, .pptm, .potx, .potm)
- StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
- Unified Office Format presentation (.uop, .uof)
- CGM – Computer Graphics Metafile (.cgm)
- Portable Document Format (.pdf)

**Opening graphic files**
In addition to OpenDocument formats (.odg and .otg), Draw 3 can open the formats used by OpenOffice.org 1.x (.sxd and .std) and the following graphic formats:

<table>
<thead>
<tr>
<th>Format</th>
<th>Format</th>
<th>Format</th>
<th>Format</th>
<th>Format</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMP</td>
<td>JPEG, JPG</td>
<td>PCX</td>
<td>PSD</td>
<td>SGV</td>
<td>WMF</td>
</tr>
<tr>
<td>DXF</td>
<td>MET</td>
<td>PGM</td>
<td>RAS</td>
<td>SVM</td>
<td>XBM</td>
</tr>
<tr>
<td>EMF</td>
<td>PBM</td>
<td>PLT</td>
<td>SDA</td>
<td>TGA</td>
<td>XPM</td>
</tr>
<tr>
<td>EPS</td>
<td>PCD</td>
<td>PNG</td>
<td>SDD</td>
<td>TIF, TIFF</td>
<td></td>
</tr>
<tr>
<td>GIF</td>
<td>PCT</td>
<td>PPM</td>
<td>SGF</td>
<td>VOR</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Opening formula files**
In addition to OpenDocument Formula (.odf) files, Math 3 can open the format used by OpenOffice.org 1.x (.sxm), StarMath, (.smf), and MathML (.mml) files.

When opening a Word document that contains an embedded equation editor object, if the option for it (MathType to OpenOffice.org Math/ OpenOffice.org to MathType) is checked in **Tools > Options > Load/Save > Microsoft Office**, the object will be automatically converted to an OpenOffice.org Math object.

**File formats Apache OpenOffice can save to**
Saving in an OpenDocument format guarantees the correct rendering of the file when it is transferred to another person or when the file is re-opened with a later version of OpenOffice.org. It is strongly recommended that you use ODF as default file format. However, you can save files in other formats, if you wish.

**Tip**
When sharing a document that you do not expect or want the recipient to modify, the safest option is to convert the document to PDF. AOO provides a very straightforward way to convert documents to PDF. See Chapter 9 (Printing, Exporting, and E-Mailing).
Saving text documents

In addition to OpenDocument formats (.odt and .ott), Writer 3 can save in these formats:

- OpenOffice.org 1.x Text Document (.sxw)
- OpenOffice.org 1.x Text Document Template (.stw)
- Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
- Microsoft Word 2003 XML (.xml)
- Rich Text Format (.rtf)
- StarWriter 3.0, 4.0, and 5.0 (.sdw)
- StarWriter 3.0, 4.0, and 5.0 Template (.vor)
- Text (.txt)
- Text Encoded (.txt)
- Unified Office Format text (.uot, .uof)
- HTML Document (OpenOffice.org Writer) (.html and .htm)
- DocBook (.xml)
- AportisDoc (Palm) (.pdb)
- Pocket Word (.psw)

Encryption support within the Microsoft Word 97/2000/XP filter allows password protected Microsoft Word documents to be saved.

**Note**
The .rtf format is a common format for transferring text files between applications, but you are likely to experience loss of formatting and images. For this reason, other formats should be used.

Saving spreadsheet files

In addition to OpenDocument formats (.ods and .ots), Calc 3 can save in these formats:

- OpenOffice.org 1.x Spreadsheet (.sxc)
- OpenOffice.org 1.x Spreadsheet Template (.stc)
- Microsoft Excel 97/2000/XP (.xls and .xlw)
- Microsoft Excel 97/2000/XP Template (.xlt)
- Microsoft Excel 5.0 and 95 (.xls and .xlw)
- Microsoft Excel 2003 XML (.xml)
- Data Interchange Format (.dif)
- dBase (.dbf)
- SYLK (.slk)
- Text CSV (.csv and .txt)
- StarCalc 3.0, 4.0, and 5.0 formats (.sdc and .vor)
- Unified Office Format spreadsheet (.uos)
- HTML Document (OpenOffice.org Calc) (.html and .htm)
- Pocket Excel (.pxl)

**Note**
The Java Runtime Environment is required to use the mobile device filters for AportisDoc (Palm), Pocket Word, and Pocket Excel.

Saving drawings

Draw 3 can only save in the OpenDocument Drawing formats (.odg and .otg), the OpenOffice.org 1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, and .vor).

However, Draw can also export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG, PPM, RAS, SVG, SVM, TIFF, WMF, and XPM.
Saving presentations
In addition to OpenDocument formats (.odp, .otp, and .odg), Impress 3 can save in these formats:

- OpenOffice.org 1.x Presentation (.sxi)
- OpenOffice.org 1.x Presentation Template (.sti)
- Microsoft PowerPoint 97/2000/XP (.ppt)
- Microsoft PowerPoint 97/2000/XP Template (.pot)
- StarDraw, StarImpress (.sda, .sdd, and .vor)
- Unified Office Format presentation (.uop)

Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats listed for
Draw.

Saving from Writer/Web
Writer/Web can save in these formats:
- HTML document (.html and .htm), as HTML 4.0 Transitional
- OpenOffice.org 1.0 HTML Template (.stw)
- OpenOffice.org 2.x HTML Template (.oth)
- StarWriter/Web 4.0 and 5.0 (.vor)
- Text (OpenOffice.org Writer/Web) (.txt)
- Text Encoded (OpenOffice.org Writer/Web) (.txt)

Exporting to other formats
Apache OpenOffice uses the term “export” for some file operations involving a change of file type.
If you cannot find what you want under Save As, look under Export as well.

AOO can export files to XHTML. In addition, Draw and Impress can export to Adobe Flash (.swf)
and a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file name
for the exported document, then select the required format in the File format list and click the
Export button.
## Index

### 3
- 3D objects 170

### A
- accepting or rejecting changes 75
- accessibility options 280
- advantages of Apache OpenOffice 11
- antialiasing screen font 273
- appearance options 280
- Apply Style list 34
- area fill, editing 166
- arranging objects 162
- arrow styles, customizing 166
- arrows 165
- Asian language support 287
- AutoCorrect 61, 289
- AutoFormat, Calc 106
- AutoInput 98
- AutoLayout 134
- automatic changes 98
- automatic saving 25
- AutoRecovery 25, 283
- AutoUpdate styles 35

### B
- background images from Gallery 257
- bitmaps 170
- book preview 241
- booklet printing 239
- bookmarks 76
- borders, editing 165
- brackets (Math) 229
- bring forward 162
- brochure printing 239
- bulleted list 136
- Bullets and Numbering dialog 138

### C
- Calc
  - AutoFormat 106
  - editing data 101
  - Enter key, use of 86
  - features 79
  - filtering visible cells 109
  - formula bar 81
  - Function Wizard 81
  - hiding and showing data 108
  - Navigator 85
  - outline group controls 108
  - printing 111
  - sheet tabs 81
- combining objects 170
- comma separated values (CSV) 82, 84
- comments
  - Draw 171
- comments, adding 70
- complex text layout (CTL) 287
- components of OpenOffice.org 15
- conditional formatting 108
- connectors 159
- content boxes (Impress) 132
- context menu 165
- context menus 21
- conversion 170
- copy and paste 55
- copying object from Gallery 256
- create document from template 39
- creating a document 23
- cross-fading 168
- cross-references
  - inserting references 76
  - overview 76
- CSV file
  - open 83
  - save 84
- CSV files 82, 84
- sorting records 109
- splitting the screen 94
- status bar 82
- themes 107
- viewing 93
- callouts 161
- cells, in Calc
  - formatting 102
  - navigating 84
  - selecting 88
- change tracking 74
- changes, undo and redo 28
- check for updates automatically 282
- circle, drawing 157
- clipboard 274
- closing a document 25
- closing OpenOffice.org 26
- CMYK 152
- Color Bar 152
- color options 276
- color palette 153
- color scheme 280
- columns, in Calc
  - deleting 90
  - freezing 93
  - inserting 90
  - selecting 88
- combining objects 170
- comma separated values (CSV) 82, 84
- comments
  - Draw 171
- comments, adding 70
- complex text layout (CTL) 287
- components of OpenOffice.org 15
- conditional formatting 108
- connectors 159
- content boxes (Impress) 132
- context menu 165
- context menus 21
- conversion 170
- copy and paste 55
- copying object from Gallery 256
- create document from template 39
- creating a document 23
- cross-fading 168
- cross-references
  - inserting references 76
  - overview 76
- CSV file
  - open 83
  - save 84
- CSV files 82, 84
- sorting records 109
- splitting the screen 94
- status bar 82
- themes 107
- viewing 93
- callouts 161
- cells, in Calc
  - formatting 102
  - navigating 84
  - selecting 88
- change tracking 74
- changes, undo and redo 28
- check for updates automatically 282
- circle, drawing 157
- clipboard 274
- closing a document 25
- closing OpenOffice.org 26
- CMYK 152
- Color Bar 152
- color options 276
- color palette 153
- color scheme 280
- columns, in Calc
  - deleting 90
  - freezing 93
  - inserting 90
  - selecting 88
- combining objects 170
- comma separated values (CSV) 82, 84
- comments
  - Draw 171
- comments, adding 70
- complex text layout (CTL) 287
- components of OpenOffice.org 15
- conditional formatting 108
- connectors 159
- content boxes (Impress) 132
- context menu 165
- context menus 21
- conversion 170
- copy and paste 55
- copying object from Gallery 256
- create document from template 39
- creating a document 23
- cross-fading 168
- cross-references
  - inserting references 76
  - overview 76
- CSV file
  - open 83
  - save 84
- CSV files 82, 84
Ctrl-click required to follow hyperlinks 280
curves, Draw 159
custom dictionary 289
customizing
   keyboard shortcuts 297
   menus 290
   toolbars 293
cut and paste 55
D
dashes 58
data editing, Calc
   changing data in a cell 102
   removing data from a cell 101
   replacing all data in a cell 102
data entry, Calc
   dates and times 97
   fill series 99
   Fill tool 98
   numbers 96
   numbers as text 97
   selection lists 101
   speeding up 98
   text 97
   validating cell contents 101
data source
   description 173
   editing 200
   linking 199
   registering 199
   using in OOo documents 200
   viewing 200
data validity 101
database
   AutoValue 180
   creating 175
   creating tables 176
   field types and formats 177
   list table 183
   planning 174
   primary key 176, 178, 180
   registering 199
   Report Wizard 214
   Table Wizard 176
   tables 176
database form
   activation order 198
   background 196
   creating in Design View 198
   creating using a Wizard 185
   entering data 203
   modifying 188
   subform 186
   tab order 198
database reports
   creating 213
   modifying 218
   static 213
database table
   create using wizard 176
   dynamic 216
   joined fields 187
   relationships 183
DataPilot Tools 301
date conversion, automatic 98
default file format 284
default template 44
derivative markup (Math) 230
Design View (Base)
   creating a new table 179
   creating forms 198
   creating queries 208
dictionaries, installing 287
dictionary 60
different first page 47
digital rights management (DRM) 246
digital signature 252
distorting an image 167
divide document into chapters 47
dockable window 20
document
   closing 25
   create from template 39
   creating 23
   opening 23
   starting new 23
document status option 271
document views 52
download updates automatically 282
downloading OpenOffice.org 16
drag and drop 253
Draw 171
   features 149
   status bar 151
   toolbars 151
drawing
   circle or ellipse 157
duplication 168
Flash export 171
HTML export 171
inserting pictures 170
line 156
rectangle 157
save in a foreign format 171
Drawing Object Properties toolbar 262
drawing objects
   3D objects 170
   grouping 263
   grouping and combining 169
   positioning 170
properties 262
Drawing toolbar 152, 262
drawing tools 261
duplication 168
dynamic gradients 167

E
E-mail options 289
e-mailing
  Mail Merge Wizard 249
  several recipients 249
  Writer document as attachment 248
edit document properties before saving 283
editing data, Calc 101
ellipse, drawing 157
en-dash and em-dash 58
envelope
  printing 240
  envelope printing 240
EPS images in PDF 243
equation
  inserting 221
  numbering 231
equation editor 221
  brackets 229
  derivative markup 230
  Elements window 222
  equations over more than one line 229
  floating window 227
  font size 228
  formula layout 229
  limits to sum/integral 229
  markup 224
  matrix markup 230
  right-click menu 224
export directly as PDF 242
export HTML 286
exporting
  Flash 248
  PDF 242
  XHTML 248
extended tips 271
Extension Manager 43
extensions 299
  DataPilot Tools 301
extensions and addons
  sources of 16

F
fax icon, adding to toolbar 296
FDF 244
features
  Calc 79
  Draw 149
  Impress 119
  Writer 49
fields
  bookmarks 76
  cross-reference 76
Fields dialog box
  References tab 77
file locations 275
file sharing options 278
Fill Format 33
Fill tool, Calc 98
fill, editing 166
filtering visible cells, Calc 109
flip an object 167
floating toolbars 19, 20
floating window 20
flowchart symbols 161
font
  history 274
  ignore settings when importing HTML 286
  options 278
  preview 273
  replacement table 278
  replacements 278
  sizes for HTML 286
font resizing (Impress) 136
Fontwork
  alignment 265
  anchoring 267
  area options 267
  attributes 266
  character spacing 266
  creating an object 264
  editing an object 265
  Formatting toolbar 266
  Gallery 264
  grouping 267
  line options 266
  moving and resizing objects 268
  positioning options 267
  same letter heights 265
  toolbar 263, 265
Form Wizard 185
formatting pages 66
Formatting toolbar 19
formatting, Calc
  AutoFormat 106
  conditional 108
  themes 107
formula bar, Calc 81
formula editor
  See: equation editor 227
formula files, opening 306
formula layout 229
Free Software Foundation (FSF) 304
freeform line, Draw 158
Function Wizard, Calc 81

G

Gallery
adding objects 258
creating a new theme 259
deleting images 259
deleting objects 259
hide/show 257
inserting object as background 257
location 259
opening 256
themes 257
views (icon/detailed) 257
genral options 270
gerometric shapes, Draw 160
gluepoints 160
GNU/Linux
system requirements 16
gradients 167
grammar checker 60
graphic files
opening 306
saving 307
graphic styles
formatting text 136
graphics
adding from file 253
linking 254
grid options 154
grid points 153
guiding lines 155

H
header
different on right and left pages 48
headers and footers, Calc 115
Help Agent 271
Help system 9
Help Tips 271
hidden objects 162
hiding and showing data, Calc 108
high contrast 271
history of Apache OpenOffice 303
HTML compatibility 285
HTML export 286
hyphenation
manual 66

I
icon size and style (user interface) 273
icons in menus 273
ignore font settings when importing HTML 286
image map 260
images
adding from file 253
linking 254
scanned 256
importing files 305
importing numbers from an HTML page 286
Impress
content boxes 132
features 119
font resizing 136
main window 120
inclination 164
indents 59
indexes and bibliographies 71
Insert Bookmark dialog 77
Insert Picture dialog 253
Internet options 289

J
Java options 281
Java Runtime Environment (JRE) 173
JRE (Java Runtime Environment) 16, 281

K
keyboard shortcuts
assigning 297
customizing 297
loading from a file 299
resetting to default values 299
saving to a file 299

L
landscape pages 47
language settings 287
language support 11
layout methods 66
limits to sum/integral 229
Line and Filling toolbar 151
line properties 165
line, customizing 166
line, drawing 156
lines, editing 165
linking object from gallery 256
Linux
Quickstarter 18
system requirements 16
list table (database) 183
load Basic code to edit 284
load/save options 282
loading styles 38
locale settings 287

M
Mac OS X
system requirements 16
macro security options 279
Index

mail merge 74
Mail Merge Wizard
e-mailing Writer document 249
margins 150
margins (Writer) 69
Master Pages 142
master slides 133, 141
mathematical equations 221
mathematical markup 224
mathematical symbols 221
matrix markup (Math) 230
measurement unit 59
memory options 272
menu bar 19
menus
  adding commands 293
  creating 291
  customizing 290
  modifying 292
  modifying entries 293
Microsoft Office file conversion 285
Microsoft Windows
  file associations 17
  Quickstarter 17
  system requirements 16
middle mouse button function 274
mirror copies 167
mouse positioning 274
MySQL 173

N

navigation
  cell to cell, in Calc 85
  sheet to sheet, in Calc 87
Navigation icons 53
Navigation toolbar 28, 52
Navigator 27, 123
  Calc 85
new document 23
non-breaking hyphen 58
non-breaking spaces 58
nonconsecutive items, selecting 54
numbered list 136
numbering equations 231
numbering pages 68

O

OASIS 11
objects
  adjusting size 163
  arranging 162
dynamic movement 163
dynamic size modification 163
framing 162
hidden 162
moving 163
rotating 163
selecting several 162
ODF format version, saving 284
Office Assistant (Microsoft) 271
online update options 282
Open and Save As dialogs 26
Open Source Initiative (OSI) 304
Open/Save dialogs 271
OpenDocument Format 11, 284
opening a document 23
Options Bar (Draw) 152
orientation of page 47
outline group controls, Calc 108
outline level 137
OXT extension 43

P

page break, Calc 114
page layout
different first page 47
landscape page 47
orientation 47
page layouts 66
page margins 69, 150
page numbering 68
parts of the main window 18
password protection 24
password-protect PDF 246
paste text 56
path options 275
PDF
  blank page export 244
digital rights management (DRM) 246
  embed standard fonts 244
  encrypt 246
  EPS image 243
  export documents to 242
  form 244
  image compression and resolution 243
  initial view selection 244
  pages to export 242
  password-protect 246
  security settings 246
  tagged 244
  user interface settings 244
PDF import 300
PDF Options dialog 242
PDF/A-1a 244
personal data, removing 252
pictures
  adding from file 253
  linking 254
pixels 149
polygons, Draw 158
positioning objects 170
Powerpoint
  See: Impress 119
presentation
  output medium 129
  slide design 129
  transition effect 129
  transitions 129
Presentation Wizard 128
presentations
  saving 308
primary key 178
primary key (database) 178
Print dialog 234
print file directly 233
print options
  general 275
  print preview
    Calc 242
    Writer 241
print ranges, Calc 111
printer settings 283
printing
  black and white on color printer 240
  booklet 239
  brochure 239
  Calc 111, 237
  envelopes, labels, business cards 240
  general options 234
  grayscale on color printer 241
  handouts 239
  headers and footers, Calc 115
  Impress and Draw 238
  multiple pages per sheet 235
  notes (Impress) 239
  page break, Calc 114
  page order, details, scale, in Calc 112
  page orientation 235
  rows or columns on every page 113
  selecting what to print 236
  Writer 236
Professional Template Pack extension 301
Q
queries (database)
  aliases 212
  creating using a Wizard 206
  creating using Design View 208
  joined fields 187
  search conditions 207
Query Wizard (database) 206
Quickstarter 17
  enabling 272
quotation marks 98
R
raster graphics 170
rectangle, drawing 157
redlines 74
redo change 29
regular expressions 56
relationships (database) 183
remove personal information on saving 279
removing personal data 252
replacement table (font) 278
Report Wizard (database) 214
revision marks 74
RGB 152
right-click (context) menus 21
rotating an object 163
rows, in Calc
  deleting 90
  freezing 93
  inserting 90
  selecting 88
rulers (Draw) 150
S
save AutoRecovery information 283
save original Basic code 284
save relative URLs 283
saving files 24
scaling factor (user interface) 273
scanner 256
screen font antialiasing 273
security 24
security options 278
selecting
  nonconsecutive items 54
  vertical block of text 55
selecting objects 161
selection clipboard 274
selection lists, Calc 274
selection, in Calc
  cells 88
  columns 88
  rows 88
  sheets 89
send backward 162
send document as e-mail 249
sequence of styles, automatic 48
setup options 269
shadows 166
shapes, Draw 160
shared extension 300
sheet tabs, Calc 81
sheets, in Calc
  deleting 93
  inserting 91
renaming 93
selecting 89
size optimization 284
slanting an object 164
Slide Design dialog 143
slide master 133, 141
    apply 143
    author information 145
    create 142
slide show
    automatically advance 148
See: presentation 119
    transitions 147
slides
    layouts 131
    master 133, 141
    modifying 133
snap functions 153
Snap to grid 153
sort order (database fields) 206
sorting records, Calc 109
special characters 58, 61
spelling checker 60
spelling options 288
spreadsheet
    using as data source 199
spreadsheets
    cell reference 84
    definition 79
    navigate 84
    opening 305
    saving 307
    saving as CSV 84
Standard toolbar 19
Start Center 23
starting a new document 23
starting OpenOffice.org 17
status bar 22
    Calc 82
    Draw 151
    Impress 122
    Writer 50
Style dialog 35, 36
styles 166
    Apply Style list 34
    assigning to shortcut keys 298
    AutoUpdate 35
    changing using Style dialog 35
    creating by dragging and dropping 37
    creating from selection 36
    creating new 36
    creating using Style dialog 36
    custom 36
    defining a sequence 48
    deleting 39
description 31, 141
    Fill Format 33
    formatting text 136
    linking 36
    loading from template or document 38
    modifying 34
    types supported 31
    updating from a selection 35
Styles and Formatting window 32
Sun Microsystems 303
support 9
system font (user interface) 273
T
tab stops 59
table of contents, automated 71
Table Wizard (database) 176
tear-off toolbars 19
template
    associate with document 44
    create document from 39
    create from document 40
    create using wizard 41
    deleting 46
    description 31
    editing 42
    exporting 46
    Extension Manager 43
    folders 45
    update document styles from 42
    Template Changer extension 301
    Template Management dialog 37
    templates
        importing 46
    text
        bulleted or numbered list 136
        outline level 137
        pasting 136
        text boundaries (show/hide) 280
        text box
            AutoLayout 134, 137
        text documents
            opening 305
        Text Formatting toolbar 136
        text in Draw 159
        text tool 134
        theme
            deleting 259
            themes 257
            themes (Gallery) 259
toolbars 122
    adding commands 295
    choosing icons for commands 295
    Color Bar 152
    creating 294

Index 315
customizing 21
displaying or hiding 19
Draw 151
Drawing 152
Fontwork 263
Line and Filling toolbar 151
moving 20
Options Bar (Draw) 152
overview 19
show or hide icons 21
tooltips 132, 271
track changes 74
transparency 166, 167
two-digit years 271
typing errors, autocorrect 98

U
undo change 28
undoing groups 169
ungrouping 169
unit of measurement 150
unsaved changes flag 51
user data options 270
user interface options 273
user interface, parts of 13
user-specific settings 283

V
validating cell contents, Calc 101
VBA properties load/save options 284
vector graphics 149
vertical block of text, select 55
view options 273

W
wildcards 56
windows, dockable/floating 20
wizard
form (database) 185
presentation 128
query (database) 206
report (database) 214
table (database) 176
workspace
Draw 149
Writer
document views 52
features 49
Navigation icons 53
Navigation toolbar 52
status bar 50
workspace 49
zoom 52

X
XML 284

Y
year (two digits) 271

Z
zoom 52